summaryrefslogtreecommitdiffstats
path: root/recipes/mplayer
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-08 10:03:36 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-08 10:03:36 +0200
commit3a5ed90ae5d9d2cc80ba08a97711441f72c49f56 (patch)
treeef7b9babed330751c8354f51e39ff4ca70d1304a /recipes/mplayer
parentb7e05654818cc8139e241874b075c843ef23e614 (diff)
downloadopenembedded-3a5ed90ae5d9d2cc80ba08a97711441f72c49f56.tar.gz
mplayer: bump SRCREV
Diffstat (limited to 'recipes/mplayer')
-rw-r--r--recipes/mplayer/files/vo_omapfb.c18
-rw-r--r--recipes/mplayer/mplayer_svn.bb5
2 files changed, 20 insertions, 3 deletions
diff --git a/recipes/mplayer/files/vo_omapfb.c b/recipes/mplayer/files/vo_omapfb.c
index 127e550cae..0fb32d811e 100644
--- a/recipes/mplayer/files/vo_omapfb.c
+++ b/recipes/mplayer/files/vo_omapfb.c
@@ -118,6 +118,24 @@ static Window parent = 0; // pointer to the newly created window.
/* This is used to intercept window closing requests. */
static Atom wm_delete_window;
+
+void vo_calc_drwXY(uint32_t *drwX, uint32_t *drwY)
+{
+ *drwX = *drwY = 0;
+ if (vo_fs) {
+ aspect(&vo_dwidth, &vo_dheight, A_ZOOM);
+ vo_dwidth = FFMIN(vo_dwidth, vo_screenwidth);
+ vo_dheight = FFMIN(vo_dheight, vo_screenheight);
+ *drwX = (vo_screenwidth - vo_dwidth) / 2;
+ *drwY = (vo_screenheight - vo_dheight) / 2;
+ mp_msg(MSGT_VO, MSGL_V, "[vo-fs] dx: %d dy: %d dw: %d dh: %d\n",
+ *drwX, *drwY, vo_dwidth, vo_dheight);
+ } else if (WinID == 0) {
+ *drwX = vo_dx;
+ *drwY = vo_dy;
+ }
+}
+
/**
* Function to get the offset to be used when in windowed mode
* or when using -wid option
diff --git a/recipes/mplayer/mplayer_svn.bb b/recipes/mplayer/mplayer_svn.bb
index d26302e65b..d0658372d4 100644
--- a/recipes/mplayer/mplayer_svn.bb
+++ b/recipes/mplayer/mplayer_svn.bb
@@ -8,7 +8,7 @@ DEPENDS = "live555 libdvdread libtheora virtual/libsdl ffmpeg xsp zlib libpng jp
RDEPENDS = "mplayer-common"
LICENSE = "GPL"
SRC_URI = "svn://svn.mplayerhq.hu/mplayer;module=trunk \
- file://Makefile-codec-cfg.patch;patch=1 \
+# file://Makefile-codec-cfg.patch;patch=1 \
file://pld-onlyarm5-svn.patch;patch=1 \
file://makefile-nostrip-svn.patch;patch=1 \
file://configh \
@@ -87,8 +87,6 @@ EXTRA_OECONF = " \
--enable-sortsub \
--disable-fribidi \
--disable-enca \
- --disable-macosx \
- --disable-macosx-bundle \
--disable-ftp \
--disable-vstream \
\
@@ -210,6 +208,7 @@ do_configure() {
sed -i 's|/usr/lib|${STAGING_LIBDIR}|g' ${S}/configure
sed -i 's|/usr/\S*include[\w/]*||g' ${S}/configure
sed -i 's|/usr/\S*lib[\w/]*||g' ${S}/configure
+ sed -i 's|HOST_CC|BUILD_CC|' ${S}/Makefile
export SIMPLE_TARGET_SYS="$(echo ${TARGET_SYS} | sed s:${TARGET_VENDOR}::g)"
./configure ${EXTRA_OECONF}