aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mt-daapd
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mt-daapd
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mt-daapd')
-rw-r--r--recipes/mt-daapd/files/itunes-5-fix.patch45
-rw-r--r--recipes/mt-daapd/files/mt-daapd.init41
-rw-r--r--recipes/mt-daapd/mt-daapd.inc26
-rw-r--r--recipes/mt-daapd/mt-daapd_0.2.1.1.bb3
-rw-r--r--recipes/mt-daapd/mt-daapd_0.2.2.bb4
-rw-r--r--recipes/mt-daapd/mt-daapd_0.2.3.bb4
-rw-r--r--recipes/mt-daapd/mt-daapd_0.2.4.2.bb3
7 files changed, 126 insertions, 0 deletions
diff --git a/recipes/mt-daapd/files/itunes-5-fix.patch b/recipes/mt-daapd/files/itunes-5-fix.patch
new file mode 100644
index 0000000000..e5f597295f
--- /dev/null
+++ b/recipes/mt-daapd/files/itunes-5-fix.patch
@@ -0,0 +1,45 @@
+# WARNING: this is a copy of the same file off www.mt-daapd.org with
+# the path names fixed so that it works in OE
+--- S/src/daap.c.orig 2005-09-07 21:41:41.000000000 -0500
++++ S/src/daap.c 2005-09-07 21:44:25.000000000 -0500
+@@ -770,26 +770,28 @@
+ DAAP_BLOCK *daap_response_server_info(char *name, char *client_version) {
+ DAAP_BLOCK *root;
+ int g=1;
++ int mpro = 2 << 16;
++ int apro = 3 << 16;
+
+ DPRINTF(E_DBG,L_DAAP,"Preparing to send server-info for client ver %s\n",client_version);
+
+ root=daap_add_empty(NULL,"msrv");
+
+ if(root) {
+- g = (int)daap_add_int(root,"mstt",200); /* result */
+- if((!client_version)||(!strcmp(client_version,"3.0"))) {
+- g = g && daap_add_int(root,"mpro",2 << 16); /* dmap proto ? */
+- g = g && daap_add_int(root,"apro",3 << 16); /* daap protocol */
+- } else {
+- if(!strcmp(client_version,"1.0")) {
+- g = g && daap_add_int(root,"mpro",1 << 16); /* dmap proto ? */
+- g = g && daap_add_int(root,"apro",1 << 16); /* daap protocol */
+- } else if(!strcmp(client_version,"2.0")) {
+- g = g && daap_add_int(root,"mpro",1 << 16); /* dmap proto ? */
+- g = g && daap_add_int(root,"apro",2 << 16); /* daap protocol */
+- }
++ if((client_version) && (!strcmp(client_version,"1.0"))) {
++ mpro = 1 << 16;
++ apro = 1 << 16;
++ }
++
++ if((client_version) && (!strcmp(client_version,"2.0"))) {
++ mpro = 1 << 16;
++ apro = 2 << 16;
+ }
+
++ g = (int)daap_add_int(root,"mstt",200); /* result */
++ g = g && daap_add_int(root,"mpro",mpro); /* dmap proto ? */
++ g = g && daap_add_int(root,"apro",apro); /* daap protocol */
++
+ g = g && daap_add_string(root,"minm",name); /* server name */
+
+ #if 0
diff --git a/recipes/mt-daapd/files/mt-daapd.init b/recipes/mt-daapd/files/mt-daapd.init
new file mode 100644
index 0000000000..7a35a72186
--- /dev/null
+++ b/recipes/mt-daapd/files/mt-daapd.init
@@ -0,0 +1,41 @@
+#! /bin/sh
+#
+# This is an init script for openembedded
+# Copy it to /etc/init.d/mt-daapd and type
+# > update-rc.d mt-daapd defaults 60
+#
+
+
+test -f /usr/sbin/mt-daapd || exit 0
+
+test -d /var/spool/mt-daapd || mkdir -p /var/spool/mt-daapd
+
+case "$1" in
+ start)
+ echo -n "Starting mt-daapd daemon: mt-daapd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/mt-daapd
+ echo "."
+ ;;
+ stop)
+ echo -n "Stopping mt-daapd daemon: mt-daapd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/mt-daapd
+ echo "."
+ ;;
+ reload|force-reload)
+ start-stop-daemon --stop --quiet --signal 1 --exec /usr/sbin/mt-daapd
+ ;;
+ restart)
+ echo -n "Stopping mt-daapd daemon: mt-daapd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/mt-daapd
+ sleep 1
+ echo -n "Starting mt-daapd daemon: mt-daapd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/mt-daapd
+ echo "."
+ ;;
+ *)
+ echo "Usage: /etc/init.d/mt-daapd {start|stop|reload|restart|force-reload}"
+ exit 1
+esac
+
+exit 0
+
diff --git a/recipes/mt-daapd/mt-daapd.inc b/recipes/mt-daapd/mt-daapd.inc
new file mode 100644
index 0000000000..859e586cdf
--- /dev/null
+++ b/recipes/mt-daapd/mt-daapd.inc
@@ -0,0 +1,26 @@
+DESCRIPTION = "multi threaded daap server for POSIX Systems: iTunes Server."
+SECTION = "console/network"
+PRIORITY = "optional"
+DEPENDS = "zlib gdbm libid3tag \
+ ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libid3tag', d)}"
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.gz \
+ file://${PN}.init"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "${PN}"
+INITSCRIPT_PARAMS = "defaults 84"
+
+EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes"
+
+do_install() {
+ autotools_do_install
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0644 ${S}/contrib/${PN}.conf ${D}${sysconfdir}
+ install -m 0755 ${WORKDIR}/${PN}.init ${D}${sysconfdir}/init.d/${PN}
+}
+
+CONFFILES_${PN} = "${sysconfdir}/${PN}.conf"
diff --git a/recipes/mt-daapd/mt-daapd_0.2.1.1.bb b/recipes/mt-daapd/mt-daapd_0.2.1.1.bb
new file mode 100644
index 0000000000..e39cd775d7
--- /dev/null
+++ b/recipes/mt-daapd/mt-daapd_0.2.1.1.bb
@@ -0,0 +1,3 @@
+require ${PN}.inc
+PR = "r4"
+SRC_URI += "file://itunes-5-fix.patch;patch=1"
diff --git a/recipes/mt-daapd/mt-daapd_0.2.2.bb b/recipes/mt-daapd/mt-daapd_0.2.2.bb
new file mode 100644
index 0000000000..8145a5892b
--- /dev/null
+++ b/recipes/mt-daapd/mt-daapd_0.2.2.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+# This has not been released yet!
+DEFAULT_PREFERENCE = "-1"
+PR = "r1"
diff --git a/recipes/mt-daapd/mt-daapd_0.2.3.bb b/recipes/mt-daapd/mt-daapd_0.2.3.bb
new file mode 100644
index 0000000000..f6a01e0d80
--- /dev/null
+++ b/recipes/mt-daapd/mt-daapd_0.2.3.bb
@@ -0,0 +1,4 @@
+require ${PN}.inc
+# This has not been released yet!
+#DEFAULT_PREFERENCE = -1
+PR = "r1"
diff --git a/recipes/mt-daapd/mt-daapd_0.2.4.2.bb b/recipes/mt-daapd/mt-daapd_0.2.4.2.bb
new file mode 100644
index 0000000000..9a48668e8a
--- /dev/null
+++ b/recipes/mt-daapd/mt-daapd_0.2.4.2.bb
@@ -0,0 +1,3 @@
+require ${PN}.inc
+
+PR = "r0"