aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mtd/mtd-utils_0.0.0+cvs20041113.bb
diff options
context:
space:
mode:
authorMartin Dietze <mdietze@gmail.com>2013-03-01 23:29:19 +0100
committerMartin Dietze <mdietze@gmail.com>2013-03-02 17:27:30 +0100
commit889579dc45ac2e62b4e41e1508dc96b074bf082d (patch)
treebc74b71685e30f4a3707b9100e750075c1bb7c72 /recipes/mtd/mtd-utils_0.0.0+cvs20041113.bb
parentb01a466d2bbe58e255229d214794b30674ebe579 (diff)
downloadopenembedded-889579dc45ac2e62b4e41e1508dc96b074bf082d.tar.gz
mtd-utils: re-added older version 20041113 for nylon
Diffstat (limited to 'recipes/mtd/mtd-utils_0.0.0+cvs20041113.bb')
-rw-r--r--recipes/mtd/mtd-utils_0.0.0+cvs20041113.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/mtd/mtd-utils_0.0.0+cvs20041113.bb b/recipes/mtd/mtd-utils_0.0.0+cvs20041113.bb
new file mode 100644
index 0000000000..1c9bcfb24f
--- /dev/null
+++ b/recipes/mtd/mtd-utils_0.0.0+cvs20041113.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Tools for managing memory technology devices."
+SECTION = "base"
+DEPENDS = "zlib"
+HOMEPAGE = "http://www.linux-mtd.infradead.org/"
+LICENSE = "GPLv2"
+PR = "r2"
+SRCDATE = "20041113"
+
+SRC_URI = "http://www.the-little-red-haired-girl.org/pub/nylon/thirdparty/mtd-snapshot-20041113.tar.bz2 \
+ file://add-exclusion-to-mkfs-jffs2-20041113.patch;patch=1" \
+ file://target-endian.patch;patch=1"
+
+S = "${WORKDIR}/mtd"
+
+
+CFLAGS_prepend = "-I${S}/include "
+
+do_compile () {
+ oe_runmake -C util
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}/mtd
+ for f in ${S}/include/mtd/*.h; do
+ install -m 0644 $f ${STAGING_INCDIR}/mtd/
+ done
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ for binary in ftl_format flash_erase flash_eraseall nanddump doc_loadbios \
+ mkfs.jffs ftl_check mkfs.jffs2 flash_lock flash_unlock flash_info mtd_debug \
+ flashcp nandwrite jffs2dump; do
+ install -m 0755 util/$binary ${D}${bindir}
+ done
+}
+