aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mtools
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mtools
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mtools')
-rw-r--r--recipes/mtools/files/m486.patch48
-rw-r--r--recipes/mtools/files/mtools-makeinfo.patch63
-rw-r--r--recipes/mtools/files/no-x11.patch19
-rw-r--r--recipes/mtools/mtools-native_3.9.11.bb7
-rw-r--r--recipes/mtools/mtools_3.9.11.bb19
5 files changed, 156 insertions, 0 deletions
diff --git a/recipes/mtools/files/m486.patch b/recipes/mtools/files/m486.patch
new file mode 100644
index 0000000000..e6303247bc
--- /dev/null
+++ b/recipes/mtools/files/m486.patch
@@ -0,0 +1,48 @@
+#!/bin/sh -e
+## 07-m486.dpatch by Matthias Klose <doko@ubuntu.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: #474817: mtools: FTBFS: cc1: error: unrecognized command line option "-m486"
+
+if [ $# -lt 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+
+[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
+patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
+
+case "$1" in
+ -patch) patch $patch_opts -p1 < $0;;
+ -unpatch) patch $patch_opts -p1 -R < $0;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+--- mtools-3.9.11.orig/configure.in
++++ mtools-3.9.11/configure.in
+@@ -249,7 +249,7 @@
+ objs=`echo $srcdir/*.c | sed 's/\.c$/.o/' `
+ if [ "X$GCC" = "Xyes" ] ; then
+ if [ "$host_cpu" = i486 ] ; then
+- CFLAGS="$CFLAGS -m486"
++ CFLAGS="$CFLAGS"
+ fi
+ Wall=-Wall
+ if [ "$host_os3" = sunos ] ; then
+unchanged:
+--- mtools-3.9.11.orig/configure
++++ mtools-3.9.11/configure
+@@ -5905,7 +5905,7 @@
+ objs=`echo $srcdir/*.c | sed 's/\.c$/.o/' `
+ if [ "X$GCC" = "Xyes" ] ; then
+ if [ "$host_cpu" = i486 ] ; then
+- CFLAGS="$CFLAGS -m486"
++ CFLAGS="$CFLAGS"
+ fi
+ Wall=-Wall
+ if [ "$host_os3" = sunos ] ; then
diff --git a/recipes/mtools/files/mtools-makeinfo.patch b/recipes/mtools/files/mtools-makeinfo.patch
new file mode 100644
index 0000000000..35fae44aba
--- /dev/null
+++ b/recipes/mtools/files/mtools-makeinfo.patch
@@ -0,0 +1,63 @@
+--- mtools-3.9.9/configure.in.orig 2006-04-14 16:05:54.337655192 -0600
++++ mtools-3.9.9/configure.in 2006-04-14 16:12:29.736545424 -0600
+@@ -21,6 +21,33 @@
+ AC_C_CONST
+ AC_C_INLINE
+
++AC_CHECK_PROG(MAKEINFO, makeinfo, makeinfo, )
++if test "x$MAKEINFO" = "x"; then
++ MAKEINFO="@echo makeinfo missing; true"
++fi
++AC_CHECK_PROG(TEXI2DVI, texi2dvi, texi2dvi, )
++if test "x$TEXI2DVI" = "x"; then
++ TEXI2DVI="@echo texi2dvi missing; true"
++fi
++AC_CHECK_PROG(TEXI2PDF, texi2pdf, texi2pdf, )
++if test "x$TEXI2PDF" = "x"; then
++ TEXI2PDF="@echo texi2pdf missing; true"
++fi
++AC_CHECK_PROG(TEXI2HTML, texi2html, texi2html, )
++if test "x$TEXI2HTML" = "x"; then
++ TEXI2HTML="@echo texi2html missing; true"
++fi
++AC_CHECK_PROG(DVI2PS, dvi2ps, dvi2ps, )
++if test "x$DVI2PS" = "x"; then
++ DVI2PS="@echo dvi2ps missing; true"
++fi
++
++AC_SUBST(MAKEINFO)
++AC_SUBST(TEXI2DVI)
++AC_SUBST(TEXI2PDF)
++AC_SUBST(TEXI2HTML)
++AC_SUBST(DVI2PS)
++
+
+ dnl Check for configuration options
+ dnl Enable OS/2 extended density format disks
+--- mtools-3.9.9/Makefile.in.sav 2006-04-14 15:56:19.000000000 -0600
++++ mtools-3.9.9/Makefile.in 2006-04-14 16:15:29.315245312 -0600
+@@ -11,10 +11,11 @@
+ USERLDFLAGS =
+ USERLDLIBS =
+
+-MAKEINFO = makeinfo
+-TEXI2DVI = texi2dvi
+-TEXI2PDF = texi2pdf
+-TEXI2HTML = texi2html
++MAKEINFO = @MAKEINFO@
++TEXI2DVI = @TEXI2DVI@
++TEXI2PDF = @TEXI2PDF@
++TEXI2HTML = @TEXI2HTML@
++DVI2PS = @DVI2PS@
+
+
+ # do not edit below this line
+@@ -181,7 +182,7 @@
+
+ ps: mtools.ps
+ %.ps: %.dvi
+- dvips -f < $< > $@
++ $(DVI2PS) -f < $< > $@
+
+ pdf: mtools.pdf
+ %.pdf: %.texi
diff --git a/recipes/mtools/files/no-x11.patch b/recipes/mtools/files/no-x11.patch
new file mode 100644
index 0000000000..300f43f000
--- /dev/null
+++ b/recipes/mtools/files/no-x11.patch
@@ -0,0 +1,19 @@
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- mtools-3.9.9.orig/Makefile.in
++++ mtools-3.9.9/Makefile.in
+@@ -128,11 +128,11 @@ X_EXTRA_LIBS = @X_EXTRA_LIBS@
+ X_PRE_LIBS = @X_PRE_LIBS@
+ CFLAGS = $(CPPFLAGS) $(DEFS) $(MYCFLAGS) -I. @extraincludedir@ -I@srcdir@ $(USERCFLAGS)
+ CXXFLAGS = $(CPPFLAGS) $(DEFS) $(MYCXXFLAGS) -I. @extraincludedir@ -I@srcdir@ $(USERCFLAGS)
+ LINK = $(CC) $(LDFLAGS) $(USERLDFLAGS) @extralibdir@
+ ALLLIBS = $(USERLDLIBS) $(MACHDEPLIBS) $(SHLIB) $(LIBS)
+-X_LDFLAGS = $(X_EXTRA_LIBS) $(X_LIBS) $(X_PRE_LIBS) -lXau -lX11 $(LIBS)
++X_LDFLAGS = $(X_EXTRA_LIBS) $(X_LIBS) $(X_PRE_LIBS) $(LIBS)
+ X_CCFLAGS = $(X_CFLAGS) $(CFLAGS)
+
+ all: mtools $(LINKS) mkmanifest @FLOPPYD@
+
+ %.o: %.c
diff --git a/recipes/mtools/mtools-native_3.9.11.bb b/recipes/mtools/mtools-native_3.9.11.bb
new file mode 100644
index 0000000000..c82f7404eb
--- /dev/null
+++ b/recipes/mtools/mtools-native_3.9.11.bb
@@ -0,0 +1,7 @@
+# mtools-native OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+require mtools_${PV}.bb
+
+inherit autotools native
diff --git a/recipes/mtools/mtools_3.9.11.bb b/recipes/mtools/mtools_3.9.11.bb
new file mode 100644
index 0000000000..4d1822f0d7
--- /dev/null
+++ b/recipes/mtools/mtools_3.9.11.bb
@@ -0,0 +1,19 @@
+# mtools OE build file
+# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="Mtools is a collection of utilities for accessing MS-DOS disks from Unix without mounting them."
+HOMEPAGE="http://mtools.linux.lu"
+LICENSE="GPL"
+PR = "r4"
+
+SRC_URI="http://mtools.linux.lu/mtools-${PV}.tar.gz \
+ file://m486.patch;patch=1 \
+ file://mtools-makeinfo.patch;patch=1 \
+ file://no-x11.patch;patch=1"
+
+S = "${WORKDIR}/mtools-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-x"