aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mupdf/mupdf_0.6.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-08 15:08:27 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-09 09:40:48 +0200
commitf1b5be68502b508c68977970f8774c0991cf4d5a (patch)
tree22adf3d7004e07a8d9f0424da86984c62685cbf3 /recipes/mupdf/mupdf_0.6.bb
parent72fb6426ac6874db2a078f2e5353e5300c121d24 (diff)
downloadopenembedded-f1b5be68502b508c68977970f8774c0991cf4d5a.tar.gz
Revert "mupdf_0.6.bb: remove recipe."
* mupdf_git doesn't build here * only grg have successfull build on http://tinderbox.openembedded.org/packages/mupdf/ This reverts commit 71d25fe210fc31a342114e5a229f89be304632be. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/mupdf/mupdf_0.6.bb')
-rw-r--r--recipes/mupdf/mupdf_0.6.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes/mupdf/mupdf_0.6.bb b/recipes/mupdf/mupdf_0.6.bb
new file mode 100644
index 0000000000..16d49d8ff1
--- /dev/null
+++ b/recipes/mupdf/mupdf_0.6.bb
@@ -0,0 +1,62 @@
+DESCRIPTION = "A lightweight PDF viewer and toolkit written in portable C."
+HOMEPAGE = "http://www.mupdf.com"
+SECTION = "x11/applications"
+LICENSE = "GPLv3"
+PR = "r0"
+
+DEPENDS = "openjpeg-native jbig2dec-native jpeg-native freetype-native libpng-native openjpeg jbig2dec jpeg zlib virtual/libx11 libxext freetype"
+
+SRC_URI = "http://mupdf.com/download/source/${PN}-${PV}.tar.gz \
+ file://mupdf_fix_endianness.patch \
+ file://Makerules"
+
+S = "${WORKDIR}/mupdf"
+
+PACKAGES =+ "${PN}-tools ${PN}-tools-doc "
+FILES_${PN}-tools = "${bindir}/pdfclean ${bindir}/pdfdraw ${bindir}/pdfshow \
+ ${bindir}/pdfextract ${bindir}/pdfinfo"
+FILES_${PN}-tools-doc = "${mandir}/man1/pdfclean.1 ${mandir}/man1/pdfdraw.1 \
+ ${mandir}/man1/pdfshow.1"
+
+# mupdf crashes (at least on arm) when built with high level of optimization
+# so we need to provide some safe settings
+FULL_OPTIMIZATION = "-O2"
+
+do_configure() {
+ cp ${WORKDIR}/Makerules ${S}/Makerules
+
+ # we don't include CJK fonts to make binary more slim
+ # comment out following two lines if you need support for CJK
+ sed -i 's:^\t\$.GENDIR./font_cjk.c::g' ${S}/Makefile
+ echo "CFLAGS += -DNOCJK" >> ${S}/Makerules
+}
+
+do_compile() {
+ # mupdf uses couple of tools for code generation during build process
+ # so we need to compile them first with host compiler
+ unset CFLAGS LDFLAGS
+ export PKG_CONFIG_PATH=${STAGING_LIBDIR_NATIVE}/pkgconfig
+ oe_runmake build/debug
+ oe_runmake build/debug/cmapdump LD="${BUILD_CC} -L${STAGING_LIBDIR_NATIVE} -Wl,-rpath,${STAGING_LIBDIR_NATIVE}" CC=${BUILD_CC}
+ oe_runmake build/debug/fontdump LD="${BUILD_CC} -L${STAGING_LIBDIR_NATIVE} -Wl,-rpath,${STAGING_LIBDIR_NATIVE}" CC=${BUILD_CC}
+
+ export PKG_CONFIG_PATH=${STAGING_LIBDIR}/pkgconfig
+ # ...and then we fire 'make', feeding proper
+ # cross-compilation flags through Makerules file
+ echo "CFLAGS += ${CFLAGS}" >> ${S}/Makerules
+ echo "LDFLAGS += ${LDFLAGS}" >> ${S}/Makerules
+ oe_runmake LD="${CC}"
+}
+
+do_install() {
+ oe_runmake install prefix="${D}/usr"
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -d ${D}/${mandir}/man1
+ install -m 0644 ${S}/debian/mupdf.xpm ${D}/${datadir}/pixmaps/
+ install -m 0644 ${S}/debian/mupdf.desktop ${D}/${datadir}/applications/
+ install -m 0644 ${S}/debian/*.1 ${D}/${mandir}/man1/
+}
+
+SRC_URI[md5sum] = "d1e1a1df8fb3e4d1c601506797b75036"
+SRC_URI[sha256sum] = "6f87c4f113ee9e0f4bdfd3a316ef44052edc4febc8f7b531c4a3f44ffe149605"