summaryrefslogtreecommitdiffstats
path: root/recipes/mythfront
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/mythfront
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/mythfront')
-rw-r--r--recipes/mythfront/mythfront-config.bb32
-rwxr-xr-xrecipes/mythfront/mythfront-config/epia/serial.sh7
-rw-r--r--recipes/mythfront/mythfront-config/epia/xorg.conf70
-rwxr-xr-xrecipes/mythfront/mythfront-config/tftp.sh36
-rw-r--r--recipes/mythfront/mythfront-session.bb9
-rw-r--r--recipes/mythfront/mythfront-session/mythfront.sh8
6 files changed, 162 insertions, 0 deletions
diff --git a/recipes/mythfront/mythfront-config.bb b/recipes/mythfront/mythfront-config.bb
new file mode 100644
index 0000000000..b87e0be8ad
--- /dev/null
+++ b/recipes/mythfront/mythfront-config.bb
@@ -0,0 +1,32 @@
+PV = "1.10"
+PR = "r0"
+
+RDEPENDS_${PN} = "font-misc-misc"
+LICENSE = "MIT"
+SRC_URI = "file://tftp.sh file://xorg.conf"
+
+SRC_URI_append_epia = " file://serial.sh"
+
+do_install() {
+ install -d ${D}${sysconfdir}/udhcpc.d/
+ install ${WORKDIR}/tftp.sh ${D}${sysconfdir}/udhcpc.d/80tftp
+
+ install -d ${D}${sysconfdir}/mythtv
+ ln -sf /var/lib/config/mysql.txt ${D}${sysconfdir}/mythtv
+
+ install -d ${D}${sysconfdir}/X11
+ install -m 0644 ${WORKDIR}/xorg.conf ${D}${sysconfdir}/X11
+
+ ln -sf /var/lib/config/lircd.conf ${D}${sysconfdir}/lircd.conf
+
+ install -d ${D}/dev
+ ln -sf lirc0 ${D}/dev/lirc
+
+ if [ -f ${WORKDIR}/serial.sh ]; then
+ install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/rc2.d
+ install ${WORKDIR}/serial.sh ${D}${sysconfdir}/init.d/mythfront-serial
+ ln -sf ../init.d/mythfront-serial ${D}${sysconfdir}/rc2.d/S10mythfront-serial
+ fi
+}
+
diff --git a/recipes/mythfront/mythfront-config/epia/serial.sh b/recipes/mythfront/mythfront-config/epia/serial.sh
new file mode 100755
index 0000000000..6d2a978fea
--- /dev/null
+++ b/recipes/mythfront/mythfront-config/epia/serial.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+setserial /dev/ttyS0 uart none
+modprobe lirc_serial
+modprobe snes232
+inputattach --snes232 /dev/ttyS1 &
+
diff --git a/recipes/mythfront/mythfront-config/epia/xorg.conf b/recipes/mythfront/mythfront-config/epia/xorg.conf
new file mode 100644
index 0000000000..1783a88af8
--- /dev/null
+++ b/recipes/mythfront/mythfront-config/epia/xorg.conf
@@ -0,0 +1,70 @@
+Section "Files"
+ FontPath "unix/:7100" # local font server
+ FontPath "/usr/lib/X11/fonts/misc"
+ FontPath "/usr/lib/X11/fonts/cyrillic"
+ FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
+ FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
+ FontPath "/usr/lib/X11/fonts/Type1"
+ FontPath "/usr/lib/X11/fonts/CID"
+ FontPath "/usr/lib/X11/fonts/Speedo"
+ FontPath "/usr/lib/X11/fonts/100dpi"
+ FontPath "/usr/lib/X11/fonts/75dpi"
+EndSection
+
+Section "Module"
+ Load "ddc"
+ Load "glx"
+ Load "GLcore"
+ Load "dbe"
+ Load "dri"
+ Load "extmod"
+ #Load "pex5"
+ Load "record"
+ #Load "xie"
+ Load "bitmap"
+EndSection
+
+Section "InputDevice"
+ Identifier "Generic Keyboard"
+ Driver "keyboard"
+ Option "CoreKeyboard"
+ Option "XkbRules" "xfree86"
+ Option "XkbModel" "pc104"
+ Option "XkbLayout" "gb"
+EndSection
+
+Section "Device"
+ Identifier "Via"
+ Driver "via"
+ Option "TVType" "PAL"
+ #Option "TVVScan" "over"
+ #Option "TVDotCrawl"
+ #Option "NoDDCValue" "true"
+ Option "TVOutput" "S-Video"
+ Option "EnableAGPDMA" "true"
+EndSection
+
+Section "Monitor"
+ Identifier "TV"
+ Option "DPMS" "no"
+ HorizSync 15-70
+ VertRefresh 50-100
+ DisplaySize 400 225
+ #Modeline "720x576" 27.88 720 744 768 920 576 578 579 606 # 28 MHz, 30.3 kHz, 50.0 Hz
+ ModeLine "720x576" 32.7 720 744 816 912 576 577 580 597
+
+ #Modeline "720x576" 55.75 720 744 768 920 576 578 581 606 # 56 MHz, 60.6 kHz, 100.0 Hz
+ #ModeLine "720x480" 26.7 720 736 808 896 480 481 484 497
+ #ModeLine "720x576" 32.7 720 744 816 912 576 577 580 597
+EndSection
+
+Section "Screen"
+ Identifier "Default Screen"
+ Device "Via"
+ Monitor "TV"
+ DefaultDepth 24
+ Subsection "Display"
+ Depth 24
+ Modes "720x576"
+ EndSubsection
+EndSection
diff --git a/recipes/mythfront/mythfront-config/tftp.sh b/recipes/mythfront/mythfront-config/tftp.sh
new file mode 100755
index 0000000000..8ac4bf8020
--- /dev/null
+++ b/recipes/mythfront/mythfront-config/tftp.sh
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+case $1 in
+ renew|bound)
+ ;;
+ *)
+ exit 0
+ ;;
+esac
+
+bootdir=`dirname $boot_file`
+
+files="mysql.txt lircrc mythfront.config"
+
+mkdir /var/lib/config
+cd /var/lib/config
+
+for fn in $files; do
+ if ! tftp -g $siaddr -r $bootdir/mythfront/$ip/$fn -l $fn; then
+ if ! tftp -g $siaddr -r $bootdir/mythfront/default/$fn -l $fn; then
+ rm -f $fn
+ fi
+ fi
+done
+
+if [ -f ./mythfront.config ]; then
+ . ./mythfront.config
+ if [ "x$REMOTE" != "x" ]; then
+ fn=`find /usr/share/lirc/remotes -name lircd.conf.$REMOTE`
+ if [ "x$fn" != "x" ]; then
+ rm -f lircd.conf
+ ln -sf $fn lircd.conf
+ fi
+ fi
+fi
+
diff --git a/recipes/mythfront/mythfront-session.bb b/recipes/mythfront/mythfront-session.bb
new file mode 100644
index 0000000000..bd9e286fef
--- /dev/null
+++ b/recipes/mythfront/mythfront-session.bb
@@ -0,0 +1,9 @@
+PV = "1.5"
+LICENSE = "MIT"
+SRC_URI = "file://mythfront.sh"
+
+do_install() {
+ install -d ${D}${sysconfdir}/X11/Xinit.d
+ install ${WORKDIR}/mythfront.sh ${D}${sysconfdir}/X11/Xinit.d/90mythfront
+}
+
diff --git a/recipes/mythfront/mythfront-session/mythfront.sh b/recipes/mythfront/mythfront-session/mythfront.sh
new file mode 100644
index 0000000000..97b7833001
--- /dev/null
+++ b/recipes/mythfront/mythfront-session/mythfront.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+mkdir -p $HOME/.mythtv
+ln -sf /var/lib/config/lircrc $HOME/.mythtv/lircrc
+ln -sf /etc/mythtv/mysql.txt $HOME/.mythtv/mysql.txt
+
+exec mythfrontend
+