aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mythtv
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-01 18:00:07 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-01 18:02:15 +0100
commit5ccd6effbef68b5318ef16911f5eab8cbc35f92e (patch)
tree678874d8844f0217c501ebeefd4dc8a007cf11d0 /recipes/mythtv
parent9393ac7170efdc97c6dc03f54a5f074c6005b1eb (diff)
downloadopenembedded-5ccd6effbef68b5318ef16911f5eab8cbc35f92e.tar.gz
mythplugins: move into mythtv directory
Diffstat (limited to 'recipes/mythtv')
-rw-r--r--recipes/mythtv/mythplugins/MythBackend.php.patch13
-rw-r--r--recipes/mythtv/mythplugins/mythflix.pro.patch13
-rw-r--r--recipes/mythtv/mythplugins/mythgallery.pro.patch13
-rw-r--r--recipes/mythtv/mythplugins/mythmovies.pro.patch13
-rw-r--r--recipes/mythtv/mythplugins/mythnews.pro.patch17
-rw-r--r--recipes/mythtv/mythplugins/mythweather.pro.patch15
-rw-r--r--recipes/mythtv/mythplugins/mythzoneminder.pro.patch13
-rw-r--r--recipes/mythtv/mythplugins_0.21+0.22rc1.bb124
8 files changed, 221 insertions, 0 deletions
diff --git a/recipes/mythtv/mythplugins/MythBackend.php.patch b/recipes/mythtv/mythplugins/MythBackend.php.patch
new file mode 100644
index 0000000000..95cf86e49f
--- /dev/null
+++ b/recipes/mythtv/mythplugins/MythBackend.php.patch
@@ -0,0 +1,13 @@
+Index: mythplugins-0.22rc1/mythweb/classes/MythBackend.php
+===================================================================
+--- mythplugins-0.22rc1.orig/mythweb/classes/MythBackend.php
++++ mythplugins-0.22rc1/mythweb/classes/MythBackend.php
+@@ -111,7 +111,7 @@ class MythBackend {
+ }
+
+ public function setTimezone() {
+- if (!is_string($_SESSION['backend']['timezone']['value']) || $_SESSION['backend']['timezone']['last_check_time'] - time() > 60*60*24) {
++ if (!is_string($_SESSION['backend']['timezone']['value']) || time() - $_SESSION['backend']['timezone']['last_check_time'] () > 60*60*24) {
+ $response = $this->sendCommand('QUERY_TIME_ZONE');
+ $timezone = str_replace(' ', '_', $response[0]);
+ $_SESSION['backend']['timezone']['value'] = $timezone;
diff --git a/recipes/mythtv/mythplugins/mythflix.pro.patch b/recipes/mythtv/mythplugins/mythflix.pro.patch
new file mode 100644
index 0000000000..cffaeae197
--- /dev/null
+++ b/recipes/mythtv/mythplugins/mythflix.pro.patch
@@ -0,0 +1,13 @@
+Index: mythplugins-0.22rc1/mythflix/mythflix/mythflix.pro
+===================================================================
+--- mythplugins-0.22rc1.orig/mythflix/mythflix/mythflix.pro
++++ mythplugins-0.22rc1/mythflix/mythflix/mythflix.pro
+@@ -8,7 +8,7 @@ TARGET = mythflix
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
+
+ installfiles.path = $${PREFIX}/share/mythtv/mythflix
+ installfiles.files = netflix-rss.xml
diff --git a/recipes/mythtv/mythplugins/mythgallery.pro.patch b/recipes/mythtv/mythplugins/mythgallery.pro.patch
new file mode 100644
index 0000000000..8be5ea016b
--- /dev/null
+++ b/recipes/mythtv/mythplugins/mythgallery.pro.patch
@@ -0,0 +1,13 @@
+Index: mythplugins-0.22rc1/mythgallery/mythgallery/mythgallery.pro
+===================================================================
+--- mythplugins-0.22rc1.orig/mythgallery/mythgallery/mythgallery.pro
++++ mythplugins-0.22rc1/mythgallery/mythgallery/mythgallery.pro
+@@ -14,7 +14,7 @@ TARGET = mythgallery
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
+
+ # Input
+ HEADERS += iconview.h singleview.h
diff --git a/recipes/mythtv/mythplugins/mythmovies.pro.patch b/recipes/mythtv/mythplugins/mythmovies.pro.patch
new file mode 100644
index 0000000000..84e9450309
--- /dev/null
+++ b/recipes/mythtv/mythplugins/mythmovies.pro.patch
@@ -0,0 +1,13 @@
+Index: mythplugins-0.22rc1/mythmovies/mythmovies/mythmovies.pro
+===================================================================
+--- mythplugins-0.22rc1.orig/mythmovies/mythmovies/mythmovies.pro
++++ mythplugins-0.22rc1/mythmovies/mythmovies/mythmovies.pro
+@@ -10,7 +10,7 @@ TARGET = mythmovies
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+
+ # Input
+ HEADERS += moviesui.h helperobjects.h moviessettings.h
diff --git a/recipes/mythtv/mythplugins/mythnews.pro.patch b/recipes/mythtv/mythplugins/mythnews.pro.patch
new file mode 100644
index 0000000000..8b572fcb15
--- /dev/null
+++ b/recipes/mythtv/mythplugins/mythnews.pro.patch
@@ -0,0 +1,17 @@
+Index: mythplugins-0.22rc1/mythnews/mythnews/mythnews.pro
+===================================================================
+--- mythplugins-0.22rc1.orig/mythnews/mythnews/mythnews.pro
++++ mythplugins-0.22rc1/mythnews/mythnews/mythnews.pro
+@@ -10,9 +10,9 @@ TARGET = mythnews
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythdb
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythdb
+
+ installfiles.path = $${PREFIX}/share/mythtv/mythnews
+ installfiles.files = news-sites.xml
diff --git a/recipes/mythtv/mythplugins/mythweather.pro.patch b/recipes/mythtv/mythplugins/mythweather.pro.patch
new file mode 100644
index 0000000000..c7fff48708
--- /dev/null
+++ b/recipes/mythtv/mythplugins/mythweather.pro.patch
@@ -0,0 +1,15 @@
+Index: mythplugins-0.22rc1/mythweather/mythweather/mythweather.pro
+===================================================================
+--- mythplugins-0.22rc1.orig/mythweather/mythweather/mythweather.pro
++++ mythplugins-0.22rc1/mythweather/mythweather/mythweather.pro
+@@ -13,8 +13,8 @@ INSTALLS += target
+ QMAKE_COPY_DIR = sh ../../cpsvndir
+ win32:QMAKE_COPY_DIR = sh ../../cpsimple
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+
+ datafiles.path = $${PREFIX}/share/mythtv/mythweather/
+ datafiles.files = weather-screens.xml
diff --git a/recipes/mythtv/mythplugins/mythzoneminder.pro.patch b/recipes/mythtv/mythplugins/mythzoneminder.pro.patch
new file mode 100644
index 0000000000..9eb019c3ac
--- /dev/null
+++ b/recipes/mythtv/mythplugins/mythzoneminder.pro.patch
@@ -0,0 +1,13 @@
+Index: mythplugins-0.22rc1/mythzoneminder/mythzoneminder/mythzoneminder.pro
+===================================================================
+--- mythplugins-0.22rc1.orig/mythzoneminder/mythzoneminder/mythzoneminder.pro
++++ mythplugins-0.22rc1/mythzoneminder/mythzoneminder/mythzoneminder.pro
+@@ -8,7 +8,7 @@ TARGET = mythzoneminder
+ target.path = $${LIBDIR}/mythtv/plugins
+ INSTALLS += target
+
+-INCLUDEPATH += $${PREFIX}/include/mythtv/libmythui
++INCLUDEPATH += $${SYSROOT}$${PREFIX}/include/mythtv/libmythui
+
+ # Input
+ HEADERS += zmconsole.h zmplayer.h zmevents.h zmliveplayer.h zmdefines.h
diff --git a/recipes/mythtv/mythplugins_0.21+0.22rc1.bb b/recipes/mythtv/mythplugins_0.21+0.22rc1.bb
new file mode 100644
index 0000000000..62b4accfa4
--- /dev/null
+++ b/recipes/mythtv/mythplugins_0.21+0.22rc1.bb
@@ -0,0 +1,124 @@
+inherit qmake2 qt4x11
+
+DEFAULT_PREFERENCE = "-1"
+
+PV = "0.21+0.22rc1"
+PR = "r0"
+DEPENDS = "flac taglib mythtv libvorbis libexif libvisual libsdl-x11 libcdaudio"
+# to add libcdparanoia
+
+# todo: add mythweb
+
+PACKAGES =+ "mythmovies mythnews mythweather"
+
+RDEPENDS_${PN} = "mythmovies mythnews mythweather"
+
+FILES_mythmovies = "${libdir}/mythtv/plugins/libmythmovies.so \
+ ${bindir}/ignyte \
+ ${datadir}/mythtv/mythmovies/ \
+ ${datadir}/mythtv/themes/default/movies-ui.xml \
+ ${datadir}/mythtv/themes/default-wide/movies-ui.xml \
+ "
+
+FILES_mythmovies-dbg = "${bindir}/.debug/ignyte \
+ ${libdir}/mythtv/plugins/.debug/libmythmovies.so"
+
+
+FILES_mythnews = "${libdir}/mythtv/plugins/libmythnews.so \
+ ${datadir}/mythtv/mythnews/ \
+ ${datadir}/mythtv/themes/default/enclosures.png \
+ ${datadir}/mythtv/themes/default/needs-download.png \
+ ${datadir}/mythtv/themes/default/news-info-bg.png \
+ ${datadir}/mythtv/themes/default/news-ui.xml \
+ "
+
+FILES_mythnews-dbg = "${libdir}/mythtv/plugins/.debug/libmythnews.so"
+
+FILES_mythweather = "${libdir}/mythtv/plugins/libmythweather.so \
+ ${datadir}/mythtv/mythweather/ \
+ ${datadir}/mythtv/il8n/mythweather* \
+ ${datadir}/mythtv/themes/default-wide/mw-background.png \
+ ${datadir}/mythtv/themes/default-wide/mw-lines.png \
+ ${datadir}/mythtv/themes/default-wide/mw-map-sat.png \
+ ${datadir}/mythtv/themes/default-wide/mw-map.png \
+ ${datadir}/mythtv/themes/default-wide/mw-popup.png \
+ ${datadir}/mythtv/themes/default-wide/weather-ui.xml \
+ ${datadir}/mythtv/themes/default/cloudy.png \
+ ${datadir}/mythtv/themes/default/fair.png \
+ ${datadir}/mythtv/themes/default/flurries.png \
+ ${datadir}/mythtv/themes/default/fog.png \
+ ${datadir}/mythtv/themes/default/logo.png \
+ ${datadir}/mythtv/themes/default/lshowers.png \
+ ${datadir}/mythtv/themes/default/mcloudy.png \
+ ${datadir}/mythtv/themes/default/mw_background.png \
+ ${datadir}/mythtv/themes/default/mw_checked.png \
+ ${datadir}/mythtv/themes/default/mw_checked_high.png \
+ ${datadir}/mythtv/themes/default/mw_lines.png \
+ ${datadir}/mythtv/themes/default/mw_map-sat.png \
+ ${datadir}/mythtv/themes/default/mw_map.png \
+ ${datadir}/mythtv/themes/default/mw_popup.png \
+ ${datadir}/mythtv/themes/default/mw_shading.png \
+ ${datadir}/mythtv/themes/default/mw_unchecked.png \
+ ${datadir}/mythtv/themes/default/mw_unchecked_high.png \
+ ${datadir}/mythtv/themes/default/mwmain.png \
+ ${datadir}/mythtv/themes/default/pcloudy.png \
+ ${datadir}/mythtv/themes/default/rainsnow.png \
+ ${datadir}/mythtv/themes/default/showers.png \
+ ${datadir}/mythtv/themes/default/snowshow.png \
+ ${datadir}/mythtv/themes/default/sunny.png \
+ ${datadir}/mythtv/themes/default/thunshowers.png \
+ ${datadir}/mythtv/themes/default/unknown.png \
+ ${datadir}/mythtv/themes/default/weather-ui.xml \
+ ${datadir}/mythtv/themes/menus/weather_settings.xml \
+ "
+
+FILES_mythweather-dbg = "${libdir}/mythtv/plugins/.debug/libmythweather.so"
+
+SRC_URI = "ftp://ftp.osuosl.org/pub/mythtv/mythplugins-0.22rc1.tar.bz2 \
+ file://MythBackend.php.patch;patch=1 \
+ file://mythflix.pro.patch;patch=1 \
+ file://mythgallery.pro.patch;patch=1 \
+ file://mythmovies.pro.patch;patch=1 \
+ file://mythnews.pro.patch;patch=1 \
+ file://mythweather.pro.patch;patch=1 \
+ file://mythzoneminder.pro.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/mythplugins-0.22rc1"
+
+QMAKE_PROFILES = "mythplugins.pro"
+
+# Note: a lot of functionality is disabled because it depends on QtOpenGL
+# which is not in OE at the moment
+
+EXTRA_OECONF = " \
+ --cross-prefix=${TARGET_PREFIX} \
+ --sysroot=${STAGING_DIR_HOST} \
+ --prefix=${prefix} \
+ --with-libdir-name=${STAGING_LIBDIR} \
+ --disable-opengl \
+ --disable-mytharchive \
+ --disable-mythbrowser \
+ --disable-mythflix \
+ --disable-mythgallery \
+ --disable-mythgame \
+ --disable-mythmusic \
+ --disable-mythvideo \
+ --disable-mythzoneminder \
+ \
+ --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
+ --extra-cxxflags="${TARGET_CXXFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
+ --extra-ldflags="${TARGET_LDFLAGS}" \
+ ${EXTRA_MYTHTVCONF} \
+"
+
+do_configure() {
+ ${S}/configure --qmake=qmake2 ${EXTRA_OECONF}
+}
+
+do_install () {
+ oe_runmake install INSTALL_ROOT="${D}"
+
+}
+
+#ALLOW_EMPTY_${PN} = "1"