aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/mythtv
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-06 12:21:28 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-11-06 12:21:28 +0100
commitb441c5e7b9956dee5aaad5ff58df374e4b57f2fa (patch)
treeed2aa043efe5f8db9dfe1faf3eead5e660db2074 /recipes/mythtv
parent35cc93da885ac6d438da6aaed9517e91d4a7e6b3 (diff)
downloadopenembedded-b441c5e7b9956dee5aaad5ff58df374e4b57f2fa.tar.gz
mythtv: added mc.sql; introduced database package for that one (similar to debian)
Diffstat (limited to 'recipes/mythtv')
-rw-r--r--recipes/mythtv/mythtv_0.21+0.22rc2.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/recipes/mythtv/mythtv_0.21+0.22rc2.bb b/recipes/mythtv/mythtv_0.21+0.22rc2.bb
index 3ba8ff725c..bc85a1ad86 100644
--- a/recipes/mythtv/mythtv_0.21+0.22rc2.bb
+++ b/recipes/mythtv/mythtv_0.21+0.22rc2.bb
@@ -1,10 +1,10 @@
require mythtv.inc
-RDEPENDS_${PN} = "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-data"
+RDEPENDS_${PN} = "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-database"
RDEPENDS_${PN}_append_libc-glibc = " glibc-gconv-utf-16"
PV = "0.21+0.22rc2"
-PR = "r2"
+PR = "r3"
REALPV = "0.22"
DEFAULT_PREFERENCE = "-1"
@@ -51,6 +51,12 @@ do_configure_prepend() {
--without-bindings=perl,python \
${EXTRA_OECONF}
}
+do_install() {
+ oe_runmake INSTALL_ROOT=${D} install
+ install -d ${D}${datadir}/mythtv
+ install -d ${D}${datadir}/mythtv/sql
+ install -m 0644 ${S}/database/mc.sql ${D}${datadir}/mythtv/sql
+}
do_stage() {
install -d ${STAGING_INCDIR}
install -d ${STAGING_INCDIR}/${PN}
@@ -84,7 +90,7 @@ do_stage() {
chmod -R ugo+r ${STAGING_LIBDIR}
}
-PACKAGES =+ "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-data"
+PACKAGES =+ "mythtv-backend mythtv-frontend mythtv-bin mythtv-filters mythtv-database"
PACKAGES_DYNAMIC = "mythtv-theme-*"
FILES_${PN}-dbg += "${libdir}/mythtv/filters/.debug"
@@ -92,7 +98,7 @@ FILES_mythtv-backend = "${bindir}/mythbackend ${bindir}/mythcommflag ${bindir}/m
FILES_mythtv-frontend = "${bindir}/mythfrontend ${datadir}/mythtv/i18n/mythfrontend_* ${datadir}/mythtv/*.ttf"
FILES_mythtv-bin = "${bindir}/*"
FILES_mythtv-filters = "${libdir}/mythtv/filters/*"
-FILES_mythtv-data = "${datadir}"
+FILES_mythtv-database = "${datadir}/mythtv/sql/"
mythlibs = "mythdb mythavutil mythavcodec mythavformat mythswscale mythhdhomerun myth mythtv mythui mythfreemheg mythupnp mythlivemedia"