aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nautilus/nautilus_2.26.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-04-13 11:39:18 +0200
committerKoen Kooi <koen@openembedded.org>2009-04-13 11:39:18 +0200
commit1a9bfdf30e73e8b5a410af5b768c666a43c8e06a (patch)
treeb210df7513f881e2f7f8491ee2cb9ce409399290 /recipes/nautilus/nautilus_2.26.1.bb
parent7ac45fd7eeef4ddb35bca22ba0fe1bf89b722a88 (diff)
downloadopenembedded-1a9bfdf30e73e8b5a410af5b768c666a43c8e06a.tar.gz
nautilus: add 2.26.1
Diffstat (limited to 'recipes/nautilus/nautilus_2.26.1.bb')
-rw-r--r--recipes/nautilus/nautilus_2.26.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/nautilus/nautilus_2.26.1.bb b/recipes/nautilus/nautilus_2.26.1.bb
new file mode 100644
index 0000000000..8eb5c80ed9
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.26.1.bb
@@ -0,0 +1,37 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+SRC_URI += "file://idl-sysroot.patch;patch=1 \
+ file://no-try-run-strftime.diff;patch=1 \
+"
+
+export SYSROOT = "${STAGING_DIR_HOST}"
+
+LICENSE="GPL"
+
+DEPENDS += " gvfs tracker librsvg libexif eel esound gnome-desktop orbit2-native"
+RDEPENDS = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
+
+EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
+
+PACKAGES += " libnautilus"
+
+FILES_${PN} += "${datadir}/icons /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+do_configure_prepend() {
+ sed -i -e /docs/d Makefile.am
+}
+
+# We need native orbit-idl with target idl files. No way to say it in a clean way:
+do_configure_append () {
+ find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+do_stage() {
+ autotools_stage_all
+}