aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nautilus
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-08 10:35:08 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-08 10:35:08 +0100
commit2d4ef9ad61dc414faee88e692fbc9759dcf353be (patch)
tree84a7cf57c4a85ea2d50f03307c3707fd255ede3a /recipes/nautilus
parent1309ac4fd20ff3a1f0e3571db6ddfb59f7ae1228 (diff)
downloadopenembedded-2d4ef9ad61dc414faee88e692fbc9759dcf353be.tar.gz
nautilus: add 2.28.1
Diffstat (limited to 'recipes/nautilus')
-rw-r--r--recipes/nautilus/nautilus_2.28.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/nautilus/nautilus_2.28.1.bb b/recipes/nautilus/nautilus_2.28.1.bb
new file mode 100644
index 0000000000..e3a551c76f
--- /dev/null
+++ b/recipes/nautilus/nautilus_2.28.1.bb
@@ -0,0 +1,37 @@
+# nautilus OE build file
+# Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+inherit gnome
+
+SRC_URI += "file://idl-sysroot.patch;patch=1 \
+ file://no-try-run-strftime.diff;patch=1 \
+"
+
+export SYSROOT = "${STAGING_DIR_HOST}"
+
+LICENSE="GPL"
+
+DEPENDS += "libunique gvfs tracker librsvg libexif eel esound gnome-desktop orbit2-native"
+RDEPENDS = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
+
+EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
+
+PACKAGES += " libnautilus"
+
+FILES_${PN} += "${datadir}/icons /usr/libexec/ "
+FILES_libnautilus = "/usr/lib/*.so*"
+FILES_${PN}-dbg += "/usr/libexec/.debug"
+
+do_configure_prepend() {
+ sed -i -e /docs/d Makefile.am
+}
+
+# We need native orbit-idl with target idl files. No way to say it in a clean way:
+do_configure_append () {
+ find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
+}
+
+do_stage() {
+ autotools_stage_all
+}