aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/navit/navit-icons_svn.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-12-06 11:46:35 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-12-06 11:48:56 +0100
commit8bfd1a4e9122d62521bfe71b33579019ba95640d (patch)
treed3799362dc8cbdf3de5a7df0703ddc47a61211a5 /recipes/navit/navit-icons_svn.bb
parent3d9fce8306ff3d54c3f59fe7c430e220a91b8449 (diff)
downloadopenembedded-8bfd1a4e9122d62521bfe71b33579019ba95640d.tar.gz
navit: change to INC_PR, bump srcrev, split icons and config for navit_svn
* xpm stuff is updated maybe about 6 times a year, sources are updated few times every day * with navit-icons in separate package we don't need to download 3,5MB package, every time we bump SRCREV because of software fix * navit-icons SRCREV will be changed only if there is new icon needed for newer navit SRCREV * big package was installed by opkg really slow * provide 2 desktop icons one with Display blanking disabled ie for car navigation, second with only CPU requested ie if you're using navit on foot or bike and want longer battery life * splitted configs are easier to modify, also provide better defaults for freerunner layout Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/navit/navit-icons_svn.bb')
-rw-r--r--recipes/navit/navit-icons_svn.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/navit/navit-icons_svn.bb b/recipes/navit/navit-icons_svn.bb
new file mode 100644
index 0000000000..09961deb7c
--- /dev/null
+++ b/recipes/navit/navit-icons_svn.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Navit is a car navigation system with routing engine."
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS = "glib-2.0 gtk+"
+RRECOMMENDS = "gpsd espeak flite"
+
+PV = "0.1.0+svnr${SRCPV}"
+PR = "r0"
+
+DEPENDS_shr += " librsvg-native"
+EXTRA_OECONF = "--disable-binding-python --disable-gui-sdl --disable-samplemap --enable-avoid-float --enable-avoid-unaligned --enable-svg2png-scaling-flag=32 --disable-speech-speech-dispatcher"
+
+S = "${WORKDIR}/xpm"
+
+inherit autotools
+
+FILES_${PN} = " /usr/share/navit/xpm/"
+
+#use different URL than navit_svn doest, to prevent upgrade/downgrade cycle in downloads dir
+SRC_URI = "svn://anonymous@navit.svn.sourceforge.net/svnroot/navit/trunk/navit/navit;module=xpm;proto=https \
+ file://configure.in"
+
+do_configure_prepend() {
+ cp ${WORKDIR}/configure.in ${S}/
+ # replace include with just xpmdir variable
+ sed -i 's#.*Makefile.inc.*#xpmdir=$(pkgdatadir)/xpm#g' ${S}/Makefile.am
+ # don't install desktopfile and icons
+ sed -i 's/^\(EXTRADIST.*\) $(DESKTOPFILE_DATA) $(ICON128_DATA) $(ICON22_DATA) \(.*\)$/\1\2/g' ${S}/Makefile.am
+}