aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nbench-byte
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-21 21:36:30 +0200
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-06-22 21:58:07 +0200
commitad42bf9065928b2902d7d9534709d3ccea7ec956 (patch)
tree9252c343d42c5e9ff20048edd6c3003ce50b08f5 /recipes/nbench-byte
parent0dcaad77742245477b34542b49c66e91d16a147d (diff)
downloadopenembedded-ad42bf9065928b2902d7d9534709d3ccea7ec956.tar.gz
nbench-byte: added BYTEmark benchmark
BYTE Magazine's native benchmarks (also called BYTEmark) designed to expose the capabilities of a system's CPU, FPU and memory system. http://www.tux.org/~mayer/linux/ Recipe from old Atmel overlay.
Diffstat (limited to 'recipes/nbench-byte')
-rw-r--r--recipes/nbench-byte/nbench-byte/nbench_32bits.patch18
-rw-r--r--recipes/nbench-byte/nbench-byte_2.2.3.bb19
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes/nbench-byte/nbench-byte/nbench_32bits.patch b/recipes/nbench-byte/nbench-byte/nbench_32bits.patch
new file mode 100644
index 0000000000..fa33d60e41
--- /dev/null
+++ b/recipes/nbench-byte/nbench-byte/nbench_32bits.patch
@@ -0,0 +1,18 @@
+diff -Nur nbench-byte-2.2.3_orig/Makefile nbench-byte-2.2.3/Makefile
+--- nbench-byte-2.2.3_orig/Makefile 2004-12-30 03:23:30.000000000 +0100
++++ nbench-byte-2.2.3/Makefile 2008-10-06 18:38:46.000000000 +0200
+@@ -119,12 +119,8 @@
+ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+ -c emfloat.c
+
+-pointer.h: pointer Makefile
+- $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+- -o pointer pointer.c
+- rm -f pointer.h
+- if [ "4" = `./pointer` ] ; then touch pointer.h ;\
+- else echo "#define LONG64" >pointer.h ; fi
++pointer.h: Makefile
++ touch pointer.h ;
+
+ misc.o: misc.h misc.c Makefile
+ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
diff --git a/recipes/nbench-byte/nbench-byte_2.2.3.bb b/recipes/nbench-byte/nbench-byte_2.2.3.bb
new file mode 100644
index 0000000000..4a5fa24dad
--- /dev/null
+++ b/recipes/nbench-byte/nbench-byte_2.2.3.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "BYTE Magazine's native benchmarks (also called BYTEmark) \
+designed to expose the capabilities of a system's CPU, FPU, \
+and memory system."
+HOMEPAGE = "http://www.tux.org/~mayer/linux/"
+LICENSE = "freely distributable"
+SECTION = "console/utils"
+
+SRC_URI = "http://www.tux.org/~mayer/linux/${PN}-${PV}.tar.gz \
+ file://nbench_32bits.patch;patch=1"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0644 NNET.DAT ${D}${bindir}/
+ install -m 0755 nbench ${D}${bindir}/
+}