aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ncurses
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-07-24 22:28:22 -0400
committerChris Larson <chris_larson@mentor.com>2010-07-25 10:02:50 -0700
commitda26c362b6b32d52f755ca55bfc6cc0f9ddb42f6 (patch)
tree4bf6a6a588baba78acd7d2be1b71bc54cf69d884 /recipes/ncurses
parent8df384ecb006741bdb891ad82d6ee24fa5be38bb (diff)
downloadopenembedded-da26c362b6b32d52f755ca55bfc6cc0f9ddb42f6.tar.gz
Work around ncurses-sdk & zlib-sdk build failures on CentOS 5.4
The issue here is that we're building ncurses with HOST==BUILD!=TARGET, aka 'cross', yet we're applying a CFLAGS override based on the target, not the host, which results in passing -fforward-propagate to the build machine's gcc, which isn't supported in older versions. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'recipes/ncurses')
-rw-r--r--recipes/ncurses/ncurses.inc3
-rw-r--r--recipes/ncurses/ncurses_5.4.bb3
2 files changed, 4 insertions, 2 deletions
diff --git a/recipes/ncurses/ncurses.inc b/recipes/ncurses/ncurses.inc
index 3cf6a57e60..bebdeb4cb4 100644
--- a/recipes/ncurses/ncurses.inc
+++ b/recipes/ncurses/ncurses.inc
@@ -32,8 +32,7 @@ export EXTRA_OEMAKE = '"BUILD_LDFLAGS=" "BUILD_CCFLAGS=${BUILD_CCFLAGS}"'
# Below option is added to overcome the GCC bug on ARM
# see http://gcc.gnu.org/PR42981 for further details.
# We could potentially take it off when its fixed in gcc 4.5
-
-CFLAGS_append_arm = " -fforward-propagate "
+CFLAGS_EXTRA_append_arm = " -fforward-progagate"
# This is necessary so that the "tic" command executed during the install can
# link with the correct libary in staging.
diff --git a/recipes/ncurses/ncurses_5.4.bb b/recipes/ncurses/ncurses_5.4.bb
index 50231a0e3e..5726110ff1 100644
--- a/recipes/ncurses/ncurses_5.4.bb
+++ b/recipes/ncurses/ncurses_5.4.bb
@@ -12,7 +12,10 @@ LEAD_SONAME = "libncurses.so.5"
SRC_URI[md5sum] = "069c8880072060373290a4fefff43520"
SRC_URI[sha256sum] = "5abce063cf431790f4e6a801a96c7eea0b33a41ecd0970f6312f52575c083b36"
+CFLAGS += "${CFLAGS_EXTRA}"
BBCLASSEXTEND = "native nativesdk sdk"
+CFLAGS_EXTRA_virtclass-native = ""
+CFLAGS_EXTRA_virtclass-sdk = ""
DEPENDS_virtclass-native = ""
EXTRA_OEMAKE_virtclass-native = '"BUILD_CCFLAGS=${BUILD_CCFLAGS}"'
EXTRA_OEMAKE_virtclass-sdk = '"BUILD_CCFLAGS=${BUILD_CCFLAGS}"'