aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ncurses
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-02 13:03:21 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-05 06:52:41 -0700
commitbe8c14f9c3f31bb56ef442156a04465d2efd2270 (patch)
treebbbc74e2ff74d66430e49199385a6e5bb2f041bb /recipes/ncurses
parent4f52d2c50f62e998df9b06d333b9c7f02dd8dcac (diff)
downloadopenembedded-be8c14f9c3f31bb56ef442156a04465d2efd2270.tar.gz
ncurses: Add -fforward-propagate on arm.
* Needed on -O1 compile. Generally we use -Os where this option is already enabled. But we enable is anyway so it gets picked at -O1 too which we use with DEBUG builds. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/ncurses')
-rw-r--r--recipes/ncurses/ncurses.inc11
-rw-r--r--recipes/ncurses/ncurses_5.4.bb2
2 files changed, 7 insertions, 6 deletions
diff --git a/recipes/ncurses/ncurses.inc b/recipes/ncurses/ncurses.inc
index bfecfff1bb..337d670cc5 100644
--- a/recipes/ncurses/ncurses.inc
+++ b/recipes/ncurses/ncurses.inc
@@ -30,6 +30,12 @@ export BUILD_CCFLAGS = "-I${S}/ncurses -I${S}/include ${BUILD_CFLAGS}"
export BUILD_LDFLAGS = ""
export EXTRA_OEMAKE = '"BUILD_LDFLAGS=" "BUILD_CCFLAGS=${BUILD_CCFLAGS}"'
+# Below option is added to overcome the GCC bug on ARM
+# see http://gcc.gnu.org/PR42981 for further details.
+# We could potentially take it off when its fixed in gcc 4.5
+
+CFLAGS_append_arm = " -fforward-propagate "
+
# This is necessary so that the "tic" command executed during the install can
# link with the correct libary in staging.
export LD_LIBRARY_PATH = "${STAGING_LIBDIR_NATIVE}"
@@ -70,16 +76,12 @@ do_install() {
mv ${D}${bindir}/reset ${D}${bindir}/reset.${PN}
fi
}
-
-
pkg_postinst_ncurses-tools () {
if [ "${PN}" = "ncurses" ]; then
update-alternatives --install ${bindir}/clear clear clear.${PN} 100
update-alternatives --install ${bindir}/reset reset reset.${PN} 100
fi
}
-
-
pkg_prerm_ncurses-tools () {
if [ "${PN}" = "ncurses" ]; then
update-alternatives --remove clear clear.${PN}
@@ -110,7 +112,6 @@ FILES_${PN}-tools = "\
FILES_${PN}-terminfo = "\
${datadir}/terminfo \
"
-
RSUGGESTS_${PN} = "ncurses-terminfo"
RPROVIDES_${PN} = "libncurses5"
RCONFLICTS_${PN} = "libncurses5"
diff --git a/recipes/ncurses/ncurses_5.4.bb b/recipes/ncurses/ncurses_5.4.bb
index a6aed6dcef..8c0f62c48a 100644
--- a/recipes/ncurses/ncurses_5.4.bb
+++ b/recipes/ncurses/ncurses_5.4.bb
@@ -1,4 +1,4 @@
-PR = "r19"
+PR = "r20"
SRC_URI = "${GNU_MIRROR}/ncurses/ncurses-${PV}.tar.gz \
file://makefile_tweak.patch \