aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/net-snmp/net-snmp_5.4.2.1.bb
diff options
context:
space:
mode:
authorEvan Doiron <edoiron@cbnco.com>2009-08-25 09:49:43 +0000
committerMichael Smith <msmith@cbnco.com>2009-08-31 11:57:45 -0400
commit199c29075ef45515047c02555bc6fd1ff2f8ee8c (patch)
tree039bba07545096b1898d4aa3670bbad16a88f250 /recipes/net-snmp/net-snmp_5.4.2.1.bb
parent2d5f5e12bb0e9ac682d84cabcf678829cc9a9b87 (diff)
downloadopenembedded-199c29075ef45515047c02555bc6fd1ff2f8ee8c.tar.gz
net-snmp: add v5.4.2.1
Signed-off-by: Evan Doiron <edoiron@cbnco.com> Signed-off-by: Michael Smith <msmith@cbnco.com>
Diffstat (limited to 'recipes/net-snmp/net-snmp_5.4.2.1.bb')
-rw-r--r--recipes/net-snmp/net-snmp_5.4.2.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/net-snmp/net-snmp_5.4.2.1.bb b/recipes/net-snmp/net-snmp_5.4.2.1.bb
new file mode 100644
index 0000000000..3c51a5fa3c
--- /dev/null
+++ b/recipes/net-snmp/net-snmp_5.4.2.1.bb
@@ -0,0 +1,26 @@
+require net-snmp.inc
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz \
+ file://configure-tail.patch;patch=1 \
+ file://init \
+ file://snmpd.conf \
+ file://snmptrapd.conf"
+
+EXTRA_OECONF = "--enable-shared --disable-manuals --with-defaults \
+ --disable-embedded-perl --with-perl-modules=no"
+EXTRA_OEMAKE = "INSTALL_PREFIX=${D}"
+
+do_configure_prepend() {
+ gnu-configize -f
+ # We better change sources and re-autoconf here, but
+ # required autoconf is too new for us.
+ sed -e '/echo.*\".*\\\\.*\"/s/echo/echo -e/g' \
+ -e 's/tail -1/tail -n 1/g' \
+ -i configure
+
+ #The tarball for v5.4.2.1 is missing config.sub
+ cp ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
+}
+
+PARALLEL_MAKE = ""
+CCACHE = ""