aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/net-snmp
diff options
context:
space:
mode:
authorJan Lübbe <jluebbe@debian.org>2009-09-09 13:57:50 +0000
committerJan Lübbe <jluebbe@debian.org>2009-09-18 08:04:37 +0000
commit6adf15ce211e6111567fa66a282ffcaae4fa58c7 (patch)
tree7848f77aacc6c2d32958ade2dade8e7d778194a9 /recipes/net-snmp
parent07f750c6382476b799201b5ca47f93a5f7aa7e84 (diff)
downloadopenembedded-6adf15ce211e6111567fa66a282ffcaae4fa58c7.tar.gz
net-snmp: add recipe for perl bindings
It seems hard to convince net-snmp's build system to crossbuild the perl bindings, so i use a new recipe.
Diffstat (limited to 'recipes/net-snmp')
-rw-r--r--recipes/net-snmp/libsnmp-perl_5.4.2.1.bb13
-rw-r--r--recipes/net-snmp/libsnmp-perl_svn.bb13
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes/net-snmp/libsnmp-perl_5.4.2.1.bb b/recipes/net-snmp/libsnmp-perl_5.4.2.1.bb
new file mode 100644
index 0000000000..135260132a
--- /dev/null
+++ b/recipes/net-snmp/libsnmp-perl_5.4.2.1.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Perl module from net-snmp"
+SECTION = "libs"
+LICENSE = "BSD"
+DEPENDS = "net-snmp"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.tar.gz"
+
+S = "${WORKDIR}/net-snmp-${PV}/perl"
+
+inherit cpan
+
+EXTRA_CPANFLAGS = "-NET-SNMP-CONFIG=\"sh ${STAGING_BINDIR}/net-snmp-config\""
diff --git a/recipes/net-snmp/libsnmp-perl_svn.bb b/recipes/net-snmp/libsnmp-perl_svn.bb
new file mode 100644
index 0000000000..729a3d944b
--- /dev/null
+++ b/recipes/net-snmp/libsnmp-perl_svn.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Perl module from net-snmp"
+SECTION = "libs"
+LICENSE = "BSD"
+DEPENDS = "net-snmp"
+PR = "r2"
+
+SRC_URI = "svn://net-snmp.svn.sourceforge.net/svnroot/net-snmp/trunk;rev=17367;module=net-snmp;proto=https"
+
+S = "${WORKDIR}/net-snmp/perl"
+
+inherit cpan
+
+EXTRA_CPANFLAGS = "-NET-SNMP-CONFIG=${STAGING_BINDIR}/net-snmp-config -NET-SNMP-IN-SOURCE=false"