aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netbase
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2009-06-15 09:19:40 +0100
committerPhil Blundell <philb@gnu.org>2009-06-15 09:19:40 +0100
commit87a447e42bb298e96cb3b10ced23d944454870a0 (patch)
tree73829552334c9d82eb561f9cb0d1139201690b78 /recipes/netbase
parent2088234985ba46a767634f0959690015c4f032ce (diff)
downloadopenembedded-87a447e42bb298e96cb3b10ced23d944454870a0.tar.gz
netbase: don't ship update-inetd if not doing online package management
Diffstat (limited to 'recipes/netbase')
-rw-r--r--recipes/netbase/netbase_4.21.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/netbase/netbase_4.21.bb b/recipes/netbase/netbase_4.21.bb
index 4dfc18223a..c0c97b73bf 100644
--- a/recipes/netbase/netbase_4.21.bb
+++ b/recipes/netbase/netbase_4.21.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "This package provides the necessary \
infrastructure for basic TCP/IP based networking."
SECTION = "base"
LICENSE = "GPL"
-PR = "r35"
+PR = "r36"
inherit update-rc.d
@@ -51,8 +51,10 @@ do_install () {
install -m 0644 etc-rpc ${D}${sysconfdir}/rpc
install -m 0644 etc-protocols ${D}${sysconfdir}/protocols
install -m 0644 etc-services ${D}${sysconfdir}/services
+ if [ "${ONLINE_PACKAGE_MANAGEMENT}" != "none" ]; then
install -m 0755 update-inetd ${D}${sbindir}/
install -m 0644 update-inetd.8 ${D}${mandir}/man8/
+ fi
install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
}