aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netcat
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2009-05-19 15:22:09 +0200
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-05-19 15:22:56 +0200
commit8379f149a2aec4de98f7376b37e6213dccc0c1b2 (patch)
tree6f9fb0dc7d9711869d9e0d48f023132b1f552e70 /recipes/netcat
parent72060aa173aeae99866845ba3c1b92f5c615add0 (diff)
downloadopenembedded-8379f149a2aec4de98f7376b37e6213dccc0c1b2.tar.gz
netcat: use update-alternatives as we have netcat in busybox too
Diffstat (limited to 'recipes/netcat')
-rw-r--r--recipes/netcat/netcat_0.7.1.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/recipes/netcat/netcat_0.7.1.bb b/recipes/netcat/netcat_0.7.1.bb
index c7ceccddf2..cc5b9e2d6e 100644
--- a/recipes/netcat/netcat_0.7.1.bb
+++ b/recipes/netcat/netcat_0.7.1.bb
@@ -2,8 +2,20 @@ DESCRIPTION = "GNU Netcat"
HOMEPAGE = "http://netcat.sourceforge.net"
SECTION = "console/network"
LICENSE = "GPLv2"
-PR = "r1"
+PR = "r2"
SRC_URI = "${SOURCEFORGE_MIRROR}/netcat/netcat-${PV}.tar.bz2"
inherit autotools
+
+do_install_append() {
+ mv ${D}${bindir}/nc ${D}${bindir}/nc.${PN}
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${bindir}/nc nc nc.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove nc nc.${PN}
+}