aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netsurf
diff options
context:
space:
mode:
authorAlex Ferguson <thoughtmonster@gmail.com>2010-11-27 21:04:02 +0200
committerKristoffer Ericson <kristoffer.ericson@gmail.com>2010-11-27 20:33:04 +0100
commit38fbc4fad56ec527a5a06373beb736c74d94f5d3 (patch)
tree7d5dd5118623ff100073d96b81d5170ec81bc5b8 /recipes/netsurf
parentadeaa68d8c673d39adb05a39cdf078b59e87ef1d (diff)
downloadopenembedded-38fbc4fad56ec527a5a06373beb736c74d94f5d3.tar.gz
netsurf: Remove old/obsolete recipes, update netsurf-fb
Removed older versions of recipes for netsurf and its dependancies which were accidentally left behind in the last update. Bumped SRCREV for netsurf-fb for some important framebuffer related changes in the upstream source. Signed-off-by: Alex Ferguson <thoughtmonster@gmail.com> Signed-off-by: Kristoffer Ericson <kristoffer.ericson@gmail.com>
Diffstat (limited to 'recipes/netsurf')
-rw-r--r--recipes/netsurf/files/hubbub-uninitialised.patch35
-rw-r--r--recipes/netsurf/files/libnsgif-strict-aliasing.patch82
-rw-r--r--recipes/netsurf/files/netsurf.desktop10
-rw-r--r--recipes/netsurf/hubbub_0.0.1.bb34
-rw-r--r--recipes/netsurf/libnsbmp_0.0.1.bb27
-rw-r--r--recipes/netsurf/libnsgif_0.0.1.bb30
-rw-r--r--recipes/netsurf/libparserutils_0.0.1.bb39
-rw-r--r--recipes/netsurf/netsurf-2.1/Makefile.config9
-rw-r--r--recipes/netsurf/netsurf-2.1/debugxml_fix.patch64
-rw-r--r--recipes/netsurf/netsurf-2.1/fix_makefile.patch12
-rw-r--r--recipes/netsurf/netsurf-2.1/netsurf.desktop10
-rw-r--r--recipes/netsurf/netsurf-2.1/netsurf.pngbin9329 -> 0 bytes
-rw-r--r--recipes/netsurf/netsurf-fb_svn.bb2
-rw-r--r--recipes/netsurf/netsurf_2.1.bb37
14 files changed, 1 insertions, 390 deletions
diff --git a/recipes/netsurf/files/hubbub-uninitialised.patch b/recipes/netsurf/files/hubbub-uninitialised.patch
deleted file mode 100644
index 4f87120c31..0000000000
--- a/recipes/netsurf/files/hubbub-uninitialised.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-http://source.netsurf-browser.org/?view=rev&revision=7398
-Initialise variables to stop GCC 4.4 complaining (credit: Jeroen Habraken)
-
---- hubbub/src/tokeniser/tokeniser.c 2009/04/06 15:22:16 7052
-+++ hubbub/src/tokeniser/tokeniser.c 2009/05/05 17:18:41 7398
-@@ -787,7 +787,7 @@
- + 1);
- } else {
- parserutils_error error;
-- const uint8_t *cptr;
-+ const uint8_t *cptr = NULL;
- error = parserutils_inputstream_peek(
- tokeniser->input,
- tokeniser->context.pending,
-@@ -1590,8 +1590,8 @@
- tokeniser->context.match_entity.length
- + 1;
- } else {
-- size_t len;
-- const uint8_t *cptr;
-+ size_t len = 0;
-+ const uint8_t *cptr = NULL;
- parserutils_error error;
-
- error = parserutils_inputstream_peek(
-@@ -3137,7 +3137,7 @@
- {
- hubbub_token token;
- size_t len;
-- const uint8_t *cptr;
-+ const uint8_t *cptr = NULL;
- parserutils_error error;
-
- /* Calling this with nothing to output is a probable bug */
-
diff --git a/recipes/netsurf/files/libnsgif-strict-aliasing.patch b/recipes/netsurf/files/libnsgif-strict-aliasing.patch
deleted file mode 100644
index 4fe913c491..0000000000
--- a/recipes/netsurf/files/libnsgif-strict-aliasing.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-http://source.netsurf-browser.org/?view=rev&revision=9027
-Stop utterly insane palette entry population.
-Palette entries are always ABGR, regardless of platform endianness.
-This change probably breaks big-endian platforms which, under the old approach,
-had palette entries of the form RGBA (assuming I understood the code correctly).
-
-http://source.netsurf-browser.org/?view=rev&revision=9138
-Fix palette entry population some more. Hopefully, it's completely endian
-agnostic now and still builds with GCC 4.4
-
---- libnsgif/src/libnsgif.c 2009/03/29 01:43:27 6984
-+++ libnsgif/src/libnsgif.c 2009/08/09 22:24:14 9138
-@@ -319,19 +319,34 @@
- return GIF_INSUFFICIENT_DATA;
- }
- for (index = 0; index < gif->colour_table_size; index++) {
-- char colour[] = {0, 0, 0, (char)0xff};
-- colour[0] = gif_data[0];
-- colour[1] = gif_data[1];
-- colour[2] = gif_data[2];
-- gif->global_colour_table[index] = *((int *) (void *) colour);
-+ /* Gif colour map contents are r,g,b.
-+ *
-+ * We want to pack them bytewise into the
-+ * colour table, such that the red component
-+ * is in byte 0 and the alpha component is in
-+ * byte 3.
-+ */
-+ unsigned char *entry = (unsigned char *) &gif->
-+ global_colour_table[index];
-+
-+ entry[0] = gif_data[0]; /* r */
-+ entry[1] = gif_data[1]; /* g */
-+ entry[2] = gif_data[2]; /* b */
-+ entry[3] = 0xff; /* a */
-+
- gif_data += 3;
- }
- gif->buffer_position = (gif_data - gif->gif_data);
- } else {
- /* Create a default colour table with the first two colours as black and white
- */
-- gif->global_colour_table[0] = 0xff000000;
-- gif->global_colour_table[1] = 0xffffffff;
-+ unsigned int *entry = gif->global_colour_table;
-+
-+ entry[0] = 0x00000000;
-+ /* Force Alpha channel to opaque */
-+ ((unsigned char *) entry)[3] = 0xff;
-+
-+ entry[1] = 0xffffffff;
- }
- }
-
-@@ -844,11 +859,21 @@
- colour_table = gif->local_colour_table;
- if (!clear_image) {
- for (index = 0; index < colour_table_size; index++) {
-- char colour[] = {0, 0, 0, (char)0xff};
-- colour[0] = gif_data[0];
-- colour[1] = gif_data[1];
-- colour[2] = gif_data[2];
-- colour_table[index] = *((int *) (void *) colour);
-+ /* Gif colour map contents are r,g,b.
-+ *
-+ * We want to pack them bytewise into the
-+ * colour table, such that the red component
-+ * is in byte 0 and the alpha component is in
-+ * byte 3.
-+ */
-+ unsigned char *entry =
-+ (unsigned char *) &colour_table[index];
-+
-+ entry[0] = gif_data[0]; /* r */
-+ entry[1] = gif_data[1]; /* g */
-+ entry[2] = gif_data[2]; /* b */
-+ entry[3] = 0xff; /* a */
-+
- gif_data += 3;
- }
- } else {
-
diff --git a/recipes/netsurf/files/netsurf.desktop b/recipes/netsurf/files/netsurf.desktop
deleted file mode 100644
index 4188d3019d..0000000000
--- a/recipes/netsurf/files/netsurf.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=NetSurf
-Comment=NetSurf Web Browser
-GenericName=Web Browser
-Icon=netsurf
-Exec=netsurf
-Terminal=false
-StartupNotify=false
-Categories=Network;WebBrowser;
diff --git a/recipes/netsurf/hubbub_0.0.1.bb b/recipes/netsurf/hubbub_0.0.1.bb
deleted file mode 100644
index 88a6ce7b92..0000000000
--- a/recipes/netsurf/hubbub_0.0.1.bb
+++ /dev/null
@@ -1,34 +0,0 @@
-DESCRIPTION = "Hubbub is an HTML5 compliant parsing library"
-HOMEPAGE = "http://www.netsurf-browser.org/projects/hubbub/"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "MIT"
-DEPENDS = "libparserutils"
-
-SRC_URI = "http://www.netsurf-browser.org/projects/releases/hubbub-${PV}-src.tar.gz \
- file://hubbub-uninitialised.patch"
-
-PR = "r1"
-
-inherit pkgconfig
-
-EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
-
-# NOTE: we're using default buildmode here, which results in building only
-# static libraries (.a) Not a problem as hubbub is only used by Netsurf
-# at the moment
-
-do_stage() {
- oe_libinstall -a -C build-OE/ libhubbub ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/hubbub
- install -m 0644 include/hubbub/*.h ${STAGING_INCDIR}/hubbub
-}
-
-
-do_install() {
- oe_runmake install
-}
-
-SRC_URI[md5sum] = "58c6e2b5a5906f3f0bf136c0c71b5403"
-SRC_URI[sha256sum] = "3ba0bdf71376429bb3ce8ae51595fc25e6a5147cdcc26e47b6da17386eb78cdf"
diff --git a/recipes/netsurf/libnsbmp_0.0.1.bb b/recipes/netsurf/libnsbmp_0.0.1.bb
deleted file mode 100644
index 96b48c2999..0000000000
--- a/recipes/netsurf/libnsbmp_0.0.1.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "Libnsbmp is a decoding library for the BMP and ICO image file formats"
-HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsbmp/"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "MIT"
-
-SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsbmp-${PV}-src.tar.gz"
-
-inherit pkgconfig
-
-EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
-
-# NOTE: we're using default buildmode here, which results in building only
-# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
-# at the moment
-
-do_stage() {
- oe_libinstall -a -C build-OE/ libnsbmp ${STAGING_LIBDIR}
- install -m 0644 include/*.h ${STAGING_INCDIR}/
-}
-
-do_install() {
- oe_runmake install
-}
-
-SRC_URI[md5sum] = "61e1e5703580c1bc7d950a1aacea7bad"
-SRC_URI[sha256sum] = "424d12aae7a6ea8c90438cf4ccff486dc01a3a2a7b68eb602ee2b8c28178b6d1"
diff --git a/recipes/netsurf/libnsgif_0.0.1.bb b/recipes/netsurf/libnsgif_0.0.1.bb
deleted file mode 100644
index 4845398ca8..0000000000
--- a/recipes/netsurf/libnsgif_0.0.1.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "Libnsgif is a decoding library for the GIF image file format"
-HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsgif/"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "MIT"
-
-SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsgif-${PV}-src.tar.gz \
- file://libnsgif-strict-aliasing.patch"
-
-PR = "r1"
-
-inherit pkgconfig
-
-EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
-
-# NOTE: we're using default buildmode here, which results in building only
-# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
-# at the moment
-
-do_stage() {
- oe_libinstall -a -C build-OE/ libnsgif ${STAGING_LIBDIR}
- install -m 0644 include/*.h ${STAGING_INCDIR}/
-}
-
-do_install() {
- oe_runmake install
-}
-
-SRC_URI[md5sum] = "a547da766fccacd00fd05190baf644da"
-SRC_URI[sha256sum] = "54f316f530caaacd55dc23f546537759382a45ac6378ead249b5a5d51cf4db52"
diff --git a/recipes/netsurf/libparserutils_0.0.1.bb b/recipes/netsurf/libparserutils_0.0.1.bb
deleted file mode 100644
index 56bc4d0ae7..0000000000
--- a/recipes/netsurf/libparserutils_0.0.1.bb
+++ /dev/null
@@ -1,39 +0,0 @@
-DESCRIPTION = "LibParserUtils is a library for building efficient parsers"
-HOMEPAGE = "http://www.netsurf-browser.org/projects/libparserutils/"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "MIT"
-
-SRC_URI = "http://www.netsurf-browser.org/projects/releases/libparserutils-${PV}-src.tar.gz"
-
-inherit pkgconfig
-
-EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
-
-# NOTE: we're using default buildmode here, which results in building only
-# static libraries (.a) Not a problem as libparserutils is only used by Netsurf
-# at the moment
-
-do_stage () {
- oe_libinstall -a -C build-OE/ libparserutils ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/parserutils
- install -d ${STAGING_INCDIR}/parserutils/charset
- install -d ${STAGING_INCDIR}/parserutils/input
- install -d ${STAGING_INCDIR}/parserutils/utils
- install -m 0644 include/parserutils/*.h ${STAGING_INCDIR}/parserutils
- install -m 0644 include/parserutils/charset/*.h \
- ${STAGING_INCDIR}/parserutils/charset
- install -m 0644 include/parserutils/input/*.h \
- ${STAGING_INCDIR}/parserutils/input
- install -m 0644 include/parserutils/utils/*.h \
- ${STAGING_INCDIR}/parserutils/utils
-}
-
-
-do_install() {
- oe_runmake install
-}
-
-SRC_URI[md5sum] = "5999c2d52f8c07eeef2a8808fee4f858"
-SRC_URI[sha256sum] = "5aed4edfd2023ed3ccd566fe76131d10faf43c8c3efa2e90978eed37c5503165"
diff --git a/recipes/netsurf/netsurf-2.1/Makefile.config b/recipes/netsurf/netsurf-2.1/Makefile.config
deleted file mode 100644
index 72c86003f5..0000000000
--- a/recipes/netsurf/netsurf-2.1/Makefile.config
+++ /dev/null
@@ -1,9 +0,0 @@
-override NETSURF_USE_BMP := YES
-override NETSURF_USE_GIF := YES
-override NETSURF_USE_JPEG := YES
-override NETSURF_USE_PNG := YES
-override NETSURF_USE_MNG := NO
-override NETSURF_USE_HARU_PDF := NO
-override NETSURF_USE_RSVG := NO
-override NETSURF_USE_ROSPRITE := NO
-
diff --git a/recipes/netsurf/netsurf-2.1/debugxml_fix.patch b/recipes/netsurf/netsurf-2.1/debugxml_fix.patch
deleted file mode 100644
index 3a6626abe8..0000000000
--- a/recipes/netsurf/netsurf-2.1/debugxml_fix.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- netsurf-2.0/gtk/gtk_scaffolding.c.orig 2009-05-15 01:18:44.000000000 +0400
-+++ netsurf-2.0/gtk/gtk_scaffolding.c 2009-05-15 01:24:32.000000000 +0400
-@@ -22,7 +22,6 @@
- #include <stdlib.h>
- #include <string.h>
- #include <gtk/gtk.h>
--#include <libxml/debugXML.h>
- #include "content/content.h"
- #include "desktop/browser.h"
- #include "desktop/history_core.h"
-@@ -1040,52 +1039,7 @@
-
- MENUHANDLER(save_dom_tree)
- {
-- GtkWidget *save_dialog;
-- struct gtk_scaffolding *gw = (struct gtk_scaffolding *)g;
--
-- save_dialog = gtk_file_chooser_dialog_new("Save File", gw->window,
-- GTK_FILE_CHOOSER_ACTION_SAVE,
-- GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL,
-- GTK_STOCK_SAVE, GTK_RESPONSE_ACCEPT,
-- NULL);
--
-- gtk_file_chooser_set_current_folder(GTK_FILE_CHOOSER(save_dialog),
-- getenv("HOME") ? getenv("HOME") : "/");
--
-- gtk_file_chooser_set_current_name(GTK_FILE_CHOOSER(save_dialog),
-- "domtree.txt");
--
-- if (gtk_dialog_run(GTK_DIALOG(save_dialog)) == GTK_RESPONSE_ACCEPT) {
-- gchar *filename = gtk_file_chooser_get_filename(
-- GTK_FILE_CHOOSER(save_dialog));
-- FILE *fh;
-- LOG(("Saving dom tree to %s...\n", filename));
--
-- fh = fopen((const char *) filename, "w");
-- if (fh == NULL) {
-- warn_user("Error saving box tree dump.",
-- "Unable to open file for writing.");
-- } else {
-- struct browser_window *bw;
-- bw = nsgtk_get_browser_window(gw->top_level);
--
-- if (bw->current_content &&
-- bw->current_content->type ==
-- CONTENT_HTML) {
-- xmlDebugDumpDocument(fh,
-- bw->current_content->
-- data.html.document);
-- }
--
-- fclose(fh);
-- }
--
-- g_free(filename);
-- }
--
-- gtk_widget_destroy(save_dialog);
--
-- return TRUE;
-+ return FALSE;
- }
-
-
diff --git a/recipes/netsurf/netsurf-2.1/fix_makefile.patch b/recipes/netsurf/netsurf-2.1/fix_makefile.patch
deleted file mode 100644
index 1783921d1e..0000000000
--- a/recipes/netsurf/netsurf-2.1/fix_makefile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: Makefile
-===================================================================
---- a/Makefile (revision 7536)
-+++ b/Makefile (working copy)
-@@ -820,7 +820,6 @@
- @cp -vRL gtk/res/netsurf-16x16.xpm $(DESTDIR)$(NETSURF_GTK_RESOURCES)
- @cp -vRL gtk/res/throbber/*.png $(DESTDIR)$(NETSURF_GTK_RESOURCES)/throbber
- @cp -vRL gtk/res/Aliases $(DESTDIR)$(NETSURF_GTK_RESOURCES)
-- @cp -vrL gtk/res/docs $(DESTDIR)/$(NETSURF_GTK_RESOURCES)
- gzip -9v < gtk/res/messages > $(DESTDIR)$(NETSURF_GTK_RESOURCES)messages
- gzip -9v < gtk/res/downloads.glade > $(DESTDIR)$(NETSURF_GTK_RESOURCES)downloads.glade
- gzip -9v < gtk/res/netsurf.glade > $(DESTDIR)$(NETSURF_GTK_RESOURCES)netsurf.glade
diff --git a/recipes/netsurf/netsurf-2.1/netsurf.desktop b/recipes/netsurf/netsurf-2.1/netsurf.desktop
deleted file mode 100644
index 4188d3019d..0000000000
--- a/recipes/netsurf/netsurf-2.1/netsurf.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=NetSurf
-Comment=NetSurf Web Browser
-GenericName=Web Browser
-Icon=netsurf
-Exec=netsurf
-Terminal=false
-StartupNotify=false
-Categories=Network;WebBrowser;
diff --git a/recipes/netsurf/netsurf-2.1/netsurf.png b/recipes/netsurf/netsurf-2.1/netsurf.png
deleted file mode 100644
index 3064e5d4f3..0000000000
--- a/recipes/netsurf/netsurf-2.1/netsurf.png
+++ /dev/null
Binary files differ
diff --git a/recipes/netsurf/netsurf-fb_svn.bb b/recipes/netsurf/netsurf-fb_svn.bb
index 3d384be1ba..692da98043 100644
--- a/recipes/netsurf/netsurf-fb_svn.bb
+++ b/recipes/netsurf/netsurf-fb_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "NetSurf is a lightweight, multi-platform web browser."
HOMEPAGE = "http://www.netsurf-browser.org/"
SECTION = "x11/network"
LICENSE = "GPLv2"
-SRCREV = "10946"
+SRCREV = "10950"
PV = "2.6+svnr${SRCPV}"
PR = "r0"
diff --git a/recipes/netsurf/netsurf_2.1.bb b/recipes/netsurf/netsurf_2.1.bb
deleted file mode 100644
index 3aeae0c8c7..0000000000
--- a/recipes/netsurf/netsurf_2.1.bb
+++ /dev/null
@@ -1,37 +0,0 @@
-DESCRIPTION = "Lightweight web browser capable of handling many of the \
-web standards in use today."
-HOMEPAGE = "http://www.netsurf-browser.org/"
-SECTION = "x11/network"
-LICENSE = "GPLv2"
-
-SRC_URI = "http://www.netsurf-browser.org/downloads/releases/netsurf-${PV}-src.tar.gz \
- file://fix_makefile.patch \
- file://debugxml_fix.patch \
- file://netsurf.png \
- file://netsurf.desktop \
- file://Makefile.config"
-
-PR = "r1"
-
-# Workaround for 2.1 tarball (unpacks into netsurf/, not netsurf-2.1/ )
-S = "${WORKDIR}/netsurf"
-
-DEPENDS = "gtk+ lemon-native re2c-native jpeg openssl curl libxml2 \
- libglade hubbub libnsgif libnsbmp lcms"
-
-EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix}"
-
-do_configure() {
- cp ${WORKDIR}/Makefile.config ${S}/
-}
-
-do_install() {
- oe_runmake install
- install -d ${D}/${datadir}/applications
- install -d ${D}/${datadir}/pixmaps
- install -m 0644 ${WORKDIR}/netsurf.png ${D}/${datadir}/pixmaps/
- install -m 0644 ${WORKDIR}/netsurf.desktop ${D}/${datadir}/applications/
-}
-
-SRC_URI[md5sum] = "f0a34fd076b492c1a13b45432e8d7e49"
-SRC_URI[sha256sum] = "cda2cf41c852938c226c47c2b995d527387120141f68b416ea745e50a7165a81"