aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/netsurf
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2009-05-23 10:35:17 +0000
committerTom Rini <trini@embeddedalley.com>2009-05-30 12:32:44 -0400
commit6adb84f4f4d5b43e9ef85f156228dc2c0f04afe3 (patch)
tree2023905aa15a55c95c80458270ae7d8ca17dd877 /recipes/netsurf
parentf18439433c8795e31da60d20a2c49fb343db9dfb (diff)
downloadopenembedded-6adb84f4f4d5b43e9ef85f156228dc2c0f04afe3.tar.gz
libnsgif: add recipe for version 0.0.1
libnsgif is GIF decoding library. Currently only Netsurf browser is using it, so we build just static library. Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru> Acked-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes/netsurf')
-rw-r--r--recipes/netsurf/libnsgif_0.0.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/netsurf/libnsgif_0.0.1.bb b/recipes/netsurf/libnsgif_0.0.1.bb
new file mode 100644
index 0000000000..3b9cfc2930
--- /dev/null
+++ b/recipes/netsurf/libnsgif_0.0.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Libnsgif is a decoding library for the GIF image file format"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsgif/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsgif-${PV}-src.tar.gz"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libnsgif ${STAGING_LIBDIR}
+ install -m 0644 include/*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_runmake install
+}