summaryrefslogtreecommitdiffstats
path: root/recipes/netsurf
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2009-05-23 10:35:18 +0000
committerTom Rini <trini@embeddedalley.com>2009-05-30 12:32:44 -0400
commit13cae2bad12a26706f60768572ca23cdb74a60e7 (patch)
tree2da274ef991f3ef7c4091683a81ac3ae95a14a29 /recipes/netsurf
parent6adb84f4f4d5b43e9ef85f156228dc2c0f04afe3 (diff)
downloadopenembedded-13cae2bad12a26706f60768572ca23cdb74a60e7.tar.gz
libparserutils: add recipe for version 0.0.1
LibParserUtils is a library for building efficient parsers. Currently only Netsurf browser is using it (via hubbub), so we build just static library. Please note that this build doesn't use external iconv(), so only few built-in charsets are supported (UTF-8/16, windows-125x, iso-8859-*) We may revisit this later, if there's a need. Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru> Acked-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes/netsurf')
-rw-r--r--recipes/netsurf/libparserutils_0.0.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/netsurf/libparserutils_0.0.1.bb b/recipes/netsurf/libparserutils_0.0.1.bb
new file mode 100644
index 0000000000..5317364a84
--- /dev/null
+++ b/recipes/netsurf/libparserutils_0.0.1.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "LibParserUtils is a library for building efficient parsers"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/libparserutils/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/libparserutils-${PV}-src.tar.gz"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as libparserutils is only used by Netsurf
+# at the moment
+
+do_stage () {
+ oe_libinstall -a -C build-OE/ libparserutils ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/parserutils
+ install -d ${STAGING_INCDIR}/parserutils/charset
+ install -d ${STAGING_INCDIR}/parserutils/input
+ install -d ${STAGING_INCDIR}/parserutils/utils
+ install -m 0644 include/parserutils/*.h ${STAGING_INCDIR}/parserutils
+ install -m 0644 include/parserutils/charset/*.h \
+ ${STAGING_INCDIR}/parserutils/charset
+ install -m 0644 include/parserutils/input/*.h \
+ ${STAGING_INCDIR}/parserutils/input
+ install -m 0644 include/parserutils/utils/*.h \
+ ${STAGING_INCDIR}/parserutils/utils
+}
+
+
+do_install() {
+ oe_runmake install
+}