summaryrefslogtreecommitdiffstats
path: root/recipes/netsurf
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2009-05-23 10:35:19 +0000
committerTom Rini <trini@embeddedalley.com>2009-05-30 12:32:45 -0400
commitb66852caed52146efcb1ae8145d535780ae6c943 (patch)
treeb6220993f2ad3f09e79e5a572eb1b2befcba3e86 /recipes/netsurf
parent13cae2bad12a26706f60768572ca23cdb74a60e7 (diff)
downloadopenembedded-b66852caed52146efcb1ae8145d535780ae6c943.tar.gz
hubbub: add recipe for version 0.0.1
Hubbub is an HTML5 compliant parsing library, written in C. Currently only Netsurf browser is using it, so we build just static library. Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru> Acked-by: Tom Rini <trini@embeddedalley.com>
Diffstat (limited to 'recipes/netsurf')
-rw-r--r--recipes/netsurf/hubbub_0.0.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/netsurf/hubbub_0.0.1.bb b/recipes/netsurf/hubbub_0.0.1.bb
new file mode 100644
index 0000000000..0d70b4165d
--- /dev/null
+++ b/recipes/netsurf/hubbub_0.0.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Hubbub is an HTML5 compliant parsing library"
+HOMEPAGE = "http://www.netsurf-browser.org/projects/hubbub/"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+DEPENDS = "libparserutils"
+
+SRC_URI = "http://www.netsurf-browser.org/projects/releases/hubbub-${PV}-src.tar.gz"
+
+inherit pkgconfig
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
+
+# NOTE: we're using default buildmode here, which results in building only
+# static libraries (.a) Not a problem as hubbub is only used by Netsurf
+# at the moment
+
+do_stage() {
+ oe_libinstall -a -C build-OE/ libhubbub ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/hubbub
+ install -m 0644 include/hubbub/*.h ${STAGING_INCDIR}/hubbub
+}
+
+
+do_install() {
+ oe_runmake install
+}