aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nfs-utils/nfs-utils_1.0.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nfs-utils/nfs-utils_1.0.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nfs-utils/nfs-utils_1.0.6.bb')
-rw-r--r--recipes/nfs-utils/nfs-utils_1.0.6.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/recipes/nfs-utils/nfs-utils_1.0.6.bb b/recipes/nfs-utils/nfs-utils_1.0.6.bb
new file mode 100644
index 0000000000..1febf057bf
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils_1.0.6.bb
@@ -0,0 +1,77 @@
+DESCRIPTION = "userspace utilities for kernel nfs"
+PRIORITY = "optional"
+SECTION = "console/network"
+LICENSE = "GPL"
+PR = "r13"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
+ file://acinclude-lossage.patch;patch=1 \
+ file://rpcgen-lossage.patch;patch=1 \
+ file://stat-include.patch;patch=1 \
+ file://nfs-utils-1.0.6-uclibc.patch;patch=1 \
+ file://kernel-2.6.18+.patch;patch=1 \
+ file://uclibc_bzero_fix.patch;patch=1 \
+ file://nfsserver \
+ file://forgotten-defines"
+
+S = "${WORKDIR}/nfs-utils-${PV}/"
+
+PARALLEL_MAKE = ""
+
+# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
+# pull in the remainder of the dependencies.
+RDEPENDS = "portmap"
+RRECOMMENDS = "kernel-module-nfsd"
+
+INITSCRIPT_NAME = "nfsserver"
+# The server has no dependencies at the user run levels, so just put
+# it in at the default levels. It must be terminated before the network
+# in the shutdown levels, but that works fine.
+INITSCRIPT_PARAMS = "defaults"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = "--with-statduser=nobody \
+ --enable-nfsv3 \
+ --with-statedir=/var/lib/nfs"
+
+do_compile() {
+ # UGLY HACK ALERT
+ cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
+ oe_runmake 'BUILD=1'
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
+ install -m 0755 ${S}/utils/lockd/lockd ${D}${sbindir}/lockd
+ install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
+ install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
+ install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
+ install -m 0755 ${S}/utils/nhfsstone/nhfsgraph ${D}${sbindir}/nhfsgraph
+ install -m 0755 ${S}/utils/nhfsstone/nhfsnums ${D}${sbindir}/nhfsnums
+ install -m 0755 ${S}/utils/nhfsstone/nhfsrun ${D}${sbindir}/nhfsrun
+ install -m 0755 ${S}/utils/nhfsstone/nhfsstone ${D}${sbindir}/nhfsstone
+ install -m 0755 ${S}/utils/rquotad/rquotad ${D}${sbindir}/rquotad
+ install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
+ install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
+
+ install -d ${D}${mandir}/man8
+ install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
+ install -m 0644 ${S}/utils/lockd/lockd.man ${D}${mandir}/man8/lockd.8
+ install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
+ install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
+ install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsgraph.man ${D}${mandir}/man8/nhfsgraph.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsnums.man ${D}${mandir}/man8/nhfsnums.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsrun.man ${D}${mandir}/man8/nhfsrun.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsstone.man ${D}${mandir}/man8/nhfsstone.8
+ install -m 0644 ${S}/utils/rquotad/rquotad.man ${D}${mandir}/man8/rquotad.8
+ install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
+ install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
+}