aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nfs-utils/nfs-utils_1.1.2.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-11-25 14:15:34 +0100
committerMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-12-02 16:53:20 +0100
commitb8d64d4792410a1ebb8eda82f96a47bf2523148b (patch)
tree25d25465bb8a7511a39a76d74d041c59ea0c8d96 /recipes/nfs-utils/nfs-utils_1.1.2.bb
parent62e87d705baa834283746723fb7cb727a955f6db (diff)
downloadopenembedded-b8d64d4792410a1ebb8eda82f96a47bf2523148b.tar.gz
nfs-utils: use 'make install' for 1.1.2 version
This installs all tools as it should (mountd is no longer libtool wrapper). Adapted initscript for name changes (mountd is now rpc.mountd). rpcdebug is removed as it is host built - fix it if you need it (was not packaged before).
Diffstat (limited to 'recipes/nfs-utils/nfs-utils_1.1.2.bb')
-rw-r--r--recipes/nfs-utils/nfs-utils_1.1.2.bb26
1 files changed, 4 insertions, 22 deletions
diff --git a/recipes/nfs-utils/nfs-utils_1.1.2.bb b/recipes/nfs-utils/nfs-utils_1.1.2.bb
index cdd5d372cd..3951c46eff 100644
--- a/recipes/nfs-utils/nfs-utils_1.1.2.bb
+++ b/recipes/nfs-utils/nfs-utils_1.1.2.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
SECTION = "console/network"
LICENSE = "GPL"
-PR = "r6"
+PR = "r7"
DEPENDS = "e2fsprogs-libs tcp-wrappers libevent"
@@ -44,30 +44,12 @@ do_ccompile() {
INHIBIT_AUTO_STAGE = "1"
-do_install() {
+do_install_append() {
install -d ${D}${sysconfdir}/init.d
install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
- install -d ${D}${sbindir}
- install -d ${D}${base_sbindir}
- install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
- install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
- install -m 0755 ${S}/utils/mount/mount.nfs ${D}${base_sbindir}/mount.nfs
- install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
- install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
- install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
- install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
-
- ln -s ${base_sbindir}/mount.nfs ${D}/${base_sbindir}/mount.nfs4
-
- install -d ${D}${mandir}/man8
- install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
- install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
- install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
- install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
- install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
- install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
+ rm ${D}${sbindir}/rpcdebug
}
PACKAGES =+ "nfs-utils-client"
-FILES_nfs-utils-client = "${base_sbindir}/mount.nfs ${base_sbindir}/mount.nfs4"
+FILES_nfs-utils-client = "${base_sbindir}/*mount.nfs*"