aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nfs-utils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nfs-utils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nfs-utils')
-rw-r--r--recipes/nfs-utils/files/nfs-utils-1.0.6-uclibc.patch18
-rw-r--r--recipes/nfs-utils/files/nfsserver149
-rw-r--r--recipes/nfs-utils/files/uclibc_bzero_fix.patch17
-rw-r--r--recipes/nfs-utils/nfs-utils-1.0.6/acinclude-lossage.patch142
-rw-r--r--recipes/nfs-utils/nfs-utils-1.0.6/forgotten-defines5
-rw-r--r--recipes/nfs-utils/nfs-utils-1.0.6/kernel-2.6.18+.patch13
-rw-r--r--recipes/nfs-utils/nfs-utils-1.0.6/rpcgen-lossage.patch11
-rw-r--r--recipes/nfs-utils/nfs-utils-1.0.6/stat-include.patch11
-rw-r--r--recipes/nfs-utils/nfs-utils-1.1.2/nfs-utils-tools-unset-cflags.patch92
-rw-r--r--recipes/nfs-utils/nfs-utils_1.0.6.bb77
-rw-r--r--recipes/nfs-utils/nfs-utils_1.1.2.bb72
11 files changed, 607 insertions, 0 deletions
diff --git a/recipes/nfs-utils/files/nfs-utils-1.0.6-uclibc.patch b/recipes/nfs-utils/files/nfs-utils-1.0.6-uclibc.patch
new file mode 100644
index 0000000000..ebd3276be2
--- /dev/null
+++ b/recipes/nfs-utils/files/nfs-utils-1.0.6-uclibc.patch
@@ -0,0 +1,18 @@
+--- ./support/nfs/svc_socket.c.orig 2004-12-12 06:43:52.000000000 +0000
++++ ./support/nfs/svc_socket.c 2004-12-12 06:50:04.000000000 +0000
+@@ -66,6 +66,7 @@
+ __bzero ((char *) &addr, sizeof (addr));
+ addr.sin_family = AF_INET;
+
++#ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */
+ ret = getrpcbynumber_r (number, &rpcbuf, rpcdata, sizeof rpcdata,
+ &rpcp);
+ if (ret == 0 && rpcp != NULL)
+@@ -99,6 +100,7 @@
+ }
+ }
+ else
++#endif
+ {
+ if (bindresvport (sock, &addr))
+ {
diff --git a/recipes/nfs-utils/files/nfsserver b/recipes/nfs-utils/files/nfsserver
new file mode 100644
index 0000000000..0e9d7be787
--- /dev/null
+++ b/recipes/nfs-utils/files/nfsserver
@@ -0,0 +1,149 @@
+#!/bin/sh
+#
+# Startup script for nfs-utils
+#
+#
+# The environment variable NFS_SERVERS may be set in /etc/default/nfsd
+# Other control variables may be overridden here too
+test -r /etc/default/nfsd && . /etc/default/nfsd
+#
+# Location of executables:
+test -x "$NFS_MOUNTD" || NFS_MOUNTD=/usr/sbin/mountd
+test -x "$NFS_NFSD" || NFS_NFSD=/usr/sbin/nfsd
+test -x "$NFS_STATD" || NFS_STATD=/usr/sbin/statd
+#
+# The user mode program must also exist (it just starts the kernel
+# threads using the kernel module code).
+test -x "$NFS_MOUNTD" || exit 0
+test -x "$NFS_NFSD" || exit 0
+#
+# Default is 8 threads, value is settable between 1 and the truely
+# ridiculous 99
+test "$NFS_SERVERS" -gt 0 && test "$NFS_SERVERS" -lt 100 || NFS_SERVERS=8
+#
+# The default state directory is /var/lib/nfs
+test -n "$NFS_STATEDIR" || NFS_STATEDIR=/var/lib/nfs
+#
+#----------------------------------------------------------------------
+# Startup and shutdown functions.
+# Actual startup/shutdown is at the end of this file.
+#directories
+create_directories(){
+ echo -n 'creating NFS state directory: '
+ mkdir -p "$NFS_STATEDIR"
+ ( cd "$NFS_STATEDIR"
+ umask 077
+ mkdir -p sm sm.bak
+ test -w sm/state || {
+ rm -f sm/state
+ :>sm/state
+ }
+ umask 022
+ for file in xtab etab smtab rmtab
+ do
+ test -w "$file" || {
+ rm -f "$file"
+ :>"$file"
+ }
+ done
+ )
+ echo done
+}
+#mountd
+start_mountd(){
+ echo -n 'starting mountd: '
+ start-stop-daemon --start --exec "$NFS_MOUNTD" -- "-f /etc/exports $@"
+ echo done
+}
+stop_mountd(){
+ echo -n 'stopping mountd: '
+ start-stop-daemon --stop --quiet --exec "$NFS_MOUNTD"
+ echo done
+}
+#
+#nfsd
+start_nfsd(){
+ echo -n "starting $1 nfsd kernel threads: "
+ start-stop-daemon --start --exec "$NFS_NFSD" -- "$@"
+ echo done
+}
+delay_nfsd(){
+ for delay in 0 1 2 3 4 5 6 7 8 9
+ do
+ if pidof nfsd >/dev/null
+ then
+ echo -n .
+ sleep 1
+ else
+ return 0
+ fi
+ done
+ return 1
+}
+stop_nfsd(){
+ # WARNING: this kills any process with the executable
+ # name 'nfsd'.
+ echo -n 'stopping nfsd: '
+ start-stop-daemon --stop --quiet --signal 1 --name nfsd
+ if delay_nfsd || {
+ echo failed
+ echo ' using signal 9: '
+ start-stop-daemon --stop --quiet --signal 9 --name nfsd
+ delay_nfsd
+ }
+ then
+ echo done
+ # This will remove, recursively, dependencies
+ echo -n 'removing nfsd kernel module: '
+ if modprobe -r nfsd
+ then
+ echo done
+ else
+ echo failed
+ fi
+ else
+ echo failed
+ fi
+}
+
+#statd
+start_statd(){
+ echo -n "starting statd: "
+ start-stop-daemon --start --exec "$NFS_STATD"
+ echo done
+}
+stop_statd(){
+ # WARNING: this kills any process with the executable
+ # name 'statd'.
+ echo -n 'stopping statd: '
+ start-stop-daemon --stop --quiet --signal 1 --name statd
+ echo done
+}
+#----------------------------------------------------------------------
+#
+# supported options:
+# start
+# stop
+# reload: reloads the exports file
+# restart: stops and starts mountd
+#FIXME: need to create the /var/lib/nfs/... directories
+case "$1" in
+start) create_directories
+ start_nfsd "$NFS_SERVERS"
+ start_mountd
+ start_statd
+ test -r /etc/exports && exportfs -a;;
+stop) exportfs -ua
+ stop_statd
+ stop_mountd
+ stop_nfsd;;
+reload) test -r /etc/exports && exportfs -r;;
+restart)exportfs -ua
+ stop_mountd
+ stop_statd
+ # restart does not restart the kernel threads,
+ # only the user mode processes
+ start_mountd
+ start_statd
+ test -r /etc/exports && exportfs -a;;
+esac
diff --git a/recipes/nfs-utils/files/uclibc_bzero_fix.patch b/recipes/nfs-utils/files/uclibc_bzero_fix.patch
new file mode 100644
index 0000000000..2006192d28
--- /dev/null
+++ b/recipes/nfs-utils/files/uclibc_bzero_fix.patch
@@ -0,0 +1,17 @@
+---
+ support/nfs/svc_socket.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: nfs-utils-1.0.6/support/nfs/svc_socket.c
+===================================================================
+--- nfs-utils-1.0.6.orig/support/nfs/svc_socket.c 2007-05-27 16:14:09.000000000 +0100
++++ nfs-utils-1.0.6/support/nfs/svc_socket.c 2007-05-28 22:43:55.000000000 +0100
+@@ -63,7 +63,7 @@ svc_socket (u_long number, int type, int
+ }
+ }
+
+- __bzero ((char *) &addr, sizeof (addr));
++ memset ((char *) &addr,0, sizeof (addr));
+ addr.sin_family = AF_INET;
+
+ #ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */
diff --git a/recipes/nfs-utils/nfs-utils-1.0.6/acinclude-lossage.patch b/recipes/nfs-utils/nfs-utils-1.0.6/acinclude-lossage.patch
new file mode 100644
index 0000000000..0d2d7f3824
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils-1.0.6/acinclude-lossage.patch
@@ -0,0 +1,142 @@
+--- nfs-utils-1.0.6/acinclude.m4.old 2004-11-07 12:28:58.000000000 +0000
++++ nfs-utils-1.0.6/acinclude.m4 2000-10-11 22:49:45.000000000 +0100
+@@ -0,0 +1,139 @@
++dnl aclocal.m4 -- custom autoconf macros for various purposes
++dnl Updated for Autoconf v2
++dnl
++dnl ******** save/restore stuff **********
++define(AC_KNFSD_SAVE,
++ [AC_LANG_SAVE
++ save_LDFLAGS=$LDFLAGS
++ save_CFLAGS=$CFLAGS
++ save_CXXFLAGS=$CXXFLAGS
++ save_LIBS=$LIBS
++])dnl
++define(AC_KNFSD_RESTORE,
++ [LDFLAGS=$save_LDFLAGS
++ CFLAGS=$save_CFLAGS
++ CXXFLAGS=$save_CXXFLAGS
++ LIBS=$save_LIBS
++ AC_LANG_RESTORE
++])dnl
++dnl *********** GNU libc 2 ***************
++define(AC_GNULIBC,
++ [AC_MSG_CHECKING(for GNU libc2)
++ AC_CACHE_VAL(knfsd_cv_glibc2,
++ [AC_TRY_CPP([
++ #include <features.h>
++ #if !defined(__GLIBC__)
++ # error Nope
++ #endif], knfsd_cv_glibc2=yes, knfsd_cv_glibc2=no)])
++ AC_MSG_RESULT($knfsd_cv_glibc2)
++ if test $knfsd_cv_glibc2 = yes; then
++ CFLAGS="$CFLAGS -D_GNU_SOURCE"
++ CXXFLAGS="$CXXFLAGS -D_GNU_SOURCE"
++ fi
++]) dnl
++dnl
++dnl ************* egcs *******************
++define(AC_PROG_EGCS,
++ [AC_MSG_CHECKING(for egcs)
++ AC_CACHE_VAL(knfsd_cv_prog_EGCS,
++ [case `$CC --version 2>/dev/null` in
++ egcs*)
++ knfsd_cv_prog_EGCS=yes;;
++ *)
++ knfsd_cv_prog_EGCS=no;;
++ esac
++ ])
++ AC_MSG_RESULT($knfsd_cv_prog_EGCS)
++ test $knfsd_cv_prog_EGCS = yes && AC_DEFINE(HAVE_EGCS)
++]) dnl
++dnl *********** sizeof(dev_t) **************
++dnl ** We have to kludge this rather than use AC_CHECK_SIZEOF because
++dnl ** we have to include sys/types.h. Ugh.
++define(AC_DEV_T_SIZE,
++ [AC_MSG_CHECKING(size of dev_t)
++ AC_CACHE_VAL(ac_cv_sizeof_dev_t,
++ [AC_TRY_LINK(
++ [#include <stdio.h>
++ #include <sys/types.h>
++ main()
++ {
++ FILE *f=fopen("conftestval", "w");
++ if (!f) exit(1);
++ fprintf(f, "%d\n", sizeof(dev_t));
++ exit(0);
++ }], ac_cv_sizeof_dev_t=`cat conftestval`, ac_cv_sizeof_dev_t=0)])
++ AC_MSG_RESULT($ac_cv_sizeof_dev_t)
++ AC_DEFINE(SIZEOF_DEV_T,$ac_cv_sizeof_dev_t)
++ ])
++dnl *********** sizeof(xxx_t) **************
++dnl ** Overwrite the AC_CHECK_SIZEOF macro as we must include sys/types.h
++define([AC_CHECK_SIZEOF],
++ [changequote(<<, >>)dnl
++ define(<<AC_TYPE_NAME>>,translit(sizeof_$1, [a-z *], [A-Z_P]))dnl
++ define(<<AC_CV_NAME>>, translit(ac_cv_sizeof_$1, [ *], [_p]))dnl
++ changequote([, ])dnl
++ AC_MSG_CHECKING(size of $1)
++ AC_CACHE_VAL(AC_CV_NAME,
++ [AC_TRY_RUN(
++ [#include <stdio.h>
++ #include <sys/types.h>
++ main()
++ {
++ FILE *f=fopen("conftestval", "w");
++ if (!f) exit(1);
++ fprintf(f, "%d\n", sizeof($1));
++ exit(0);
++ }], AC_CV_NAME=`cat conftestval`, AC_CV_NAME=0)])
++ AC_MSG_RESULT($AC_CV_NAME)
++ AC_DEFINE_UNQUOTED(AC_TYPE_NAME,$AC_CV_NAME)
++ undefine([AC_TYPE_NAME])dnl
++ undefine([AC_CV_NAME])dnl
++ ])
++dnl *********** BSD vs. POSIX signal handling **************
++define([AC_BSD_SIGNALS],
++ [AC_MSG_CHECKING(for BSD signal semantics)
++ AC_CACHE_VAL(knfsd_cv_bsd_signals,
++ [AC_TRY_RUN([
++ #include <signal.h>
++ #include <unistd.h>
++ #include <sys/wait.h>
++
++ static int counter = 0;
++ static RETSIGTYPE handler(int num) { counter++; }
++
++ int main()
++ {
++ int s;
++ if ((s = fork()) < 0) return 1;
++ if (s != 0) {
++ if (wait(&s) < 0) return 1;
++ return WIFSIGNALED(s)? 1 : 0;
++ }
++
++ signal(SIGHUP, handler);
++ kill(getpid(), SIGHUP); kill(getpid(), SIGHUP);
++ return (counter == 2)? 0 : 1;
++ }
++ ], knfsd_cv_bsd_signals=yes, knfsd_cv_bsd_signals=no)]) dnl
++ AC_MSG_RESULT($knfsd_cv_bsd_signals)
++ test $knfsd_cv_bsd_signals = yes && AC_DEFINE(HAVE_BSD_SIGNALS)
++])dnl
++dnl *********** the tcp wrapper library ***************
++define(AC_TCP_WRAPPER,
++ [AC_MSG_CHECKING(for the tcp wrapper library)
++ AC_CACHE_VAL(knfsd_cv_tcp_wrapper,
++ [old_LIBS="$LIBS"
++ LIBS="$LIBS -lwrap $LIBNSL"
++ AC_TRY_LINK([
++ int deny_severity = 0;
++ int allow_severity = 0;],
++ [return hosts_ctl ("nfsd", "", "")],
++ knfsd_cv_tcp_wrapper=yes, knfsd_cv_tcp_wrapper=no)
++ LIBS="$old_LIBS"])
++ AC_MSG_RESULT($knfsd_cv_tcp_wrapper)
++ if test "$knfsd_cv_tcp_wrapper" = yes; then
++ CFLAGS="$CFLAGS -DHAVE_TCP_WRAPPER"
++ CXXFLAGS="$CXXFLAGS -DHAVE_TCP_WRAPPER"
++ LIBWRAP="-lwrap"
++ fi
++]) dnl
diff --git a/recipes/nfs-utils/nfs-utils-1.0.6/forgotten-defines b/recipes/nfs-utils/nfs-utils-1.0.6/forgotten-defines
new file mode 100644
index 0000000000..a18333100d
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils-1.0.6/forgotten-defines
@@ -0,0 +1,5 @@
+
+/* This defines the location of the NFS state files
+ * Warning: these must match definitions in config.mk!
+ */
+#define NFS_STATEDIR "/var/lib/nfs"
diff --git a/recipes/nfs-utils/nfs-utils-1.0.6/kernel-2.6.18+.patch b/recipes/nfs-utils/nfs-utils-1.0.6/kernel-2.6.18+.patch
new file mode 100644
index 0000000000..219bed094b
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils-1.0.6/kernel-2.6.18+.patch
@@ -0,0 +1,13 @@
+--- nfs-utils-1.0.6/tools/getkversion/getkversion.c.orig 2007-02-22 12:33:54.000000000 +0000
++++ nfs-utils-1.0.6/tools/getkversion/getkversion.c 2007-02-22 12:33:56.000000000 +0000
+@@ -12,6 +12,10 @@
+ int
+ main(void) /* This is for Dan Popp ;) */
+ {
++
++#ifdef UTS_RELEASE
+ printf("%s\n", UTS_RELEASE);
++#endif
++
+ return 0;
+ }
diff --git a/recipes/nfs-utils/nfs-utils-1.0.6/rpcgen-lossage.patch b/recipes/nfs-utils/nfs-utils-1.0.6/rpcgen-lossage.patch
new file mode 100644
index 0000000000..d1e1fb700d
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils-1.0.6/rpcgen-lossage.patch
@@ -0,0 +1,11 @@
+--- nfs-utils-1.0.6/config.mk.in.old 2004-11-07 12:30:05.000000000 +0000
++++ nfs-utils-1.0.6/config.mk.in 2004-11-07 12:30:19.000000000 +0000
+@@ -52,7 +52,7 @@
+ LN_S = ln -sf
+ RANLIB = @RANLIB@
+ INDENT = indent
+-RPCGEN = $(TOP)bin/rpcgen
++RPCGEN = rpcgen
+ GETKVER = $(TOP)tools/getkversion
+ INSTALL = install
+ MAN2PS = groff -Tps -man
diff --git a/recipes/nfs-utils/nfs-utils-1.0.6/stat-include.patch b/recipes/nfs-utils/nfs-utils-1.0.6/stat-include.patch
new file mode 100644
index 0000000000..d0ae022461
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils-1.0.6/stat-include.patch
@@ -0,0 +1,11 @@
+--- nfs-utils-1.0.6/utils/statd/statd.c~ 2003-09-11 20:24:29.000000000 -1000
++++ nfs-utils-1.0.6/utils/statd/statd.c 2005-03-27 03:11:03.025582700 -1000
+@@ -19,6 +19,7 @@
+ #include <rpc/pmap_clnt.h>
+ #include <rpcmisc.h>
+ #include <sys/resource.h>
++#include <sys/stat.h>
+ #include <grp.h>
+ #include "statd.h"
+ #include "version.h"
+
diff --git a/recipes/nfs-utils/nfs-utils-1.1.2/nfs-utils-tools-unset-cflags.patch b/recipes/nfs-utils/nfs-utils-1.1.2/nfs-utils-tools-unset-cflags.patch
new file mode 100644
index 0000000000..16bdebf12e
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils-1.1.2/nfs-utils-tools-unset-cflags.patch
@@ -0,0 +1,92 @@
+Index: nfs-utils-1.1.2/tools/Makefile.am
+===================================================================
+--- nfs-utils-1.1.2.orig/tools/Makefile.am 2008-03-14 08:46:29.000000000 -0700
++++ nfs-utils-1.1.2/tools/Makefile.am 2009-03-04 01:58:50.000000000 -0800
+@@ -5,7 +5,10 @@
+ if CONFIG_RPCGEN
+ OPTDIRS += rpcgen
+ endif
+-
++CFLAGS=$(CFLAGS_FOR_BUILD)
++CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
++CXXFLAGS=$(CXXFLAGS_FOR_BUILD)
++LDFLAGS=$(LDFLAGS_FOR_BUILD)
+ SUBDIRS = locktest rpcdebug nlmtest $(OPTDIRS)
+
+ MAINTAINERCLEANFILES = Makefile.in
+Index: nfs-utils-1.1.2/tools/locktest/Makefile.am
+===================================================================
+--- nfs-utils-1.1.2.orig/tools/locktest/Makefile.am 2008-03-14 08:46:29.000000000 -0700
++++ nfs-utils-1.1.2/tools/locktest/Makefile.am 2009-03-04 01:58:50.000000000 -0800
+@@ -1,12 +1,13 @@
+ ## Process this file with automake to produce Makefile.in
+
+ CC=$(CC_FOR_BUILD)
++CFLAGS=$(CFLAGS_FOR_BUILD)
++CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
++CXXFLAGS=$(CXXFLAGS_FOR_BUILD)
++LDFLAGS=$(LDFLAGS_FOR_BUILD)
+ LIBTOOL = @LIBTOOL@ --tag=CC
+
+ noinst_PROGRAMS = testlk
+ testlk_SOURCES = testlk.c
+-testlk_CFLAGS=$(CFLAGS_FOR_BUILD)
+-testlk_CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
+-testlk_LDFLAGS=$(LDFLAGS_FOR_BUILD)
+
+ MAINTAINERCLEANFILES = Makefile.in
+Index: nfs-utils-1.1.2/tools/nlmtest/Makefile.am
+===================================================================
+--- nfs-utils-1.1.2.orig/tools/nlmtest/Makefile.am 2008-03-14 08:46:29.000000000 -0700
++++ nfs-utils-1.1.2/tools/nlmtest/Makefile.am 2009-03-04 01:58:50.000000000 -0800
+@@ -1,5 +1,8 @@
+ ## Process this file with automake to produce Makefile.in
+-
++CFLAGS=$(CFLAGS_FOR_BUILD)
++CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
++CXXFLAGS=$(CXXFLAGS_FOR_BUILD)
++LDFLAGS=$(LDFLAGS_FOR_BUILD)
+ EXTRA_DIST = \
+ README \
+ host.h \
+Index: nfs-utils-1.1.2/tools/rpcgen/Makefile.am
+===================================================================
+--- nfs-utils-1.1.2.orig/tools/rpcgen/Makefile.am 2008-03-14 08:46:29.000000000 -0700
++++ nfs-utils-1.1.2/tools/rpcgen/Makefile.am 2009-03-04 01:58:50.000000000 -0800
+@@ -1,6 +1,10 @@
+ ## Process this file with automake to produce Makefile.in
+
+ CC=$(CC_FOR_BUILD)
++CFLAGS=$(CFLAGS_FOR_BUILD)
++CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
++CXXFLAGS=$(CXXFLAGS_FOR_BUILD)
++LDFLAGS=$(LDFLAGS_FOR_BUILD)
+ LIBTOOL = @LIBTOOL@ --tag=CC
+
+ noinst_PROGRAMS = rpcgen
+@@ -9,10 +13,6 @@
+ rpc_util.c rpc_sample.c rpc_output.h rpc_parse.h \
+ rpc_scan.h rpc_util.h
+
+-rpcgen_CFLAGS=$(CFLAGS_FOR_BUILD)
+-rpcgen_CPPLAGS=$(CPPFLAGS_FOR_BUILD)
+-rpcgen_LDFLAGS=$(LDFLAGS_FOR_BUILD)
+-
+ MAINTAINERCLEANFILES = Makefile.in
+
+ EXTRA_DIST = rpcgen.new.1
+Index: nfs-utils-1.1.2/tools/rpcdebug/Makefile.am
+===================================================================
+--- nfs-utils-1.1.2.orig/tools/rpcdebug/Makefile.am 2009-03-04 02:01:41.000000000 -0800
++++ nfs-utils-1.1.2/tools/rpcdebug/Makefile.am 2009-03-04 02:02:42.000000000 -0800
+@@ -1,6 +1,10 @@
+ ## Process this file with automake to produce Makefile.in
+
+ CC=$(CC_FOR_BUILD)
++CFLAGS=$(CFLAGS_FOR_BUILD)
++CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
++CXXFLAGS=$(CXXFLAGS_FOR_BUILD)
++LDFLAGS=$(LDFLAGS_FOR_BUILD)
+ LIBTOOL = @LIBTOOL@ --tag=CC
+
+ man8_MANS = rpcdebug.man
diff --git a/recipes/nfs-utils/nfs-utils_1.0.6.bb b/recipes/nfs-utils/nfs-utils_1.0.6.bb
new file mode 100644
index 0000000000..1febf057bf
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils_1.0.6.bb
@@ -0,0 +1,77 @@
+DESCRIPTION = "userspace utilities for kernel nfs"
+PRIORITY = "optional"
+SECTION = "console/network"
+LICENSE = "GPL"
+PR = "r13"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
+ file://acinclude-lossage.patch;patch=1 \
+ file://rpcgen-lossage.patch;patch=1 \
+ file://stat-include.patch;patch=1 \
+ file://nfs-utils-1.0.6-uclibc.patch;patch=1 \
+ file://kernel-2.6.18+.patch;patch=1 \
+ file://uclibc_bzero_fix.patch;patch=1 \
+ file://nfsserver \
+ file://forgotten-defines"
+
+S = "${WORKDIR}/nfs-utils-${PV}/"
+
+PARALLEL_MAKE = ""
+
+# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
+# pull in the remainder of the dependencies.
+RDEPENDS = "portmap"
+RRECOMMENDS = "kernel-module-nfsd"
+
+INITSCRIPT_NAME = "nfsserver"
+# The server has no dependencies at the user run levels, so just put
+# it in at the default levels. It must be terminated before the network
+# in the shutdown levels, but that works fine.
+INITSCRIPT_PARAMS = "defaults"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = "--with-statduser=nobody \
+ --enable-nfsv3 \
+ --with-statedir=/var/lib/nfs"
+
+do_compile() {
+ # UGLY HACK ALERT
+ cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
+ oe_runmake 'BUILD=1'
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
+ install -m 0755 ${S}/utils/lockd/lockd ${D}${sbindir}/lockd
+ install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
+ install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
+ install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
+ install -m 0755 ${S}/utils/nhfsstone/nhfsgraph ${D}${sbindir}/nhfsgraph
+ install -m 0755 ${S}/utils/nhfsstone/nhfsnums ${D}${sbindir}/nhfsnums
+ install -m 0755 ${S}/utils/nhfsstone/nhfsrun ${D}${sbindir}/nhfsrun
+ install -m 0755 ${S}/utils/nhfsstone/nhfsstone ${D}${sbindir}/nhfsstone
+ install -m 0755 ${S}/utils/rquotad/rquotad ${D}${sbindir}/rquotad
+ install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
+ install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
+
+ install -d ${D}${mandir}/man8
+ install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
+ install -m 0644 ${S}/utils/lockd/lockd.man ${D}${mandir}/man8/lockd.8
+ install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
+ install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
+ install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsgraph.man ${D}${mandir}/man8/nhfsgraph.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsnums.man ${D}${mandir}/man8/nhfsnums.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsrun.man ${D}${mandir}/man8/nhfsrun.8
+ install -m 0644 ${S}/utils/nhfsstone/nhfsstone.man ${D}${mandir}/man8/nhfsstone.8
+ install -m 0644 ${S}/utils/rquotad/rquotad.man ${D}${mandir}/man8/rquotad.8
+ install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
+ install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
+}
diff --git a/recipes/nfs-utils/nfs-utils_1.1.2.bb b/recipes/nfs-utils/nfs-utils_1.1.2.bb
new file mode 100644
index 0000000000..350c195d92
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils_1.1.2.bb
@@ -0,0 +1,72 @@
+DESCRIPTION = "userspace utilities for kernel nfs"
+PRIORITY = "optional"
+SECTION = "console/network"
+LICENSE = "GPL"
+
+PR = "r4"
+
+DEPENDS = "e2fsprogs-libs tcp-wrappers libevent"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
+ file://nfs-utils-tools-unset-cflags.patch;patch=1 \
+ file://nfsserver \
+ "
+
+S = "${WORKDIR}/nfs-utils-${PV}/"
+
+PARALLEL_MAKE = ""
+
+# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
+# pull in the remainder of the dependencies.
+RDEPENDS = "portmap"
+RRECOMMENDS = "kernel-module-nfsd"
+
+INITSCRIPT_NAME = "nfsserver"
+# The server has no dependencies at the user run levels, so just put
+# it in at the default levels. It must be terminated before the network
+# in the shutdown levels, but that works fine.
+INITSCRIPT_PARAMS = "defaults"
+
+inherit autotools update-rc.d
+
+EXTRA_OECONF = "--with-statduser=nobody \
+ --enable-nfsv3 \
+ --disable-nfsv4 \
+ --disable-gss \
+ --with-statedir=/var/lib/nfs"
+
+do_ccompile() {
+ # UGLY HACK ALERT
+ cat ${WORKDIR}/forgotten-defines >> ${S}/support/include/config.h
+ oe_runmake 'BUILD=1'
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
+
+ install -d ${D}${sbindir}
+ install -d ${D}${base_sbindir}
+ install -m 0755 ${S}/utils/exportfs/exportfs ${D}${sbindir}/exportfs
+ install -m 0755 ${S}/utils/mountd/mountd ${D}${sbindir}/mountd
+ install -m 0755 ${S}/utils/mount/mount.nfs ${D}${base_sbindir}/mount.nfs
+ install -m 0755 ${S}/utils/nfsd/nfsd ${D}${sbindir}/nfsd
+ install -m 0755 ${S}/utils/nfsstat/nfsstat ${D}${sbindir}/nfsstat
+ install -m 0755 ${S}/utils/showmount/showmount ${D}${sbindir}/showmount
+ install -m 0755 ${S}/utils/statd/statd ${D}${sbindir}/statd
+
+ ln -s ${D}/${base_sbindir}/mount.nfs ${D}/${base_sbindir}/mount.nfs4
+
+ install -d ${D}${mandir}/man8
+ install -m 0644 ${S}/utils/exportfs/exportfs.man ${D}${mandir}/man8/exportfs.8
+ install -m 0644 ${S}/utils/mountd/mountd.man ${D}${mandir}/man8/mountd.8
+ install -m 0644 ${S}/utils/nfsd/nfsd.man ${D}${mandir}/man8/nfsd.8
+ install -m 0644 ${S}/utils/nfsstat/nfsstat.man ${D}${mandir}/man8/nfsstat.8
+ install -m 0644 ${S}/utils/showmount/showmount.man ${D}${mandir}/man8/showmount.8
+ install -m 0644 ${S}/utils/statd/statd.man ${D}${mandir}/man8/statd.8
+}
+
+PACKAGES =+ "nfs-utils-client"
+FILES_nfs-utils-client = "${base_sbindir}/mount.nfs ${base_sbindir}/mount.nfs4"