aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nfs-utils
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-05-26 10:34:11 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-05-26 11:07:36 +0200
commit798066d5b2183acc617b5b9d18066f02680aa9d6 (patch)
treeb93b72b9eac9c002914d4384e4aba7475654c545 /recipes/nfs-utils
parent8935ad53ba1e4f46c43d6ed784034edc9c244c8e (diff)
downloadopenembedded-798066d5b2183acc617b5b9d18066f02680aa9d6.tar.gz
nfs-utils: add patch for missing include sys/stat.h
* without, it fails with undefined reference to S_ISREG (the same for S_ISDIR) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/nfs-utils')
-rw-r--r--recipes/nfs-utils/nfs-utils-1.1.2/nfs-utils-S_ISREG-missing-include.patch33
-rw-r--r--recipes/nfs-utils/nfs-utils_1.1.2.bb3
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes/nfs-utils/nfs-utils-1.1.2/nfs-utils-S_ISREG-missing-include.patch b/recipes/nfs-utils/nfs-utils-1.1.2/nfs-utils-S_ISREG-missing-include.patch
new file mode 100644
index 0000000000..6b2c75e7a8
--- /dev/null
+++ b/recipes/nfs-utils/nfs-utils-1.1.2/nfs-utils-S_ISREG-missing-include.patch
@@ -0,0 +1,33 @@
+diff -uNr nfs-utils-1.1.2.orig//utils/exportfs/exportfs.c nfs-utils-1.1.2/utils/exportfs/exportfs.c
+--- nfs-utils-1.1.2.orig//utils/exportfs/exportfs.c 2008-03-14 16:46:29.000000000 +0100
++++ nfs-utils-1.1.2/utils/exportfs/exportfs.c 2010-05-26 10:31:23.000000000 +0200
+@@ -19,6 +19,7 @@
+ #include <getopt.h>
+ #include <netdb.h>
+ #include <errno.h>
++#include <sys/stat.h>
+ #include "xmalloc.h"
+ #include "misc.h"
+ #include "nfslib.h"
+diff -uNr nfs-utils-1.1.2.orig//utils/mount/mount.c nfs-utils-1.1.2/utils/mount/mount.c
+--- nfs-utils-1.1.2.orig//utils/mount/mount.c 2008-03-14 16:46:29.000000000 +0100
++++ nfs-utils-1.1.2/utils/mount/mount.c 2010-05-26 10:31:32.000000000 +0200
+@@ -24,6 +24,7 @@
+
+ #include <unistd.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include <errno.h>
+diff -uNr nfs-utils-1.1.2.orig//utils/mount/network.c nfs-utils-1.1.2/utils/mount/network.c
+--- nfs-utils-1.1.2.orig//utils/mount/network.c 2008-03-14 16:46:29.000000000 +0100
++++ nfs-utils-1.1.2/utils/mount/network.c 2010-05-26 10:31:35.000000000 +0200
+@@ -37,6 +37,7 @@
+ #include <rpc/pmap_prot.h>
+ #include <rpc/pmap_clnt.h>
+ #include <sys/socket.h>
++#include <sys/stat.h>
+
+ #include "xcommon.h"
+ #include "mount.h"
diff --git a/recipes/nfs-utils/nfs-utils_1.1.2.bb b/recipes/nfs-utils/nfs-utils_1.1.2.bb
index a663a6441b..be45310d06 100644
--- a/recipes/nfs-utils/nfs-utils_1.1.2.bb
+++ b/recipes/nfs-utils/nfs-utils_1.1.2.bb
@@ -3,13 +3,14 @@ PRIORITY = "optional"
SECTION = "console/network"
LICENSE = "GPL"
-PR = "r7"
+PR = "r8"
DEPENDS = "util-linux-ng tcp-wrappers libevent"
SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.gz \
file://nfs-utils-tools-unset-cflags.patch \
file://nfs-utils-uclibc-compile.patch \
+ file://nfs-utils-S_ISREG-missing-include.patch \
file://nfsserver \
"