aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nis/pwdutils_2.6.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nis/pwdutils_2.6.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nis/pwdutils_2.6.bb')
-rw-r--r--recipes/nis/pwdutils_2.6.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/nis/pwdutils_2.6.bb b/recipes/nis/pwdutils_2.6.bb
new file mode 100644
index 0000000000..0e01e7e104
--- /dev/null
+++ b/recipes/nis/pwdutils_2.6.bb
@@ -0,0 +1,41 @@
+# This package builds tools to manage NIS passwords
+# The source package is utils/net/NIS/pwdutils
+# The package requires -lpam
+#
+PR = "r1"
+DESCRIPTION="\
+NIS PAM password management tools. \
+This is a collection of utilities to manage the passwd \
+information stored in local files, NIS, NIS+ or LDAP \
+and can replace the shadow suite completely."
+HOMEPAGE="http://lists.suse.com/archive/pwdutils/"
+
+require nis.inc
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/net/NIS/OLD/${PN}/${P}.tar.bz2"
+
+# an selinux API is used even if no selinux is detected by
+# configure.
+SRC_URI += " file://no-selinux.patch;patch=1"
+SRC_URI += " file://libdl.patch;patch=1"
+
+DEPENDS += " libpam openldap openssl"
+
+# -Werror is set within the pwdutils configure.in!
+# You might prefer to use -Wno-error rather than the
+# following long list.
+#
+# #if undefined happens in bits/string2.h and probably
+# elsewhere (since it is a standard safe C programming
+# practice - safer than #ifdef!)
+TARGET_CFLAGS += " -Wno-undef"
+# bits/socket.h has a macro which casts 'up' (increasing
+# the alignment requirement) but it is in a macro which
+# does the alignment correctly, so the following warning
+# needs to be non-error'ed. I just turn it off...
+TARGET_CFLAGS += " -Wno-cast-align"
+# openssl contains large numbers of declarations wherein
+# f() is used instead of f(void), so:
+TARGET_CFLAGS += " -Wno-strict-prototypes"
+# openssl uses error as a local variable, so:
+TARGET_CFLAGS += " -Wno-shadow"