summaryrefslogtreecommitdiffstats
path: root/recipes/nmap/nmap_3.81.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nmap/nmap_3.81.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nmap/nmap_3.81.bb')
-rw-r--r--recipes/nmap/nmap_3.81.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes/nmap/nmap_3.81.bb b/recipes/nmap/nmap_3.81.bb
new file mode 100644
index 0000000000..7aa5928191
--- /dev/null
+++ b/recipes/nmap/nmap_3.81.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Nmap is a command line portscanner."
+HOMEPAGE = "http://www.insecure.org/nmap/"
+SECTION = "console/network"
+LICENSE = "GPL"
+DEPENDS = "libpcap libpcre"
+PR = "r2"
+
+inherit autotools
+
+SRC_URI = "http://download.insecure.org/nmap/dist-old/nmap-${PV}.tar.bz2 \
+ file://autofoo.patch;patch=1 \
+ file://remove_gtk.patch;patch=1"
+S = "${WORKDIR}/nmap-${PV}"
+
+EXTRA_OECONF = "--with-pcap=linux \
+ --with-libpcap=${STAGING_LIBDIR}/.. \
+ --with-libpcre=${STAGING_LIBDIR}/.. \
+ --without-nmapfe \
+ --without-openssl"
+EXTRA_OEMAKE = "STRIPPROG=${STRIP}"
+
+CXXFLAGS_append = " -fpermissive"
+# Ugly hack follows -- their configure.ac doesnt match their configure ..
+# doesnt include a check for the length type in recvfrom, so we hack it here
+CPPFLAGS_append = " -Drecvfrom6_t=socklen_t"
+
+do_install () {
+ oe_runmake 'prefix=${D}${prefix}' \
+ 'exec_prefix=${D}${exec_prefix}' \
+ 'bindir=${D}${bindir}' \
+ 'sbindir=${D}${sbindir}' \
+ 'mandir=${D}${mandir}' \
+ 'datadir=${D}${datadir}' \
+ 'nmapdatadir=${D}${datadir}/nmap' \
+ install
+}