aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/mISDN/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/mISDN/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/mISDN/files')
-rw-r--r--recipes/nonworking/mISDN/files/Makefile4
-rw-r--r--recipes/nonworking/mISDN/files/hfcs_usb_endianchecks.diff58
2 files changed, 62 insertions, 0 deletions
diff --git a/recipes/nonworking/mISDN/files/Makefile b/recipes/nonworking/mISDN/files/Makefile
new file mode 100644
index 0000000000..bed60110ea
--- /dev/null
+++ b/recipes/nonworking/mISDN/files/Makefile
@@ -0,0 +1,4 @@
+PWD := $(shell pwd)
+SELECTION := CONFIG_MISDN_DRV=m CONFIG_MISDN_DSP=m CONFIG_MISDN_HFCUSB=m
+default modules:
+ $(MAKE) -C $(KDIR) SUBDIRS=${PWD}/drivers/isdn/hardware/mISDN/ EXTRA_CFLAGS=-I${PWD}/include modules ${SELECTION}
diff --git a/recipes/nonworking/mISDN/files/hfcs_usb_endianchecks.diff b/recipes/nonworking/mISDN/files/hfcs_usb_endianchecks.diff
new file mode 100644
index 0000000000..1f6ff3fcc8
--- /dev/null
+++ b/recipes/nonworking/mISDN/files/hfcs_usb_endianchecks.diff
@@ -0,0 +1,58 @@
+--- mISDN.org/drivers/isdn/hardware/mISDN/hfcs_usb.c 2005-06-23 18:43:36.000000000 +0200
++++ mISDN/drivers/isdn/hardware/mISDN/hfcs_usb.c 2005-08-12 16:16:24.000000000 +0200
+@@ -2038,9 +2038,9 @@
+
+ vend_idx = 0xffff;
+ for (i = 0; hfcsusb_idtab[i].idVendor; i++) {
+- if (dev->descriptor.idVendor == hfcsusb_idtab[i].idVendor
++ if (dev->descriptor.idVendor == le16_to_cpu(hfcsusb_idtab[i].idVendor)
+ && dev->descriptor.idProduct ==
+- hfcsusb_idtab[i].idProduct) {
++ le16_to_cpu(hfcsusb_idtab[i].idProduct)) {
+ vend_idx = i;
+ continue;
+ }
+@@ -2160,8 +2160,8 @@
+ usb_transfer_mode
+ = USB_INT;
+ packet_size =
+- ep->desc.
+- wMaxPacketSize;
++ le16_to_cpu(ep->desc.
++ wMaxPacketSize);
+ break;
+ case USB_ENDPOINT_XFER_BULK:
+ if (ep_addr & 0x80)
+@@ -2189,8 +2189,8 @@
+ usb_transfer_mode
+ = USB_BULK;
+ packet_size =
+- ep->desc.
+- wMaxPacketSize;
++ le16_to_cpu(ep->desc.
++ wMaxPacketSize);
+ break;
+ case USB_ENDPOINT_XFER_ISOC:
+ if (ep_addr & 0x80)
+@@ -2218,8 +2218,8 @@
+ usb_transfer_mode
+ = USB_ISOC;
+ iso_packet_size =
+- ep->desc.
+- wMaxPacketSize;
++ le16_to_cpu(ep->desc.
++ wMaxPacketSize);
+ break;
+ default:
+ card->
+@@ -2234,8 +2234,8 @@
+ card;
+ card->fifos[cidx].
+ usb_packet_maxlen =
+- ep->desc.
+- wMaxPacketSize;
++ le16_to_cpu(ep->desc.
++ wMaxPacketSize);
+ card->fifos[cidx].
+ intervall =
+ ep->desc.bInterval;