aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nonworking/r
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/r
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/r')
-rw-r--r--recipes/nonworking/r/r-2.0.0/configure.patch99
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_Makefile.patch16
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_Recommended_Makefile.patch18
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_base_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_datasets_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_grDevices_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_graphics_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_grid_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_methods_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_splines_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_stats4_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_stats_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_tcltk_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_tools_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-2.0.0/src_library_utils_Makefile.patch11
-rw-r--r--recipes/nonworking/r/r-native_2.0.0.bb20
-rw-r--r--recipes/nonworking/r/r_1.9.1.bb10
-rw-r--r--recipes/nonworking/r/r_2.0.0.bb44
18 files changed, 339 insertions, 0 deletions
diff --git a/recipes/nonworking/r/r-2.0.0/configure.patch b/recipes/nonworking/r/r-2.0.0/configure.patch
new file mode 100644
index 0000000000..acd7e6c467
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/configure.patch
@@ -0,0 +1,99 @@
+--- R-2.0.0/configure~ 2004-12-11 00:34:27.270027696 +0000
++++ R-2.0.0/configure 2004-12-10 23:06:11.000000000 +0000
+@@ -20960,41 +20960,41 @@
+
+ ### * Checks for libraries.
+
+-## Set up LD_LIBRARY_PATH or equivalent.
+-## <FIXME>
+-## What is this doing *HERE*?
+-## Should be needed for tests using AC_RUN_IFELSE()?
+-## Make sure that non-standard directories specified via '-L' are really
+-## searched in the tests.
+-## Note: earlier versions used LIBS rather than LDFLAGS.
+-for arg in ${LDFLAGS}; do
+- case "${arg}" in
+- -L*)
+- lib=`echo ${arg} | sed "s/^-L//"`
+- separator="${PATH_SEPARATOR}"
+-test -z "${separator}" && separator=" "
+-if test -z "${R_LD_LIBRARY_PATH}"; then
+- R_LD_LIBRARY_PATH="${lib}"
+-else
+- R_LD_LIBRARY_PATH="${R_LD_LIBRARY_PATH}${separator}${lib}"
+-fi
+- ;;
+- esac
+-done
+-## </FIXME>
+-
+-## Record name of environment variable which tells the dynamic linker
+-## where to find shlibs (typically, 'LD_LIBRARY_PATH').
+-ltout=`./libtool --config | grep '^shlibpath_var='`
+-eval "${ltout}"
+-
+-## Export LD_LIBRARY_PATH or equivalent.
+-if eval "test -z \"\${${shlibpath_var}}\""; then
+- eval "${shlibpath_var}=\"${R_LD_LIBRARY_PATH}\""
+-else
+- eval "${shlibpath_var}=\"${R_LD_LIBRARY_PATH}${PATH_SEPARATOR}\${${shlibpath_var}}\""
+-fi
+-eval "export ${shlibpath_var}"
++### Set up LD_LIBRARY_PATH or equivalent.
++### <FIXME>
++### What is this doing *HERE*?
++### Should be needed for tests using AC_RUN_IFELSE()?
++### Make sure that non-standard directories specified via '-L' are really
++### searched in the tests.
++### Note: earlier versions used LIBS rather than LDFLAGS.
++#for arg in ${LDFLAGS}; do
++# case "${arg}" in
++# -L*)
++# lib=`echo ${arg} | sed "s/^-L//"`
++# separator="${PATH_SEPARATOR}"
++#test -z "${separator}" && separator=" "
++#if test -z "${R_LD_LIBRARY_PATH}"; then
++# R_LD_LIBRARY_PATH="${lib}"
++#else
++# R_LD_LIBRARY_PATH="${R_LD_LIBRARY_PATH}${separator}${lib}"
++#fi
++# ;;
++# esac
++#done
++### </FIXME>
++
++### Record name of environment variable which tells the dynamic linker
++### where to find shlibs (typically, 'LD_LIBRARY_PATH').
++#ltout=`./libtool --config | grep '^shlibpath_var='`
++#eval "${ltout}"
++#
++### Export LD_LIBRARY_PATH or equivalent.
++#if eval "test -z \"\${${shlibpath_var}}\""; then
++# eval "${shlibpath_var}=\"${R_LD_LIBRARY_PATH}\""
++#else
++# eval "${shlibpath_var}=\"${R_LD_LIBRARY_PATH}${PATH_SEPARATOR}\${${shlibpath_var}}\""
++#fi
++#eval "export ${shlibpath_var}"
+
+ ## Yes, we already need this at configure time ...
+ case "${host_os}" in
+@@ -26334,6 +26334,9 @@
+
+ fi
+
++#<Cross-compile addition>
++r_cv_prog_f77_can_run=yes
++#</Cross-compile Addition>
+
+ echo "$as_me:$LINENO: checking whether mixed C/Fortran code can be run" >&5
+ echo $ECHO_N "checking whether mixed C/Fortran code can be run... $ECHO_C" >&6
+@@ -26393,6 +26396,9 @@
+ { (exit 1); exit 1; }; }
+ fi
+
++#<Cross-compile addition>
++r_cv_prog_f77_cc_compat=yes
++#</Cross-compile Addition>
+
+ echo "$as_me:$LINENO: checking whether ${F77} and ${CC} agree on int and double" >&5
+ echo $ECHO_N "checking whether ${F77} and ${CC} agree on int and double... $ECHO_C" >&6
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_Makefile.patch
new file mode 100644
index 0000000000..fcf4cd4390
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_Makefile.patch
@@ -0,0 +1,16 @@
+--- R-2.0.0/src/library/Makefile.in~ 2004-12-12 11:01:07.840925056 +0000
++++ R-2.0.0/src/library/Makefile.in 2004-12-12 11:02:49.683442640 +0000
+@@ -20,11 +20,11 @@
+ ## Need to go through Rcmd rather than just call $(PERL) to ensure that
+ ## PERL5LIB/PERLLIB are set appropriately (or do this ourselves).
+ ## See e.g. @file{src/gnuwin32/help/Makefile}.
+-R_CMD_BUILD_HELP = $(top_builddir)/bin/R CMD perl $(top_srcdir)/share/perl/build-help.pl
++R_CMD_BUILD_HELP = $(R_EXE_NATIVE) CMD perl $(top_srcdir)/share/perl/build-help.pl
+ ## </NOTE>
+ R_CMD_BUILD_HELP_OPTS =
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ PDFLATEX = @PDFLATEX@
+
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_Recommended_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_Recommended_Makefile.patch
new file mode 100644
index 0000000000..6374c6366d
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_Recommended_Makefile.patch
@@ -0,0 +1,18 @@
+--- R-2.0.0/src/library/Recommended/Makefile.in~ 2004-12-12 11:26:10.565476200 +0000
++++ R-2.0.0/src/library/Recommended/Makefile.in 2004-12-12 11:27:09.177565808 +0000
+@@ -12,7 +12,7 @@
+
+ distdir = $(top_builddir)/$(PACKAGE)-$(VERSION)/$(subdir)
+ DISTFILES = Makefile.in .cvsignore
+-R = R_LIBS= $(top_builddir)/bin/R
++R = R_LIBS= $(R_EXE_NATIVE)
+
+ ## foo.ts is the timestamp for package foo;
+ ## foo.tgz is a symlink to foo_x.y-z.tar.gz in the source dir.
+@@ -79,4 +79,4 @@
+
+ ## Hardcoded dependencies (see 'share/make/vars.mk')
+ mgcv.ts: nlme.ts VR.ts
+-nlme.ts: lattice.ts
+\ No newline at end of file
++nlme.ts: lattice.ts
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_base_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_base_Makefile.patch
new file mode 100644
index 0000000000..210fb80214
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_base_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/base/Makefile.in~ 2004-12-12 11:04:28.183468360 +0000
++++ R-2.0.0/src/library/base/Makefile.in 2004-12-12 11:05:07.761451592 +0000
+@@ -19,7 +19,7 @@
+
+ RdSRC = $(srcdir)/man/*.Rd $(srcdir)/man/$(R_OSTYPE)/*.Rd
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ all: Makefile DESCRIPTION
+ @echo "building package '$(pkg)'"
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_datasets_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_datasets_Makefile.patch
new file mode 100644
index 0000000000..3b34453239
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_datasets_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/datasets/Makefile.in~ 2004-12-12 11:05:42.632150440 +0000
++++ R-2.0.0/src/library/datasets/Makefile.in 2004-12-12 11:06:22.398105096 +0000
+@@ -17,7 +17,7 @@
+
+ RSRC = $(srcdir)/R/zzz.R
+
+-R_EXE = $(top_builddir)/bin/R --vanilla --slave
++R_EXE = $(R_EXE_NATIVE) --vanilla --slave
+
+ all: Makefile DESCRIPTION
+ @echo "building package '$(pkg)'"
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_grDevices_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_grDevices_Makefile.patch
new file mode 100644
index 0000000000..84740288eb
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_grDevices_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/grDevices/Makefile.in~ 2004-12-12 11:07:59.989268984 +0000
++++ R-2.0.0/src/library/grDevices/Makefile.in 2004-12-12 11:09:05.891250360 +0000
+@@ -15,7 +15,7 @@
+
+ pkg = grDevices
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ RSRC = `LC_COLLATE=C ls $(srcdir)/R/*.R $(srcdir)/R/$(R_OSTYPE)/*.R`
+ RdSRC = $(srcdir)/man/*.Rd $(srcdir)/man/$(R_OSTYPE)/*.Rd
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_graphics_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_graphics_Makefile.patch
new file mode 100644
index 0000000000..1a07433485
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_graphics_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/graphics/Makefile.in~ 2004-12-12 11:06:47.451296432 +0000
++++ R-2.0.0/src/library/graphics/Makefile.in 2004-12-12 11:07:21.302150320 +0000
+@@ -15,7 +15,7 @@
+
+ pkg = graphics
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ RSRC = `LC_COLLATE=C ls $(srcdir)/R/*.R`
+ RdSRC = $(srcdir)/man/*.Rd
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_grid_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_grid_Makefile.patch
new file mode 100644
index 0000000000..7b819150e4
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_grid_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/grid/Makefile.in~ 2004-12-12 11:09:32.926140432 +0000
++++ R-2.0.0/src/library/grid/Makefile.in 2004-12-12 11:10:07.531879560 +0000
+@@ -15,7 +15,7 @@
+
+ pkg = grid
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ all: Makefile DESCRIPTION
+ @echo "building package '$(pkg)'"
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_methods_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_methods_Makefile.patch
new file mode 100644
index 0000000000..2a682c8662
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_methods_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/methods/Makefile.in~ 2004-12-12 11:10:31.099296768 +0000
++++ R-2.0.0/src/library/methods/Makefile.in 2004-12-12 11:11:04.778176800 +0000
+@@ -14,7 +14,7 @@
+
+ pkg = methods
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ all: Makefile DESCRIPTION
+ @echo "building package '$(pkg)'"
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_splines_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_splines_Makefile.patch
new file mode 100644
index 0000000000..4d235de3b1
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_splines_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/splines/Makefile.in~ 2004-12-12 11:12:00.728671032 +0000
++++ R-2.0.0/src/library/splines/Makefile.in 2004-12-12 11:12:20.417677848 +0000
+@@ -15,7 +15,7 @@
+
+ pkg = splines
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ all: Makefile DESCRIPTION
+ @echo "building package '$(pkg)'"
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_stats4_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_stats4_Makefile.patch
new file mode 100644
index 0000000000..b549824187
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_stats4_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/stats4/Makefile.in~ 2004-12-12 11:13:27.693450376 +0000
++++ R-2.0.0/src/library/stats4/Makefile.in 2004-12-12 11:13:40.442512224 +0000
+@@ -15,7 +15,7 @@
+
+ pkg = stats4
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ all: Makefile DESCRIPTION
+ @echo "building package '$(pkg)'"
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_stats_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_stats_Makefile.patch
new file mode 100644
index 0000000000..b94cf237f7
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_stats_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/stats/Makefile.in~ 2004-12-12 11:12:45.191911592 +0000
++++ R-2.0.0/src/library/stats/Makefile.in 2004-12-12 11:12:58.530883760 +0000
+@@ -16,7 +16,7 @@
+
+ pkg = stats
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ all: Makefile DESCRIPTION
+ @echo "building package '$(pkg)'"
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_tcltk_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_tcltk_Makefile.patch
new file mode 100644
index 0000000000..77b6a3ae81
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_tcltk_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/tcltk/Makefile.in~ 2004-12-12 11:13:59.269650064 +0000
++++ R-2.0.0/src/library/tcltk/Makefile.in 2004-12-12 11:14:21.897210152 +0000
+@@ -15,7 +15,7 @@
+
+ pkg = tcltk
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ RSRC = `LC_COLLATE=C ls $(srcdir)/R/*.R $(srcdir)/R/$(R_OSTYPE)/*.R`
+
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_tools_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_tools_Makefile.patch
new file mode 100644
index 0000000000..84924652e2
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_tools_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/tools/Makefile.in~ 2004-12-12 11:14:42.021150848 +0000
++++ R-2.0.0/src/library/tools/Makefile.in 2004-12-12 11:14:57.141852152 +0000
+@@ -15,7 +15,7 @@
+
+ pkg = tools
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ all: Makefile DESCRIPTION
+ @echo "building package '$(pkg)'"
diff --git a/recipes/nonworking/r/r-2.0.0/src_library_utils_Makefile.patch b/recipes/nonworking/r/r-2.0.0/src_library_utils_Makefile.patch
new file mode 100644
index 0000000000..e03913935d
--- /dev/null
+++ b/recipes/nonworking/r/r-2.0.0/src_library_utils_Makefile.patch
@@ -0,0 +1,11 @@
+--- R-2.0.0/src/library/utils/Makefile.in~ 2004-12-12 11:15:17.339781600 +0000
++++ R-2.0.0/src/library/utils/Makefile.in 2004-12-12 11:15:31.214672296 +0000
+@@ -16,7 +16,7 @@
+
+ pkg = utils
+
+-R_EXE = $(top_builddir)/bin/R --vanilla
++R_EXE = $(R_EXE_NATIVE) --vanilla
+
+ RSRC0 = `LC_COLLATE=C ls $(srcdir)/R/*.R $(srcdir)/R/$(R_OSTYPE)/*.R`
+ RSRC = $(RSRC0) @BUILD_AQUA_TRUE@ `LC_COLLATE=C ls $(srcdir)/R/aqua/*.R`
diff --git a/recipes/nonworking/r/r-native_2.0.0.bb b/recipes/nonworking/r/r-native_2.0.0.bb
new file mode 100644
index 0000000000..d9360dfaef
--- /dev/null
+++ b/recipes/nonworking/r/r-native_2.0.0.bb
@@ -0,0 +1,20 @@
+DEPENDS = "ncurses-native perl-native"
+
+SRC_URI = "http://www.stats.bris.ac.uk/R/src/base/R-2/R-${PV}.tar.gz"
+
+EXTRA_OECONF = "--without-x --without-readline --without-gnome --without-tcltk --without-libpng \
+ --without-jpeglib"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/R-${PV}"
+
+S = "${WORKDIR}/R-${PV}"
+
+inherit autotools native
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ install -m 0755 ${S}/bin/R ${STAGING_BINDIR}/R
+}
diff --git a/recipes/nonworking/r/r_1.9.1.bb b/recipes/nonworking/r/r_1.9.1.bb
new file mode 100644
index 0000000000..d9c6848262
--- /dev/null
+++ b/recipes/nonworking/r/r_1.9.1.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "R is GNU S, a freely available language and environment for statistical computing and \
+graphics which provides a wide variety of statistical and graphical techniques: \
+linear and nonlinear modelling, statistical tests, time series analysis, classification, clustering, etc."
+
+SRC_URI = "http://cran.r-mirror.de/src/base/R-${PV}.tgz"
+S = "${WORKDIR}/R-${PV}"
+
+inherit autotools
+
+
diff --git a/recipes/nonworking/r/r_2.0.0.bb b/recipes/nonworking/r/r_2.0.0.bb
new file mode 100644
index 0000000000..4a0004fb55
--- /dev/null
+++ b/recipes/nonworking/r/r_2.0.0.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "R is GNU S, a freely available language and environment for statistical computing \
+and graphics which provides a wide variety of statistical and graphical techniques: \
+linear and nonlinear modelling, statistical tests, time series analysis, classification, clustering, etc."
+SECTION = "console/scientific"
+PRIORITY = "optional"
+DEPENDS = "ncurses readline less perl-native r-native"
+
+SRC_URI = "http://www.stats.bris.ac.uk/R/src/base/R-2/R-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://src_library_Makefile.patch;patch=1 \
+ file://src_library_Recommended_Makefile.patch;patch=1 \
+ file://src_library_base_Makefile.patch;patch=1 \
+ file://src_library_tools_Makefile.patch;patch=1 \
+ file://src_library_utils_Makefile.patch;patch=1 \
+ file://src_library_datasets_Makefile.patch;patch=1 \
+ file://src_library_graphics_Makefile.patch;patch=1 \
+ file://src_library_grid_Makefile.patch;patch=1 \
+ file://src_library_methods_Makefile.patch;patch=1 \
+ file://src_library_splines_Makefile.patch;patch=1 \
+ file://src_library_stats4_Makefile.patch;patch=1 \
+ file://src_library_stats_Makefile.patch;patch=1 \
+ file://src_library_tcltk_Makefile.patch;patch=1 \
+ file://src_library_grDevices_Makefile.patch;patch=1"
+
+S = "${WORKDIR}/R-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-x"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_compile_prepend () {
+ ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} src/extra/pcre/dftables.c -o src/extra/pcre/dftables -Isrc/include
+ touch src/extra/pcre/dftables.o
+ src/extra/pcre/dftables src/extra/pcre/chartables.h
+}
+
+do_compile() {
+ oe_runmake 'R_EXE_NATIVE = ${STAGING_BINDIR_NATIVE}/R'
+}