aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ntfsprogs
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-02-23 21:07:18 +0000
committerSteffen Sledz <sledz@dresearch.de>2011-02-25 08:48:57 +0100
commitf2777c68c8d6cb06dd3acb8fec69cd7de8f7705d (patch)
tree3bc16eb88b27ef27d242eee66a9e422ae7202abe /recipes/ntfsprogs
parent17d3481ca39437a51c82cfbde63c845e958be012 (diff)
downloadopenembedded-f2777c68c8d6cb06dd3acb8fec69cd7de8f7705d.tar.gz
ntfsprogs: add 2.0.0
This recipe has been imported from O.S. Systems tree and hence starts at revision r2. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/ntfsprogs')
-rw-r--r--recipes/ntfsprogs/ntfsprogs/skip-erange-errors.patch30
-rw-r--r--recipes/ntfsprogs/ntfsprogs_2.0.0.bb15
2 files changed, 45 insertions, 0 deletions
diff --git a/recipes/ntfsprogs/ntfsprogs/skip-erange-errors.patch b/recipes/ntfsprogs/ntfsprogs/skip-erange-errors.patch
new file mode 100644
index 0000000000..7292d779bf
--- /dev/null
+++ b/recipes/ntfsprogs/ntfsprogs/skip-erange-errors.patch
@@ -0,0 +1,30 @@
+diff --git a/libntfs/attrib.c b/libntfs/attrib.c
+index a1fe954..c628d9d 100644
+--- a/libntfs/attrib.c
++++ b/libntfs/attrib.c
+@@ -550,8 +550,10 @@ int ntfs_attr_map_runlist_range(ntfs_attr *na, VCN from_vcn, VCN to_vcn)
+ (long long)from_vcn, (long long)to_vcn);
+
+ /* Map extent with @from_vcn. */
+- if (ntfs_attr_map_runlist(na, from_vcn))
+- goto err_out;
++ if (ntfs_attr_map_runlist(na, from_vcn)) {
++ if (errno != ERANGE)
++ goto err_out;
++ }
+
+ for (rl = na->rl; rl->vcn <= to_vcn;) {
+ /* Skip not interesting to us runs. */
+@@ -4924,8 +4926,10 @@ static int ntfs_non_resident_attr_expand(ntfs_attr *na, const s64 newsize,
+ /* Map required part of runlist. */
+ if (ntfs_attr_map_runlist(na, na->allocated_size >>
+ vol->cluster_size_bits)) {
+- ntfs_log_error("Failed to map runlist.\n");
+- return -1;
++ if (errno != ERANGE) {
++ ntfs_log_error("Failed to map runlist.\n");
++ return -1;
++ }
+ }
+
+ /*
diff --git a/recipes/ntfsprogs/ntfsprogs_2.0.0.bb b/recipes/ntfsprogs/ntfsprogs_2.0.0.bb
new file mode 100644
index 0000000000..b41985d0f1
--- /dev/null
+++ b/recipes/ntfsprogs/ntfsprogs_2.0.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "NTFS utilies"
+HOMEPAGE = "http://www.linux-ntfs.org/"
+DEPENDS = "fuse"
+LICENSE = "GPLv2"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/linux-ntfs/ntfsprogs-2.0.0.tar.bz2 \
+ file://skip-erange-errors.patch"
+
+SRC_URI[md5sum] = "2b39dece8897bc748f4ab4c40ec7699e"
+SRC_URI[sha256sum] = "ad36e19706c7303b10aa0a9bf2c2dd0309b91cd0171f1c9eb361d94a85017432"
+
+inherit autotools
+
+EXTRA_OECONF += "--disable-gnome-vfs"