aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nxcl/libnxcl_0.9.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nxcl/libnxcl_0.9.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nxcl/libnxcl_0.9.bb')
-rw-r--r--recipes/nxcl/libnxcl_0.9.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/nxcl/libnxcl_0.9.bb b/recipes/nxcl/libnxcl_0.9.bb
new file mode 100644
index 0000000000..ebdb1b7f1c
--- /dev/null
+++ b/recipes/nxcl/libnxcl_0.9.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Backend library for the free nx-clients"
+HOMEPAGE = "http://freenx.berlios.de/"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r2"
+
+RDEPENDS = "nxproxy nxssh"
+
+SRC_URI = "http://download.berlios.de/freenx/freenx-client-${PV}.tar.bz2 \
+ file://gcc4.3-ftbfs.patch;patch=1 \
+ file://dodnx.patch;patch=1 \
+ file://gcc-warnings.patch;patch=1 \
+ file://restorekeyboard.patch;patch=1 \
+ file://publicKey.patch;patch=1 \
+ file://deletelogfiles.patch;patch=1 \
+ file://ssh_dnserror.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/freenx-client-${PV}/nxcl"
+
+EXTRA_OECONF += "--without-nxcmd \
+ --without-doxygen \
+ "
+
+inherit lib_package autotools pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}