aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nxproxy
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nxproxy
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nxproxy')
-rw-r--r--recipes/nxproxy/files/stdin.patch73
-rw-r--r--recipes/nxproxy/nxproxy_3.2.0-1.bb18
-rw-r--r--recipes/nxproxy/nxproxy_3.3.0-2.bb17
3 files changed, 108 insertions, 0 deletions
diff --git a/recipes/nxproxy/files/stdin.patch b/recipes/nxproxy/files/stdin.patch
new file mode 100644
index 0000000000..20c71dbf76
--- /dev/null
+++ b/recipes/nxproxy/files/stdin.patch
@@ -0,0 +1,73 @@
+Patch taken from the debian unstable package
+original posted by Fabian Franz on the freenx mailinglist
+
+
+Index: nxproxy/Main.c
+--- nxproxy/Main.c.old 2007-07-18 17:39:13.000000000 +0200
++++ nxproxy/Main.c 2008-03-12 04:40:30.000000000 +0100
+@@ -36,28 +36,48 @@
+ int result = -1;
+
+ char *options = NULL;
+-
++
++ char *nx_commfd_str = NULL;
++
+ options = getenv("NX_DISPLAY");
+-
+- if (NXTransParseCommandLine(argc, argv) < 0)
++
++ if ((nx_commfd_str = getenv("NX_COMMFD")) != NULL)
+ {
+- NXTransCleanup();
+- }
++ int nx_commfd = atoi(nx_commfd_str);
+
+- if (NXTransParseEnvironment(options, 0) < 0)
+- {
+- NXTransCleanup();
++ if (result)
++ result = NXTransCreate(nx_commfd, NX_MODE_SERVER, options);
++
++ // go into endless loop
++
++ if (result)
++ {
++ while (NXTransRunning(NX_FD_ANY))
++ result = NXTransContinue(NULL);
++ }
+ }
++ else
++ {
++ if (NXTransParseCommandLine(argc, argv) < 0)
++ {
++ NXTransCleanup();
++ }
++
++ if (NXTransParseEnvironment(options, 0) < 0)
++ {
++ NXTransCleanup();
++ }
++
++ /*
++ * This should not return...
++ */
++
++ #ifdef TEST
++ fprintf(stderr, "Main: Yielding control to NX entry point.\n");
++ #endif
+
+- /*
+- * This should not return...
+- */
+-
+- #ifdef TEST
+- fprintf(stderr, "Main: Yielding control to NX entry point.\n");
+- #endif
+-
+- result = NXTransProxy(NX_FD_ANY, NX_MODE_ANY, NX_DISPLAY_ANY);
++ result = NXTransProxy(NX_FD_ANY, NX_MODE_ANY, NX_DISPLAY_ANY);
++ }
+
+ /*
+ * ...So these should not be called.
diff --git a/recipes/nxproxy/nxproxy_3.2.0-1.bb b/recipes/nxproxy/nxproxy_3.2.0-1.bb
new file mode 100644
index 0000000000..68eb61416b
--- /dev/null
+++ b/recipes/nxproxy/nxproxy_3.2.0-1.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "The binary which uses libxcomp from nomachine"
+HOMEPAGE = "http://www.nomachine.com/"
+LICENSE = "GPL"
+PR = "r1"
+
+DEPENDS = "libxcomp"
+
+SRC_URI = "http://64.34.161.181/download/3.2.0/sources/${PN}-${PV}.tar.gz \
+ file://stdin.patch;patch=1 \
+ "
+inherit autotools
+
+S = "${WORKDIR}/nxproxy"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 nxproxy ${D}${bindir}/
+}
diff --git a/recipes/nxproxy/nxproxy_3.3.0-2.bb b/recipes/nxproxy/nxproxy_3.3.0-2.bb
new file mode 100644
index 0000000000..82229f9be8
--- /dev/null
+++ b/recipes/nxproxy/nxproxy_3.3.0-2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "The binary which uses libxcomp from nomachine"
+HOMEPAGE = "http://www.nomachine.com/"
+LICENSE = "GPL"
+PR = "r0"
+
+DEPENDS = "libxcomp"
+
+SRC_URI = "http://64.34.161.181/download/3.3.0/sources/${PN}-${PV}.tar.gz \
+ "
+inherit autotools
+
+S = "${WORKDIR}/nxproxy"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 nxproxy ${D}${bindir}/
+}