aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/nylon/simple-firewall.bb
diff options
context:
space:
mode:
authorMartin Dietze <di@fh-wedel.de>2009-05-20 00:36:25 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-20 10:16:06 +0200
commitcb70efeb71b3a1e5e8786d3488e4ec3a1580d45a (patch)
tree107d51ea437c6dea9543b984cdec70f3b6f34245 /recipes/nylon/simple-firewall.bb
parent24db351c88feaa1b7ef23dd20a95d2ce78fb5bd4 (diff)
downloadopenembedded-cb70efeb71b3a1e5e8786d3488e4ec3a1580d45a.tar.gz
various nylon stuff: Updates to nylon-only code, needed to work with the current OE.
Diffstat (limited to 'recipes/nylon/simple-firewall.bb')
-rw-r--r--recipes/nylon/simple-firewall.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/nylon/simple-firewall.bb b/recipes/nylon/simple-firewall.bb
new file mode 100644
index 0000000000..d9e6974480
--- /dev/null
+++ b/recipes/nylon/simple-firewall.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "simple firewall configuratiopn script"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Bruno Randolf <br1@einfach.org>"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel"
+# these kernel modules are needed if the functionality is not hard-built into the kernel:
+# kernel-module-ip-tables kernel-module-iptable-filter kernel-module-iptable-nat kernel-module-ipt-state kernel-module-ipt-reject kernel-module-ipt-masquerade
+RDEPENDS = "kernel-module-ipt-limit kernel-module-ipt-tcpmss"
+PV = "cvs20051022"
+
+SRC_URI = "http://br1.einfach.org/nylon/stable/sources/simple-firewall_gruen.4g__20051022.tar.gz \
+ file://simple-firewall-bash.diff;patch=1"
+S = "${WORKDIR}/${PN}"
+
+do_install() {
+ (cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
+}