summaryrefslogtreecommitdiffstats
path: root/recipes/nzbget
diff options
context:
space:
mode:
authorArtur Wronowski <arteqw@gmail.com>2009-11-05 20:44:52 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-05 20:45:49 +0100
commit9a06361338b59304ef7bdc5c9213b41f957253ae (patch)
tree3f2bc9241017bcdb194d5c4f63561d4b15f1f86f /recipes/nzbget
parent69026f3da9ee1777e1e7d64de4799dcbbec3af55 (diff)
downloadopenembedded-9a06361338b59304ef7bdc5c9213b41f957253ae.tar.gz
nzbget: new recipe; a command-line based binary newsgrabber for nzb files
Diffstat (limited to 'recipes/nzbget')
-rw-r--r--recipes/nzbget/nzbget.inc19
-rw-r--r--recipes/nzbget/nzbget_0.6.0.bb3
-rw-r--r--recipes/nzbget/nzbget_0.7.0-testing.bb5
3 files changed, 27 insertions, 0 deletions
diff --git a/recipes/nzbget/nzbget.inc b/recipes/nzbget/nzbget.inc
new file mode 100644
index 0000000000..93dcfead3d
--- /dev/null
+++ b/recipes/nzbget/nzbget.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "NZBGet is a command-line based binary newsgrabber for nzb files, written in C++"
+SECTION = "net"
+LICENSE = "GPL"
+HOMEPAGE = "http://nzbget.sourceforge.net/Main_Page"
+DEPENDS = "libsigc++-2.0 libpar2 ncurses libxml2"
+INC_PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/nzbget/nzbget-stable/nzbget-${PV}.tar.gz"
+S = "${WORKDIR}/nzbget-${PV}"
+
+inherit autotools_stage pkgconfig
+
+EXTRA_OECONF = "\
+ --disable-tls \
+ --with-libcurses-libraries=${STAGING_LIBDIR} \
+ --with-libcurses-includes=${STAGING_INCDIR} \
+ --with-libpar2-includes={STAGING_INCDIR} \
+ --with-libpar2-libraries={STAGING_INCDIR} \
+"
diff --git a/recipes/nzbget/nzbget_0.6.0.bb b/recipes/nzbget/nzbget_0.6.0.bb
new file mode 100644
index 0000000000..311d37627a
--- /dev/null
+++ b/recipes/nzbget/nzbget_0.6.0.bb
@@ -0,0 +1,3 @@
+require nzbget.inc
+PR = "${INC_PR}.0"
+
diff --git a/recipes/nzbget/nzbget_0.7.0-testing.bb b/recipes/nzbget/nzbget_0.7.0-testing.bb
new file mode 100644
index 0000000000..e4a9f232dc
--- /dev/null
+++ b/recipes/nzbget/nzbget_0.7.0-testing.bb
@@ -0,0 +1,5 @@
+require nzbget.inc
+PV = "0.6.9+0.7.0r342"
+SRC_URI = "${SOURCEFORGE_MIRROR}/nzbget/nzbget-stable/nzbget-0.7.0-testing-r342.tar.gz"
+S = "${WORKDIR}/nzbget-0.7.0-testing"
+