aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obexftp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/obexftp
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obexftp')
-rw-r--r--recipes/obexftp/files/i-hate-libtool.patch20
-rw-r--r--recipes/obexftp/files/iconv.patch24
-rw-r--r--recipes/obexftp/files/m4.patch64
-rw-r--r--recipes/obexftp/obexftp_0.20.bb22
-rw-r--r--recipes/obexftp/obexftp_0.22.bb30
5 files changed, 160 insertions, 0 deletions
diff --git a/recipes/obexftp/files/i-hate-libtool.patch b/recipes/obexftp/files/i-hate-libtool.patch
new file mode 100644
index 0000000000..1e31ac44b4
--- /dev/null
+++ b/recipes/obexftp/files/i-hate-libtool.patch
@@ -0,0 +1,20 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- obexftp-0.20/apps/Makefile.am~i-hate-libtool
++++ obexftp-0.20/apps/Makefile.am
+@@ -9,9 +9,9 @@
+ LDADD = ../obexftp/libobexftp.la \
+ ../multicobex/libmulticobex.la \
+ ../bfb/libbfb.la \
+- @OPENOBEX_LIBS@
+-# @BLUETOOTH_LIBS@
+-# @USB_LIBS@
++ @OPENOBEX_LIBS@ \
++ @BLUETOOTH_LIBS@
++# @USB_LIBS@
+ # need on win32:
+ # getopt.o getopt1.o libopenobex.a libwsock32.a
+
diff --git a/recipes/obexftp/files/iconv.patch b/recipes/obexftp/files/iconv.patch
new file mode 100644
index 0000000000..83b01a02fe
--- /dev/null
+++ b/recipes/obexftp/files/iconv.patch
@@ -0,0 +1,24 @@
+--- obexftp-0.20/obexftp/Makefile.am 2007-06-27 20:33:20.000000000 +0200
++++ obexftp-0.20/obexftp/Makefile.am 2007-06-27 20:35:05.000000000 +0200
+@@ -4,12 +4,6 @@
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/includes
+
+-LDADD = @OPENOBEX_LIBS@
+-# @BLUETOOTH_LIBS@ \
+-# @USB_LIBS@ \
+-# ../multicobex/libmulticobex.la \
+-# ../bfb/libbfb.la
+-
+ obexftpincludedir = $(includedir)/obexftp
+
+ libobexftp_la_SOURCES = object.c object.h \
+@@ -23,6 +17,8 @@
+ uuid.h \
+ object.h
+
++libobexftp_la_LIBADD = @OPENOBEX_LIBS@ @LIBICONV@
++
+ libobexftp_la_LDFLAGS = -version-info $(OBEXFTP_VERSION)
+
+ EXTRA_DIST = client.i
diff --git a/recipes/obexftp/files/m4.patch b/recipes/obexftp/files/m4.patch
new file mode 100644
index 0000000000..07c5eedcd7
--- /dev/null
+++ b/recipes/obexftp/files/m4.patch
@@ -0,0 +1,64 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- /dev/null 2003-09-23 18:19:32.000000000 -0400
++++ obexftp-0.10.3/m4/openobex.m4 2004-03-06 05:10:27.000000000 -0500
+@@ -0,0 +1,56 @@
++dnl Check for openobex library
++dnl Written by Pontus Fuchs 2000-08-18
++dnl Version checking fixed by Christian W. Zuckschwerdt 2002-10-17
++
++AC_DEFUN([AM_PATH_OPENOBEX], [
++ AC_PATH_PROG(OPENOBEX_CONFIG, openobex-config, no)
++
++ if test "$OPENOBEX_CONFIG" = "no" ; then
++ AC_MSG_ERROR(openobex-config not found. Pehaps openobex is not installed.)
++ fi
++
++ min_obex_version=ifelse([$1], ,0.9.6,$1)
++ AC_MSG_CHECKING(for openobex - version >= $min_obex_version)
++
++ OPENOBEX_CFLAGS=`$OPENOBEX_CONFIG --cflags`
++ OPENOBEX_LIBS=`$OPENOBEX_CONFIG --libs`
++
++ obex_config_version=`$OPENOBEX_CONFIG --version`
++
++ obex_config_major_version=`$OPENOBEX_CONFIG --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ obex_config_minor_version=`$OPENOBEX_CONFIG --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ obex_config_micro_version=`$OPENOBEX_CONFIG --version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++
++ obex_req_major_version=`echo $min_obex_version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
++ obex_req_minor_version=`echo $min_obex_version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
++ obex_req_micro_version=`echo $min_obex_version | \
++ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
++
++
++ if test $obex_req_major_version -lt $obex_config_major_version ; then
++ obex_config_version_ok="yes"
++ fi
++ if test $obex_req_major_version -eq $obex_config_major_version ; then
++ if test $obex_req_minor_version -lt $obex_config_minor_version ; then
++ obex_config_version_ok="yes"
++ fi
++ if test $obex_req_minor_version -eq $obex_config_minor_version ; then
++ if test $obex_req_micro_version -le $obex_config_micro_version ; then
++ obex_config_version_ok="yes"
++ fi
++ fi
++ fi
++
++ if test "$obex_config_version_ok" != "yes" ; then
++ AC_MSG_ERROR(Installed openobex library too old ($obex_config_version))
++ fi
++
++ AC_SUBST(OPENOBEX_CFLAGS)
++ AC_SUBST(OPENOBEX_LIBS)
++ AC_MSG_RESULT(yes)
++])
diff --git a/recipes/obexftp/obexftp_0.20.bb b/recipes/obexftp/obexftp_0.20.bb
new file mode 100644
index 0000000000..2a0b310a49
--- /dev/null
+++ b/recipes/obexftp/obexftp_0.20.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "OBEX Ftp Client based on openobex."
+SECTION = "console/network"
+HOMEPAGE = "http://openobex.triq.net"
+LICENSE = "GPL"
+DEPENDS = "openobex libgsm"
+PR = "r4"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.gz \
+ file://iconv.patch;patch=1 \
+ file://i-hate-libtool.patch;patch=1 \
+ file://m4.patch;patch=1"
+
+inherit autotools gettext
+
+EXTRA_OECONF += "--enable-bluetooth --disable-swig --disable-perl --disable-python --disable-tcl --disable-builddocs --disable-rpath"
+
+PARALLEL_MAKE = ""
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/obexftp/obexftp_0.22.bb b/recipes/obexftp/obexftp_0.22.bb
new file mode 100644
index 0000000000..89e10a72af
--- /dev/null
+++ b/recipes/obexftp/obexftp_0.22.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "OBEX Ftp Client based on openobex."
+SECTION = "console/network"
+HOMEPAGE = "http://dev.zuckschwerdt.org/openobex/wiki/ObexFtp"
+LICENSE = "GPL"
+DEPENDS = "openobex bluez-libs libusb virtual/libiconv"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/openobex/obexftp-${PV}.tar.bz2 \
+ "
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-bluetooth \
+ --disable-swig \
+ --disable-perl \
+ --disable-python \
+ --disable-tcl \
+ --disable-ruby \
+ --disable-builddocs \
+ --disable-rpath \
+ "
+
+PARALLEL_MAKE = ""
+
+LEAD_SONAME = "libobexftp.so"
+
+do_stage() {
+ autotools_stage_all
+}
+