aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-10 13:22:48 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-10 13:22:48 +0200
commit783f3cdb23b699566962eb396ae32b81ff9e4ef1 (patch)
tree755a12ff1fcd68d89c6fd28837b2466703c50ff2 /recipes/obsolete/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch
parent04736443306582cd0d2ce2fd081bf9dfa1c27adc (diff)
downloadopenembedded-783f3cdb23b699566962eb396ae32b81ff9e4ef1.tar.gz
openembedded-783f3cdb23b699566962eb396ae32b81ff9e4ef1.tar.bz2
openembedded-783f3cdb23b699566962eb396ae32b81ff9e4ef1.zip
gtk+ : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obsolete/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch')
-rw-r--r--recipes/obsolete/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch221
1 files changed, 221 insertions, 0 deletions
diff --git a/recipes/obsolete/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch b/recipes/obsolete/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch
new file mode 100644
index 0000000000..6b030e8f16
--- /dev/null
+++ b/recipes/obsolete/gtk+/gdk-pixbuf-csource/reduce-dependencies.patch
@@ -0,0 +1,221 @@
+#
+# strip unnecessary stuff out of configure, we just want
+# to build gdk-pixbuf-csource.
+# -- Michael 'Mickey' Lauer <mlauer@vanille-media.de>
+#
+---
+# configure.in | 116 ++---------------------------------------------------------
+# 1 file changed, 5 insertions(+), 111 deletions(-)
+#
+--- gtk+-2.12.7.orig/configure.in
++++ gtk+-2.12.7/configure.in
+@@ -30,13 +30,10 @@ m4_define([gtk_api_version], [2.0])
+ #GTK_BINARY_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$LT_CURRENT
+ m4_define([gtk_binary_version], [2.10.0])
+
+ # required versions of other packages
+ m4_define([glib_required_version], [2.13.5])
+-m4_define([pango_required_version], [1.17.3])
+-m4_define([atk_required_version], [1.9.0])
+-m4_define([cairo_required_version], [1.2.0])
+
+
+ AC_INIT([gtk+], [gtk_version],
+ [http://bugzilla.gnome.org/enter_bug.cgi?product=gtk%2B],
+ [gtk+])
+@@ -347,14 +344,11 @@ ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+ ## Later on we actually use the cflags/libs from separate pkg-config
+ ## calls. Oh, also the later pkg-config calls don't include
+ ## the version requirements since those make the module lists
+ ## annoying to construct
+ PKG_CHECK_MODULES(BASE_DEPENDENCIES,
+- [glib-2.0 >= glib_required_version dnl
+- atk >= atk_required_version dnl
+- pango >= pango_required_version dnl
+- cairo >= cairo_required_version])
++ [glib-2.0 >= glib_required_version])
+
+ if test "$os_win32" != yes; then
+ # libtool option to control which symbols are exported
+ # right now, symbols starting with _ are not exported
+ LIBTOOL_EXPORT_OPTIONS='-export-symbols-regex "^[[^_]].*"'
+@@ -1059,27 +1053,19 @@ GDK_PIXBUF_DEP_CFLAGS="`$PKG_CONFIG --cf
+
+ GDK_PIXBUF_XLIB_PACKAGES=
+ GDK_PIXBUF_XLIB_EXTRA_CFLAGS=
+ GDK_PIXBUF_XLIB_EXTRA_LIBS=
+
+-X_PACKAGES=fontconfig
++X_PACKAGES=
+ GDK_EXTRA_LIBS="$GDK_WLIBS"
+ GDK_EXTRA_CFLAGS=
+
+ # GTK+ uses some X calls, so needs to link against X directly
+ GTK_DEP_PACKAGES_FOR_X=
+ GTK_DEP_LIBS_FOR_X=
+
+ if test "x$gdktarget" = "xx11"; then
+- #
+- # We use fontconfig very peripherally when decoding the default
+- # settings.
+- #
+- if $PKG_CONFIG --exists fontconfig; then : ; else
+- AC_MSG_ERROR([
+-*** fontconfig (http://www.fontconfig.org) is required by the X11 backend.])
+- fi
+
+ #
+ # Check for basic X packages; we use pkg-config if available
+ #
+ if $PKG_CONFIG --exists x11 xext xrender; then
+@@ -1122,20 +1108,10 @@ if test "x$gdktarget" = "xx11"; then
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+
+ gtk_save_LIBS=$LIBS
+ LIBS="$x_libs_for_checks $LIBS"
+
+- # Sanity check for the X11 and Xext libraries. While everything we need from
+- # Xext is optional, the chances a system has *none* of these things is so
+- # small that we just unconditionally require it.
+- AC_CHECK_FUNC(XOpenDisplay, :,
+- AC_MSG_ERROR([*** libX11 not found. Check 'config.log' for more details.]))
+- AC_CHECK_FUNC(XextFindDisplay, :,
+- AC_MSG_ERROR([*** libXext not found. Check 'config.log' for more details.]))
+- AC_CHECK_FUNC(XRenderQueryExtension, :,
+- AC_MSG_ERROR([*** libXrender not found. Check 'config.log' for more details.]))
+-
+ # Check for xReply
+
+ AC_MSG_CHECKING([if <X11/extensions/XIproto.h> is needed for xReply])
+ AC_TRY_COMPILE([#include <X11/Xlibint.h>],
+ [xReply *rep;],
+@@ -1416,104 +1392,33 @@ if test "x$gdktarget" = "xdirectfb"; the
+ AM_CONDITIONAL(USE_DIRECTFB, true)
+ else
+ AM_CONDITIONAL(USE_DIRECTFB, false)
+ fi
+
+-
+-# Check for Pango flags
+-
+-if test "x$gdktarget" = "xwin32"; then
+- PANGO_PACKAGES="pangowin32 pangocairo"
+-else
+- PANGO_PACKAGES="pango pangocairo"
+-fi
+-
+-AC_MSG_CHECKING(Pango flags)
+-if $PKG_CONFIG --exists $PANGO_PACKAGES ; then
+- PANGO_CFLAGS=`$PKG_CONFIG --cflags $PANGO_PACKAGES`
+- PANGO_LIBS=`$PKG_CONFIG --libs $PANGO_PACKAGES`
+-
+- AC_MSG_RESULT($PANGO_CFLAGS $PANGO_LIBS)
+-else
+- AC_MSG_ERROR([
+-*** Pango not found. Pango built with Cairo support is required
+-*** to build GTK+. See http://www.pango.org for Pango information.
+-])
+-fi
+-
+-CFLAGS="$CFLAGS $PANGO_CFLAGS"
+-
+-if $PKG_CONFIG --uninstalled $PANGO_PACKAGES; then
+- :
+-else
+- gtk_save_LIBS="$LIBS"
+- LIBS="$PANGO_LIBS $LIBS"
+- AC_TRY_LINK_FUNC(pango_context_new, :, AC_MSG_ERROR([
+-*** Can't link to Pango. Pango is required to build
+-*** GTK+. For more information see http://www.pango.org]))
+- LIBS="$gtk_save_LIBS"
+-fi
+-
+-CFLAGS="$saved_cflags"
+-LDFLAGS="$saved_ldflags"
+-
+-GDK_PACKAGES="$PANGO_PACKAGES"
+-if test "x$gdktarget" = "xx11"; then
+- GDK_PACKAGES="$GDK_PACKAGES $X_PACKAGES"
+-fi
+ GDK_DEP_LIBS="$GDK_EXTRA_LIBS `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $GDK_PACKAGES` $GDK_PIXBUF_EXTRA_LIBS"
+ GDK_DEP_CFLAGS="`$PKG_CONFIG --cflags gthread-2.0 $GDK_PIXBUF_PACKAGES $GDK_PACKAGES` $GDK_PIXBUF_EXTRA_CFLAGS $GDK_EXTRA_CFLAGS"
+
+ #
+ # If we aren't writing explicit dependencies, then don't put the extra libraries we need
+ # into the pkg-config files
+ #
+ if test $enable_explicit_deps != yes ; then
+- GDK_PACKAGES="$PANGO_PACKAGES"
++ GDK_PACKAGES=
+ GDK_EXTRA_LIBS=
+ fi
+
+ AC_SUBST(GDK_PACKAGES)
+ AC_SUBST(GDK_EXTRA_LIBS)
+ AC_SUBST(GDK_EXTRA_CFLAGS)
+ AC_SUBST(GDK_DEP_LIBS)
+ AC_SUBST(GDK_DEP_CFLAGS)
+
+
+-########################################
+-# Check for Accessibility Toolkit flags
+-########################################
+-
+-ATK_PACKAGES=atk
+-AC_MSG_CHECKING(ATK flags)
+-if $PKG_CONFIG --exists $ATK_PACKAGES ; then
+- ATK_CFLAGS=`$PKG_CONFIG --cflags $ATK_PACKAGES`
+- ATK_LIBS=`$PKG_CONFIG --libs $ATK_PACKAGES`
+-
+- AC_MSG_RESULT($ATK_CFLAGS $ATK_LIBS)
+-else
+- AC_MSG_ERROR([
+-*** Accessibility Toolkit not found. Accessibility Toolkit is required
+-*** to build GTK+.
+-])
+-fi
+-
+-if $PKG_CONFIG --uninstalled $ATK_PACKAGES; then
+- :
+-else
+- gtk_save_LIBS="$LIBS"
+- LIBS="$ATK_LIBS $LIBS"
+- AC_TRY_LINK_FUNC(atk_object_get_type, : , AC_MSG_ERROR([
+- *** Cannot link to Accessibility Toolkit. Accessibility Toolkit is required
+- *** to build GTK+]))
+- LIBS="$gtk_save_LIBS"
+-fi
+-
+-GTK_PACKAGES="atk cairo"
++GTK_PACKAGES=
+ GTK_EXTRA_LIBS=
+ GTK_EXTRA_CFLAGS=
+-GTK_DEP_LIBS="$GDK_EXTRA_LIBS $GTK_DEP_LIBS_FOR_X `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $PANGO_PACKAGES $GTK_PACKAGES_FOR_X $GTK_PACKAGES` $GTK_EXTRA_LIBS $GDK_PIXBUF_EXTRA_LIBS"
++GTK_DEP_LIBS="$GDK_EXTRA_LIBS $GTK_DEP_LIBS_FOR_X `$PKG_CONFIG --libs $GDK_PIXBUF_PACKAGES $GTK_PACKAGES_FOR_X $GTK_PACKAGES` $GTK_EXTRA_LIBS $GDK_PIXBUF_EXTRA_LIBS"
+ GTK_DEP_CFLAGS="`$PKG_CONFIG --cflags gthread-2.0 $GDK_PIXBUF_PACKAGES $GDK_PACKAGES $GTK_PACKAGES` $GDK_PIXBUF_EXTRA_CFLAGS $GDK_EXTRA_CFLAGS $GTK_EXTRA_CFLAGS"
+
+ if test x"$os_win32" = xyes; then
+ GTK_EXTRA_CFLAGS="$msnative_struct"
+ fi
+@@ -1567,21 +1472,10 @@ LIBS="$CUPS_LIBS"
+ AC_CHECK_FUNCS(httpGetAuthString)
+ LIBS="$gtk_save_libs"
+
+ gtk_save_cppflags="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $GTK_DEP_CFLAGS"
+-
+-AC_CHECK_HEADER(cairo-pdf.h,,AC_MSG_ERROR([
+-*** Can't find cairo-pdf.h. You must build Cairo with the pdf
+-*** backend enabled.]))
+-
+-if test "$os_win32" != "yes"; then
+- AC_CHECK_HEADER(cairo-ps.h,,AC_MSG_ERROR([
+-*** Can't find cairo-ps.h. You must build Cairo with the
+-*** postscript backend enabled.]))
+-fi
+-
+ CPPFLAGS="$gtk_save_cppflags"
+
+
+ AC_ARG_ENABLE(test-print-backend,
+ [AC_HELP_STRING([--enable-test-print-backend],