aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/openmoko2
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-10-19 09:22:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-10-19 22:32:16 +0200
commit83847370bdcd13cc39adfbc1a1109584efc7fe00 (patch)
tree006ac8fae469825f5e14e69e93c67f13b2c0aa10 /recipes/obsolete/openmoko2
parenta8caf896c9000d9f09a445f622b765a835fc9baa (diff)
downloadopenembedded-83847370bdcd13cc39adfbc1a1109584efc7fe00.tar.gz
openmoko: obsolete tasks and images, openmoko as distribution was obsoleted on Aug 10, 2010.
Acked-by: Michael 'Mickey' Lauer <mickey@openmoko.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/obsolete/openmoko2')
-rw-r--r--recipes/obsolete/openmoko2/openmoko-session2.bb53
-rwxr-xr-xrecipes/obsolete/openmoko2/openmoko-session2/etc/matchbox/session12
-rwxr-xr-xrecipes/obsolete/openmoko2/openmoko-session2/matchbox-session24
3 files changed, 89 insertions, 0 deletions
diff --git a/recipes/obsolete/openmoko2/openmoko-session2.bb b/recipes/obsolete/openmoko2/openmoko-session2.bb
new file mode 100644
index 0000000000..d0c3268e0c
--- /dev/null
+++ b/recipes/obsolete/openmoko2/openmoko-session2.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Custom Matchbox session files for Openmoko"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS_${PN} = "matchbox-panel-2 openmoko-common2 openmoko-today2 openmoko-dialer2"
+RCONFLICTS_${PN} = "openmoko-session matchbox-common"
+PR = "r69"
+
+SRC_URI = "\
+ file://etc \
+ file://matchbox-session \
+"
+
+S = "${WORKDIR}"
+
+inherit update-alternatives
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0655 ${WORKDIR}/matchbox-session ${D}${bindir}
+ install -d ${D}${sysconfdir}
+ cp -R ${S}/etc/* ${D}${sysconfdir}
+ rm -fR ${D}${sysconfdir}/.svn
+ rm -fR ${D}${sysconfdir}/matchbox/.svn
+ chmod -R 755 ${D}${sysconfdir}/
+}
+
+PACKAGE_ARCH = "all"
+
+pkg_postinst_openmoko-session2 () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Moko
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme openmoko-standard
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 5"
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/wallpaper ${datadir}/pixmaps/wallpaper.png
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type bool --set /desktop/poky/interface/digital_clock 1
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/poky/peripherals/mouse/drag_threshold 8
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type int --set /desktop/openmoko/neod/power_management 2
+# gstreamer audio settings
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosink pulsesink
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct -t string --set /system/gstreamer/0.10/default/audiosrc pulsesrc
+
+}
+
+ALTERNATIVE_NAME = "x-window-manager"
+ALTERNATIVE_PATH = "${bindir}/matchbox-session"
+ALTERNATIVE_LINK = "${bindir}/x-window-manager"
+ALTERNATIVE_PRIORITY = "11"
+
+CONFFILES_${PN} = "${sysconfdir}/matchbox/session"
diff --git a/recipes/obsolete/openmoko2/openmoko-session2/etc/matchbox/session b/recipes/obsolete/openmoko2/openmoko-session2/etc/matchbox/session
new file mode 100755
index 0000000000..732cce9d3f
--- /dev/null
+++ b/recipes/obsolete/openmoko2/openmoko-session2/etc/matchbox/session
@@ -0,0 +1,12 @@
+#!/bin/sh
+SHOWCURSOR="no"
+
+openmoko-today &
+phone-kit &
+
+matchbox-window-manager -use_titlebar yes -use_desktop_mode decorated -theme Moko -use_cursor $SHOWCURSOR $@ &
+
+matchbox-panel-2 --start-applets systray,startup \
+ --end-applets openmoko-panel-battery,openmoko-panel-gsm,openmoko-panel-gps,openmoko-panel-usb,openmoko-panel-bt,openmoko-panel-memory,openmoko-panel-wifi --titlebar &
+
+exec neod
diff --git a/recipes/obsolete/openmoko2/openmoko-session2/matchbox-session b/recipes/obsolete/openmoko2/openmoko-session2/matchbox-session
new file mode 100755
index 0000000000..65f1ce72ca
--- /dev/null
+++ b/recipes/obsolete/openmoko2/openmoko-session2/matchbox-session
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Very simple session manager for matchbox tools
+#
+
+# Uncomment below to enable parsing of debian menu entrys
+# export MB_USE_DEB_MENUS=1
+
+if [ -e $HOME/.matchbox/session ]
+then
+exec $HOME/.matchbox/session
+fi
+
+if [ -e /etc/matchbox/session ]
+then
+exec /etc/matchbox/session
+fi
+
+# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
+# dont exist.
+
+matchbox-desktop &
+matchbox-panel --orientation south &
+exec matchbox-window-manager $@