aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/tor
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-06 18:49:15 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-06 18:49:15 +0200
commite2d2f6959cbfe653833a322fa17544b58d89d9d5 (patch)
treeef822777fa5d55b92bca7eb73f32312542540e44 /recipes/obsolete/tor
parent673b9cc2063f14350a22e8ee4ac38effe4c5da1d (diff)
downloadopenembedded-e2d2f6959cbfe653833a322fa17544b58d89d9d5.tar.gz
tor : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obsolete/tor')
-rw-r--r--recipes/obsolete/tor/tor-0.1.1.26/openssl.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes/obsolete/tor/tor-0.1.1.26/openssl.patch b/recipes/obsolete/tor/tor-0.1.1.26/openssl.patch
new file mode 100644
index 0000000000..e413486273
--- /dev/null
+++ b/recipes/obsolete/tor/tor-0.1.1.26/openssl.patch
@@ -0,0 +1,71 @@
+diff -Naur tor-0.1.1.23/configure.in tor-0.1.1.23_patched/configure.in
+--- tor-0.1.1.23/configure.in 2006-09-04 20:42:21.000000000 +0200
++++ tor-0.1.1.23_patched/configure.in 2006-09-04 20:45:09.000000000 +0200
+
+@@ -234,66 +234,6 @@
+ fi
+ fi
+
+-AC_CACHE_CHECK([whether we need extra options to link OpenSSL],
+- ac_cv_openssl_linker_option, [
+- saved_LDFLAGS="$LDFLAGS"
+- ssl_runs=no
+- linked_with=nothing
+- for ssl_extra in "" "-Wl,-R$ssl_libdir" "-R$ssl_libdir" ; do
+- LDFLAGS="$ssl_extra $saved_LDFLAGS"
+- AC_TRY_RUN([
+-#include <string.h>
+-#include <openssl/rand.h>
+-int main(void)
+-{
+- char a[2048];
+- memset(a, 0, sizeof(a));
+- RAND_add(a, sizeof(a), sizeof(a));
+- return(RAND_status() <= 0);
+-}
+- ],
+- openssl_runs=yes, openssl_runs=no)
+- if test $openssl_runs = yes ; then
+- if test "$linked_with" = nothing; then
+- linked_with="$ssl_extra"
+- fi
+- AC_TRY_RUN([
+-#include <openssl/opensslv.h>
+-#include <openssl/crypto.h>
+-int main(void) {
+-return (OPENSSL_VERSION_NUMBER == SSLeay()) == 0;
+-}],
+- right_version=yes, right_version=no)
+- if test "$right_version" = yes; then
+- if test -z "$ssl_extra" ; then
+- ac_cv_openssl_linker_option='(none)'
+- else
+- ac_cv_openssl_linker_option=$ssl_extra
+- fi
+- ssl_runs=yes
+- break
+- fi
+- fi
+- done
+- if test $ssl_runs = no ; then
+- if test "$linked_with" = 'nothing' ; then
+- AC_MSG_ERROR([Found linkable OpenSSL in $ac_cv_openssl_dir, but it doesn't run, even with -R. Maybe specify another using --with-ssl-dir?])
+- else
+- if test -z "$linked_with" ; then
+- ac_cv_openssl_linker_option='(none)'
+- else
+- ac_cv_openssl_linker_option=$linked_with
+- fi
+- AC_MSG_WARN([I managed to make OpenSSL link and run, but I couldn't make it link against the same version I found header files for.])
+- fi
+- fi
+- LDFLAGS="$saved_LDFLAGS"
+-])
+-
+-if test "$ac_cv_openssl_linker_option" != '(none)' ; then
+- LDFLAGS="$ac_cv_openssl_linker_option $LDFLAGS"
+-fi
+-
+ dnl Make sure to enable support for large off_t if avalable.
+
+ AC_SYS_LARGEFILE