aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete/zd1211
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2010-01-16 15:08:38 +0100
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2010-01-16 15:23:39 +0100
commit83f66a32dca5628342e49735f1b45800350b9b22 (patch)
treefd059d4a3347c69b60b155fa396c8666de7fa909 /recipes/obsolete/zd1211
parentcc13f5b5773379c39262a221b2f9b4d60d64dcff (diff)
downloadopenembedded-83f66a32dca5628342e49735f1b45800350b9b22.tar.gz
zd1211: move oldest and unfetchable entries to obsolete/
Diffstat (limited to 'recipes/obsolete/zd1211')
-rw-r--r--recipes/obsolete/zd1211/zd1211-r77/makefile-unslung.patch48
-rw-r--r--recipes/obsolete/zd1211/zd1211-r77/makefile.patch47
-rw-r--r--recipes/obsolete/zd1211/zd1211-r83/makefile-unslung.patch48
-rw-r--r--recipes/obsolete/zd1211/zd1211-r83/makefile.patch47
-rw-r--r--recipes/obsolete/zd1211/zd1211_r77.bb29
-rw-r--r--recipes/obsolete/zd1211/zd1211_r83.bb29
6 files changed, 248 insertions, 0 deletions
diff --git a/recipes/obsolete/zd1211/zd1211-r77/makefile-unslung.patch b/recipes/obsolete/zd1211/zd1211-r77/makefile-unslung.patch
new file mode 100644
index 0000000000..4edcbb7a9d
--- /dev/null
+++ b/recipes/obsolete/zd1211/zd1211-r77/makefile-unslung.patch
@@ -0,0 +1,48 @@
+--- zd1211-driver-r77/Makefile.orig 2006-02-25 16:04:26.000000000 +0100
++++ zd1211-driver-r77/Makefile 2006-02-25 17:11:27.000000000 +0100
+@@ -4,24 +4,23 @@
+ #
+ #
+
+-CC=gcc
+-CPP=g++
+-LD=ld
+-rM=rm -f -r
++CC ?= gcc
++CPP ?= g++
++LD ?= ld
+
+-MODPATH := /lib/modules/$(shell uname -r)
++MODPATH ?= /lib/modules/$(shell uname -r)
+
+ # if the kernel is 2.6.x, turn on this
+-KERN_26=y
++#KERN_26=y
+
+-KERNEL_SOURCE=$(MODPATH)/source
++KERNEL_SOURCE ?= $(MODPATH)/source
+ #KERNEL_SOURCE=/usr/src/linux
+
+ # set to 1 for zd1211b
+ ZD1211REV_B=0
+
+-SRC_DIR=src
+-DEFINES=-D__KERNEL__ -DMODULE=1
++SRC_DIR=src
++DEFINES ?=-D__KERNEL__ -DMODULE=1
+
+
+
+@@ -227,9 +226,9 @@
+ depmod -a
+
+ #for apdbg
+- gcc -o apdbg apdbg.c
+- chmod +x apdbg
+- cp ./apdbg /sbin/apdbg
++# gcc -o apdbg apdbg.c
++# chmod +x apdbg
++# cp ./apdbg /sbin/apdbg
+
+ clean:
+ rm -rf .tmp_versions .*.cmd *.ko *.mod.c *.mod.o *.o $(SRC_DIR)/*.o $(SRC_DIR)/.*.o.cmd
diff --git a/recipes/obsolete/zd1211/zd1211-r77/makefile.patch b/recipes/obsolete/zd1211/zd1211-r77/makefile.patch
new file mode 100644
index 0000000000..ed111e07ef
--- /dev/null
+++ b/recipes/obsolete/zd1211/zd1211-r77/makefile.patch
@@ -0,0 +1,47 @@
+--- zd1211-driver-r77/Makefile.orig 2006-02-25 16:04:26.000000000 +0100
++++ zd1211-driver-r77/Makefile 2006-02-25 17:11:27.000000000 +0100
+@@ -4,24 +4,23 @@
+ #
+ #
+
+-CC=gcc
+-CPP=g++
+-LD=ld
+-rM=rm -f -r
++CC ?= gcc
++CPP ?= g++
++LD ?= ld
+
+-MODPATH := /lib/modules/$(shell uname -r)
++MODPATH ?= /lib/modules/$(shell uname -r)
+
+ # if the kernel is 2.6.x, turn on this
+ KERN_26=y
+
+-KERNEL_SOURCE=$(MODPATH)/source
++KERNEL_SOURCE ?= $(MODPATH)/source
+ #KERNEL_SOURCE=/usr/src/linux
+
+ # set to 1 for zd1211b
+ ZD1211REV_B=0
+
+-SRC_DIR=src
+-DEFINES=-D__KERNEL__ -DMODULE=1
++SRC_DIR=src
++DEFINES ?=-D__KERNEL__ -DMODULE=1
+
+
+
+@@ -227,9 +226,9 @@
+ depmod -a
+
+ #for apdbg
+- gcc -o apdbg apdbg.c
+- chmod +x apdbg
+- cp ./apdbg /sbin/apdbg
++# gcc -o apdbg apdbg.c
++# chmod +x apdbg
++# cp ./apdbg /sbin/apdbg
+
+ clean:
+ rm -rf .tmp_versions .*.cmd *.ko *.mod.c *.mod.o *.o $(SRC_DIR)/*.o $(SRC_DIR)/.*.o.cmd
diff --git a/recipes/obsolete/zd1211/zd1211-r83/makefile-unslung.patch b/recipes/obsolete/zd1211/zd1211-r83/makefile-unslung.patch
new file mode 100644
index 0000000000..bc189e823f
--- /dev/null
+++ b/recipes/obsolete/zd1211/zd1211-r83/makefile-unslung.patch
@@ -0,0 +1,48 @@
+--- zd1211-driver-r83.orig/Makefile 2006-07-09 04:59:42.000000000 -0500
++++ zd1211-driver-r83/Makefile 2006-10-21 16:27:41.000000000 -0500
+@@ -4,25 +4,25 @@
+ #
+ #
+
+-CC=gcc
+-CPP=g++
+-LD=ld
++CC ?= gcc
++CPP ?= g++
++LD ?= ld
+ rM=rm -f -r
+
+ VERSION := $(shell uname -r)
+-MODPATH := /lib/modules/$(VERSION)
++MODPATH ?= /lib/modules/$(VERSION)
+
+ # if the kernel is 2.6.x, turn on this
+-KERN_26=y
++#KERN_26=y
+
+-KERNEL_SOURCE=$(MODPATH)/source
++KERNEL_SOURCE ?= $(MODPATH)/source
+ #KERNEL_SOURCE=/usr/src/linux
+
+ # set to 1 for zd1211b
+ ZD1211REV_B=0
+
+ SRC_DIR=src
+-DEFINES=-D__KERNEL__ -DMODULE=1
++DEFINES ?= -D__KERNEL__ -DMODULE=1
+
+
+
+@@ -228,9 +228,9 @@
+ depmod -a $(VERSION)
+
+ #for apdbg
+- gcc -o apdbg apdbg.c
+- chmod +x apdbg
+- cp ./apdbg /sbin/apdbg
++# gcc -o apdbg apdbg.c
++# chmod +x apdbg
++# cp ./apdbg /sbin/apdbg
+
+ clean:
+ rm -rf .tmp_versions .*.cmd *.ko *.mod.c *.mod.o *.o $(SRC_DIR)/*.o $(SRC_DIR)/.*.o.cmd
diff --git a/recipes/obsolete/zd1211/zd1211-r83/makefile.patch b/recipes/obsolete/zd1211/zd1211-r83/makefile.patch
new file mode 100644
index 0000000000..adc2bd416d
--- /dev/null
+++ b/recipes/obsolete/zd1211/zd1211-r83/makefile.patch
@@ -0,0 +1,47 @@
+--- zd1211-driver-r83/Makefile.orig 2006-09-02 16:00:00.000000000 +0200
++++ zd1211-driver-r83/Makefile 2006-09-02 16:01:57.000000000 +0200
+@@ -4,10 +4,10 @@
+ #
+ #
+
+-CC=gcc
+-CPP=g++
+-LD=ld
+-rM=rm -f -r
++#CC=gcc
++#CPP=g++
++#LD=ld
++#rM=rm -f -r
+
+ VERSION := $(shell uname -r)
+ MODPATH := /lib/modules/$(VERSION)
+@@ -15,14 +15,14 @@
+ # if the kernel is 2.6.x, turn on this
+ KERN_26=y
+
+-KERNEL_SOURCE=$(MODPATH)/source
++KERNEL_SOURCE ?= $(MODPATH)/source
+ #KERNEL_SOURCE=/usr/src/linux
+
+ # set to 1 for zd1211b
+ ZD1211REV_B=0
+
+ SRC_DIR=src
+-DEFINES=-D__KERNEL__ -DMODULE=1
++DEFINES ?= -D__KERNEL__ -DMODULE=1
+
+
+
+@@ -228,9 +228,9 @@
+ depmod -a $(VERSION)
+
+ #for apdbg
+- gcc -o apdbg apdbg.c
+- chmod +x apdbg
+- cp ./apdbg /sbin/apdbg
++# gcc -o apdbg apdbg.c
++# chmod +x apdbg
++# cp ./apdbg /sbin/apdbg
+
+ clean:
+ rm -rf .tmp_versions .*.cmd *.ko *.mod.c *.mod.o *.o $(SRC_DIR)/*.o $(SRC_DIR)/.*.o.cmd
diff --git a/recipes/obsolete/zd1211/zd1211_r77.bb b/recipes/obsolete/zd1211/zd1211_r77.bb
new file mode 100644
index 0000000000..8321f8d96c
--- /dev/null
+++ b/recipes/obsolete/zd1211/zd1211_r77.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Driver for zd1211 family of wireless USB Dongles"
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+PR = "r3"
+RDEPENDS = "wireless-tools"
+
+SRC_URI = "http://zd1211.ath.cx/download/zd1211-driver-${PV}.tgz \
+ file://makefile.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/zd1211-driver-${PV}"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CC LD CPP
+ oe_runmake 'MODPATH=${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net' \
+ 'KERNEL_SOURCE=${STAGING_KERNEL_DIR}' \
+ 'KDIR=${STAGING_KERNEL_DIR}' \
+ 'KERNEL_VERSION=${KERNEL_VERSION}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
+ install -m 0644 ${S}/zd1211*${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
+}
diff --git a/recipes/obsolete/zd1211/zd1211_r83.bb b/recipes/obsolete/zd1211/zd1211_r83.bb
new file mode 100644
index 0000000000..0f7bb7d5c8
--- /dev/null
+++ b/recipes/obsolete/zd1211/zd1211_r83.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Driver for zd1211 family of wireless USB Dongles"
+HOMEPAGE = "http://zd1211.ath.cx/"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "wireless-tools"
+PR = "r1"
+
+SRC_URI = "http://zd1211.ath.cx/download/zd1211-driver-${PV}.tgz \
+ file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/zd1211-driver-${PV}"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS CC LD CPP
+ oe_runmake 'MODPATH={D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net' \
+ 'KERNEL_SOURCE=${STAGING_KERNEL_DIR}' \
+ 'KDIR=${STAGING_KERNEL_DIR}' \
+ 'KERNEL_VERSION=${KERNEL_VERSION}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
+ install -m 0644 ${S}/zd1211*${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/net
+}