aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 18:49:15 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 19:02:28 +0100
commit46e9c80a67a6fc946a450061a26fee1eeb3a2bbc (patch)
tree1af6ad9eb28a01b7e00446a9ae5224d95e6eb02c /recipes/obsolete
parenta209e3adf6715c847441d1f7bb4ba8836b395774 (diff)
downloadopenembedded-46e9c80a67a6fc946a450061a26fee1eeb3a2bbc.tar.gz
ewl: move to obsolete
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/efl1/ewl_svn.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes/obsolete/efl1/ewl_svn.bb b/recipes/obsolete/efl1/ewl_svn.bb
new file mode 100644
index 0000000000..0c9d7ca0ec
--- /dev/null
+++ b/recipes/obsolete/efl1/ewl_svn.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "The Enlightened Widget Library"
+DEPENDS = "evas ecore edje emotion efreet"
+LICENSE = "MIT BSD"
+PV = "0.5.3.050+svnr${SRCPV}"
+PR = "r2"
+SRCREV = "${EFL_SRCREV_1.0.0}"
+
+inherit efl
+SRC_URI = "${E_SVN}/BROKEN;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
+
+EXTRA_OECONF = "\
+ --enable-software-x11 \
+ --enable-software-16-x11 \
+ --enable-xrender-x11 \
+ --disable-opengl-x11 \
+ --disable-software-xcb \
+ --disable-software-sdl \
+ --enable-framebuffer \
+ --enable-software-buffer \
+ --disable-opengl-glew \
+"
+
+do_configure_prepend() {
+ autopoint
+}
+
+# TODO package engines more granular
+PACKAGES += "${PN}-plugins ${PN}-engines"
+
+FILES_${PN} += "${sysconfdir}/ewl/*"
+FILES_${PN}-tests += "${libdir}/ewl/tests/*.so*"
+FILES_${PN}-dev += "${libdir}/ewl/*/*.a ${libdir}/ewl/*/*.la"
+FILES_${PN}-dbg += "${libdir}/ewl/*/.debug"
+
+FILES_${PN}-engines = "${libdir}/ewl/engines/*.so*"
+FILES_${PN}-plugins = "${libdir}/ewl/plugins/*.so*"
+
+RRECOMMENDS_${PN} = "${PN}-engines ${PN}-plugins ewl-themes"