aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2011-01-27 02:13:24 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-12 08:15:13 -0700
commit4d0d6c2640a3c32278db2caf196db761dfc03473 (patch)
tree3f9e26edf32af78a98baec0d4f07c55e3237eb7c /recipes/obsolete
parent6265887b16489caf6f35fef1b15e7fbe8e645b26 (diff)
downloadopenembedded-4d0d6c2640a3c32278db2caf196db761dfc03473.tar.gz
fakeroot: add 1.14.5, mv 1.12.4 to obsolete
The other old recipes should be removed. - oplinux suggests 1.7.1 which is not available anymore - chinook-compat, maemo5-compat pin 1.9.6 Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/fakeroot/fakeroot-native_1.12.4.bb21
-rw-r--r--recipes/obsolete/fakeroot/fakeroot_1.12.4.bb26
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes/obsolete/fakeroot/fakeroot-native_1.12.4.bb b/recipes/obsolete/fakeroot/fakeroot-native_1.12.4.bb
new file mode 100644
index 0000000000..e6add2bb26
--- /dev/null
+++ b/recipes/obsolete/fakeroot/fakeroot-native_1.12.4.bb
@@ -0,0 +1,21 @@
+require fakeroot_${PV}.bb
+
+SRC_URI += "file://fix-prefix.patch"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+inherit native
+
+EXTRA_OECONF = "--program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+NATIVE_INSTALL_WORKS = "1"
+
+RDEPENDS_${PN} = "util-linux-native"
+
+SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
+SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"
diff --git a/recipes/obsolete/fakeroot/fakeroot_1.12.4.bb b/recipes/obsolete/fakeroot/fakeroot_1.12.4.bb
new file mode 100644
index 0000000000..c265749f64
--- /dev/null
+++ b/recipes/obsolete/fakeroot/fakeroot_1.12.4.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Gives a fake root environment"
+HOMEPAGE = "http://fakeroot.alioth.debian.org"
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r2"
+
+SRC_URI = "\
+ ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.tar.gz \
+ file://configure-libtool.patch \
+"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${includedir}/fakeroot
+ install -m 644 *.h ${D}${includedir}/fakeroot
+ install -d ${D}${libdir}/libfakeroot/
+ oe_libinstall -so libfakeroot ${D}${libdir}/libfakeroot/
+}
+
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS_${PN} = "util-linux"
+
+
+SRC_URI[md5sum] = "aaefede2405a40c87438e7e833d69b70"
+SRC_URI[sha256sum] = "dbcab1f495b857e67feff882e018ca59958b8d189ff1f76684d28e35463ec29d"