aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-02 09:19:18 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-02 09:20:54 +0200
commit11840b3ac70805274d766de44d25893291bb1d66 (patch)
tree4738158c8bc6a59cf75d4c4989d89f5ed22f9db9 /recipes/obsolete
parent6f27f9435359f3107791fddb89b089adcbd1a1f1 (diff)
downloadopenembedded-11840b3ac70805274d766de44d25893291bb1d66.tar.gz
hal : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/hal/files/autoconf.diff11
-rw-r--r--recipes/obsolete/hal/files/dbus-fix-api.patch26
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes/obsolete/hal/files/autoconf.diff b/recipes/obsolete/hal/files/autoconf.diff
new file mode 100644
index 0000000000..eb30cccdbe
--- /dev/null
+++ b/recipes/obsolete/hal/files/autoconf.diff
@@ -0,0 +1,11 @@
+--- hal-0.5.9/configure.in~ 2007-04-03 05:36:44.000000000 +0100
++++ hal-0.5.9/configure.in 2007-04-03 10:29:39.000000000 +0100
+@@ -6,7 +6,7 @@
+ # Patches for that is welcome.
+ #
+
+-AC_PREREQ(2.59c)
++AC_PREREQ(2.59)
+ AC_INIT(hal, 0.5.9, david@fubar.dk)
+ AM_INIT_AUTOMAKE(hal, 0.5.9)
+ AM_CONFIG_HEADER(config.h)
diff --git a/recipes/obsolete/hal/files/dbus-fix-api.patch b/recipes/obsolete/hal/files/dbus-fix-api.patch
new file mode 100644
index 0000000000..1f025870bc
--- /dev/null
+++ b/recipes/obsolete/hal/files/dbus-fix-api.patch
@@ -0,0 +1,26 @@
+Index: hal-0.5.7/tools/lshal.c
+===================================================================
+--- hal-0.5.7.orig/tools/lshal.c 2006-02-13 14:35:31.000000000 +0000
++++ hal-0.5.7/tools/lshal.c 2006-11-09 13:48:07.000000000 +0000
+@@ -701,7 +701,7 @@
+ libhal_ctx_shutdown (hal_ctx, &error);
+ libhal_ctx_free (hal_ctx);
+
+- dbus_connection_disconnect (conn);
++ dbus_connection_close (conn);
+ dbus_connection_unref (conn);
+
+ if (show_device)
+Index: hal-0.5.7/tools/hal-device.c
+===================================================================
+--- hal-0.5.7.orig/tools/hal-device.c 2006-11-09 13:49:44.000000000 +0000
++++ hal-0.5.7/tools/hal-device.c 2006-11-09 13:50:00.000000000 +0000
+@@ -155,7 +155,7 @@
+
+ libhal_ctx_shutdown(hal_ctx, &error);
+ libhal_ctx_free(hal_ctx);
+- dbus_connection_disconnect(conn);
++ dbus_connection_close(conn);
+ dbus_connection_unref(conn);
+ dbus_error_free(&error);
+