aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-02 09:19:32 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-10-02 09:20:55 +0200
commit8d45059b0b21df2039ef0505567ecb37522c2024 (patch)
tree0fe66de103a501027051795b8cc0734b161fd266 /recipes/obsolete
parent11840b3ac70805274d766de44d25893291bb1d66 (diff)
downloadopenembedded-8d45059b0b21df2039ef0505567ecb37522c2024.tar.gz
hostap : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/hostap/files/hostap-no-bsd.patch19
-rw-r--r--recipes/obsolete/hostap/hostap-modules/Makefile.patch11
-rw-r--r--recipes/obsolete/hostap/hostap-modules/add_event.patch28
-rw-r--r--recipes/obsolete/hostap/hostap-modules/hostap-utsname.patch77
-rw-r--r--recipes/obsolete/hostap/hostap-modules/hostap_cardid.patch70
5 files changed, 205 insertions, 0 deletions
diff --git a/recipes/obsolete/hostap/files/hostap-no-bsd.patch b/recipes/obsolete/hostap/files/hostap-no-bsd.patch
new file mode 100644
index 0000000000..c40d98c959
--- /dev/null
+++ b/recipes/obsolete/hostap/files/hostap-no-bsd.patch
@@ -0,0 +1,19 @@
+--- hostapd-0.4.4/driver_madwifi.c-orig 2008-04-16 15:11:49.000000000 +0200
++++ hostapd-0.4.4/driver_madwifi.c 2008-04-16 15:10:38.000000000 +0200
+@@ -26,14 +26,14 @@
+ #include <net80211/ieee80211.h>
+ #ifdef WME_NUM_AC
+ /* Assume this is built against BSD branch of madwifi driver. */
+-#define MADWIFI_BSD
++/*#define MADWIFI_BSD*/
++#include <linux/wireless.h>
+ #include <net80211/_ieee80211.h>
+ #endif /* WME_NUM_AC */
+ #include <net80211/ieee80211_crypto.h>
+ #include <net80211/ieee80211_ioctl.h>
+
+ #include <net/if_arp.h>
+-#include <linux/wireless.h>
+
+ #include <netinet/in.h>
+ #include <netpacket/packet.h>
diff --git a/recipes/obsolete/hostap/hostap-modules/Makefile.patch b/recipes/obsolete/hostap/hostap-modules/Makefile.patch
new file mode 100644
index 0000000000..2fc5e9ed4b
--- /dev/null
+++ b/recipes/obsolete/hostap/hostap-modules/Makefile.patch
@@ -0,0 +1,11 @@
+--- hostap-driver-0.2.4/Makefile.old 2004-07-31 10:35:50.000000000 +0100
++++ hostap-driver-0.2.4/Makefile 2004-07-31 10:35:56.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ VERFILE := $(KERNEL_PATH)/include/linux/version.h
+ KERNELRELEASE := $(shell if [ -r $(VERFILE) ]; \
+- then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -1 | xargs echo; \
++ then (cat $(VERFILE); echo UTS_RELEASE) | $(CC) $(INCLUDES) $(CFLAGS) -E - | tail -n 1 | xargs echo; \
+ else uname -r; fi)
+ KERNELVER := $(shell echo "$(KERNELRELEASE)" | \
+ sed "s/\([0-9]*\.[0-9]*\.[0-9]*\).*/\1/")
diff --git a/recipes/obsolete/hostap/hostap-modules/add_event.patch b/recipes/obsolete/hostap/hostap-modules/add_event.patch
new file mode 100644
index 0000000000..d5f2a10e86
--- /dev/null
+++ b/recipes/obsolete/hostap/hostap-modules/add_event.patch
@@ -0,0 +1,28 @@
+Index: hostap-driver-0.3.7/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-08-03 17:05:53.000000000 +0100
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-08-03 17:07:59.000000000 +0100
+@@ -526,11 +526,13 @@
+ dev_list = link;
+ client_reg.dev_info = &dev_info;
+ client_reg.Attributes = INFO_IO_CLIENT;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,13))
+ client_reg.EventMask = CS_EVENT_CARD_INSERTION |
+ CS_EVENT_CARD_REMOVAL |
+ CS_EVENT_RESET_PHYSICAL | CS_EVENT_CARD_RESET |
+ CS_EVENT_PM_SUSPEND | CS_EVENT_PM_RESUME;
+ client_reg.event_handler = &prism2_event;
++#endif
+ client_reg.Version = 0x0210;
+ client_reg.event_callback_args.client_data = link;
+ ret = pcmcia_register_client(&link->handle, &client_reg);
+@@ -913,6 +915,9 @@
+ .name = "hostap_cs",
+ },
+ .attach = prism2_attach,
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++ .event = prism2_event,
++#endif
+ .detach = prism2_detach,
+ .owner = THIS_MODULE,
+ };
diff --git a/recipes/obsolete/hostap/hostap-modules/hostap-utsname.patch b/recipes/obsolete/hostap/hostap-modules/hostap-utsname.patch
new file mode 100644
index 0000000000..c29cc8d2c9
--- /dev/null
+++ b/recipes/obsolete/hostap/hostap-modules/hostap-utsname.patch
@@ -0,0 +1,77 @@
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap.c hostap-driver-0.3.7/driver/modules/hostap.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap.c 2005-07-25 09:14:01.995965088 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap.c 2005-07-25 09:13:22.301999488 +0000
+@@ -25,6 +25,7 @@
+ #include <linux/if_arp.h>
+ #include <linux/delay.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_ccmp.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_tkip.c 2005-07-25 09:13:22.302999336 +0000
+@@ -19,6 +19,7 @@
+ #include <linux/netdevice.h>
+ #include <linux/if_ether.h>
+ #include <linux/if_arp.h>
++#include <linux/utsname.h>
+ #include <asm/string.h>
+
+ #include "hostap_crypt.h"
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_crypt_wep.c 2005-07-25 09:14:01.996964936 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_crypt_wep.c 2005-07-25 09:13:22.302999336 +0000
+@@ -15,6 +15,7 @@
+ #include <linux/init.h>
+ #include <linux/slab.h>
+ #include <linux/random.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c hostap-driver-0.3.7/driver/modules/hostap_cs.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_cs.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_cs.c 2005-07-25 09:13:22.302999336 +0000
+@@ -12,6 +12,7 @@
+ #include <linux/timer.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c hostap-driver-0.3.7/driver/modules/hostap_pci.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_pci.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_pci.c 2005-07-25 09:13:22.303999184 +0000
+@@ -11,6 +11,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
+diff -r -U 3 hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c hostap-driver-0.3.7/driver/modules/hostap_plx.c
+--- hostap-driver-0.3.7.orig/driver/modules/hostap_plx.c 2005-07-25 09:14:01.997964784 +0000
++++ hostap-driver-0.3.7/driver/modules/hostap_plx.c 2005-07-25 09:13:22.303999184 +0000
+@@ -14,6 +14,7 @@
+ #include <linux/if.h>
+ #include <linux/skbuff.h>
+ #include <linux/netdevice.h>
++#include <linux/utsname.h>
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,5,44))
+ #include <linux/tqueue.h>
+ #else
diff --git a/recipes/obsolete/hostap/hostap-modules/hostap_cardid.patch b/recipes/obsolete/hostap/hostap-modules/hostap_cardid.patch
new file mode 100644
index 0000000000..05f716e22f
--- /dev/null
+++ b/recipes/obsolete/hostap/hostap-modules/hostap_cardid.patch
@@ -0,0 +1,70 @@
+Index: hostap-driver-0.3.9/driver/modules/hostap_cs.c
+===================================================================
+--- hostap-driver-0.3.9.orig/driver/modules/hostap_cs.c 2005-08-24 10:11:47.000000000 +0100
++++ hostap-driver-0.3.9/driver/modules/hostap_cs.c 2005-08-24 10:39:10.000000000 +0100
+@@ -908,6 +908,57 @@
+ return 0;
+ }
+
++#if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
++static struct pcmcia_device_id hostap_cs_ids[] = {
++ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7100),
++ PCMCIA_DEVICE_MANF_CARD(0x000b, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0x0101, 0x0777),
++ PCMCIA_DEVICE_MANF_CARD(0x0126, 0x8000),
++ PCMCIA_DEVICE_MANF_CARD(0x0138, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0156, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0250, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1612),
++ PCMCIA_DEVICE_MANF_CARD(0x0274, 0x1613),
++ PCMCIA_DEVICE_MANF_CARD(0x028a, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x02aa, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0x02d2, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x0001),
++ PCMCIA_DEVICE_MANF_CARD(0x50c2, 0x7300),
++ PCMCIA_DEVICE_MANF_CARD(0xc00f, 0x0000),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0002),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0005),
++ PCMCIA_DEVICE_MANF_CARD(0xd601, 0x0010),
++ PCMCIA_MFC_DEVICE_PROD_ID12(0, "SanDisk", "ConnectPlus",
++ 0x7a954bd9, 0x74be00c6),
++ PCMCIA_DEVICE_PROD_ID1234(
++ "Intersil", "PRISM 2_5 PCMCIA ADAPTER", "ISL37300P",
++ "Eval-RevA",
++ 0x4b801a17, 0x6345a0bf, 0xc9049a39, 0xc23adc0e),
++ PCMCIA_DEVICE_PROD_ID123(
++ "Addtron", "AWP-100 Wireless PCMCIA", "Version 01.02",
++ 0xe6ec52ce, 0x08649af2, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "D", "Link DWL-650 11Mbps WLAN Card", "Version 01.02",
++ 0x71b18589, 0xb6f1b0ab, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "Instant Wireless ", " Network PC CARD", "Version 01.02",
++ 0x11d901af, 0x6e9bd926, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID123(
++ "SMC", "SMC2632W", "Version 01.02",
++ 0xc4f8b18b, 0x474a1f2a, 0x4b74baa0),
++ PCMCIA_DEVICE_PROD_ID12("Compaq", "WL200_11Mbps_Wireless_PCI_Card",
++ 0x54f7c49c, 0x15a75e5b),
++ PCMCIA_DEVICE_PROD_ID12("INTERSIL", "HFA384x/IEEE",
++ 0x74c5e40d, 0xdb472a18),
++ PCMCIA_DEVICE_PROD_ID12("Linksys", "Wireless CompactFlash Card",
++ 0x0733cc81, 0x0c52f395),
++ PCMCIA_DEVICE_PROD_ID12(
++ "ZoomAir 11Mbps High", "Rate wireless Networking",
++ 0x273fe3db, 0x32a1eaee),
++ PCMCIA_DEVICE_NULL
++};
++MODULE_DEVICE_TABLE(pcmcia, hostap_cs_ids);
++#endif
+
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,5,67)
+ static struct pcmcia_driver hostap_driver = {
+@@ -917,6 +968,7 @@
+ .attach = prism2_attach,
+ #if (LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12))
+ .event = prism2_event,
++ .id_table = hostap_cs_ids,
+ #endif
+ .detach = prism2_detach,
+ .owner = THIS_MODULE,