aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-30 22:08:00 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-30 22:12:03 +0200
commit6981c76b60a082c79d33afc18d56b96a92395796 (patch)
tree0ca389da2ac4f691e2d0aa3aa8c0b45406f7079d /recipes/obsolete
parente29ef6f6bc44f6e161a13c89da3cccaa8727b5e8 (diff)
downloadopenembedded-6981c76b60a082c79d33afc18d56b96a92395796.tar.gz
mysql : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/mysql/files/gen_lex_hash.patch19
-rw-r--r--recipes/obsolete/mysql/mysql-5.1.40-have_atomic_pthread_t.patch37
2 files changed, 56 insertions, 0 deletions
diff --git a/recipes/obsolete/mysql/files/gen_lex_hash.patch b/recipes/obsolete/mysql/files/gen_lex_hash.patch
new file mode 100644
index 0000000000..c398d048dc
--- /dev/null
+++ b/recipes/obsolete/mysql/files/gen_lex_hash.patch
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- mysql-4.1.15/sql/Makefile.am~gen_lexhash
++++ mysql-4.1.15/sql/Makefile.am
+@@ -137,8 +137,10 @@
+ @echo "If it fails, re-run configure with --with-low-memory"
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
++GEN_LEX_HASH = ./gen_lex_hash$(EXEEXT)
++
+ lex_hash.h: gen_lex_hash$(EXEEXT)
+- ./gen_lex_hash$(EXEEXT) > $@
++ $(GEN_LEX_HASH) > $@
+
+ # For testing of udf_example.so; Works on platforms with gcc
+ # (This is not part of our build process but only provided as an example)
diff --git a/recipes/obsolete/mysql/mysql-5.1.40-have_atomic_pthread_t.patch b/recipes/obsolete/mysql/mysql-5.1.40-have_atomic_pthread_t.patch
new file mode 100644
index 0000000000..f6401790d4
--- /dev/null
+++ b/recipes/obsolete/mysql/mysql-5.1.40-have_atomic_pthread_t.patch
@@ -0,0 +1,37 @@
+diff -Naur mysql-5.1.40-old/storage/innodb_plugin/plug.in mysql-5.1.40-new/storage/innodb_plugin/plug.in
+--- mysql-5.1.40-old/storage/innodb_plugin/plug.in 2009-10-06 10:50:23.000000000 -0700
++++ mysql-5.1.40-new/storage/innodb_plugin/plug.in 2009-10-21 16:52:45.000000000 -0700
+@@ -63,8 +63,9 @@
+ ;;
+ esac
+ AC_SUBST(INNODB_DYNAMIC_CFLAGS)
+- AC_MSG_CHECKING(whether pthread_t can be used by GCC atomic builtins)
+- AC_TRY_RUN(
++ AC_CACHE_CHECK([whether pthread_t can be used by GCC atomic builtins],
++ [ac_cv_have_decl_HAVE_ATOMIC_PTHREAD_T],
++ [AC_TRY_RUN(
+ [
+ #include <pthread.h>
+ #include <string.h>
+@@ -84,14 +85,18 @@
+ }
+ ],
+ [
+- AC_DEFINE([HAVE_ATOMIC_PTHREAD_T], [1],
+- [pthread_t can be used by GCC atomic builtins])
+ AC_MSG_RESULT(yes)
++ ac_cv_have_decl_HAVE_ATOMIC_PTHREAD_T=yes
+ ],
+ [
+ AC_MSG_RESULT(no)
++ ac_cv_have_decl_HAVE_ATOMIC_PTHREAD_T=no
+ ]
+- )
++ )])
++ if test "x$ac_cv_have_decl_HAVE_ATOMIC_PTHREAD"= "xyes" ; then
++ AC_DEFINE([HAVE_ATOMIC_PTHREAD_T], [1],
++ [pthread_t can be used by GCC atomic builtins])
++ fi
+
+ # Try using solaris atomics on SunOS if GCC atomics are not available
+ AC_CHECK_DECLS(