aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-30 21:55:38 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-09-30 22:12:02 +0200
commit8baedf3a44e46f1a165a9c13cca3dfea7af8aa96 (patch)
tree78ff2ce6a44b499af9da0b1b71cfccbe763051bb /recipes/obsolete
parent70713b227a48e91429ebd17d281cfd7dc6eac61a (diff)
downloadopenembedded-8baedf3a44e46f1a165a9c13cca3dfea7af8aa96.tar.gz
monotone : moved unused files to obsolete dir
Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/monotone/files/configure.ac.patch36
-rw-r--r--recipes/obsolete/monotone/files/cryptopp-endianness.patch40
-rw-r--r--recipes/obsolete/monotone/files/txt2c-cross.patch15
3 files changed, 91 insertions, 0 deletions
diff --git a/recipes/obsolete/monotone/files/configure.ac.patch b/recipes/obsolete/monotone/files/configure.ac.patch
new file mode 100644
index 0000000000..2d3e75531a
--- /dev/null
+++ b/recipes/obsolete/monotone/files/configure.ac.patch
@@ -0,0 +1,36 @@
+--- monotone-0.21/configure.ac.orig 2005-07-17 19:23:29.580829434 -0700
++++ monotone-0.21/configure.ac 2005-07-17 19:28:50.237223287 -0700
+@@ -82,9 +82,14 @@
+ AC_DEFUN([BOOST_VERSION_CHECK],
+ [AC_CACHE_CHECK([boost version 1.32 or newer], ac_cv_version_boost,
+ [
+- AC_TRY_RUN(
++ AC_TRY_COMPILE(
+ [#include <boost/version.hpp>
+- int main() { return (BOOST_VERSION < 103200); }],
++ #if BOOST_VERSION < 103200
++ int main() { return (BOOST_VERSION < 103200); }
++ #else
++ #error boost version is ok
++ #endif
++ ],
+ ac_cv_version_boost=yes,
+ ac_cv_version_boost=no)
+ ])
+@@ -101,9 +106,14 @@
+ AC_DEFUN([BOOST_FIX_VERSION],
+ [AC_CACHE_CHECK([if boost requires extra flags to compile], ac_fix_boost,
+ [
+- AC_TRY_RUN(
++ AC_TRY_COMPILE(
+ [#include <boost/version.hpp>
+- int main() { return (BOOST_VERSION != 103200); }],
++ #if BOOST_VERSION != 103200
++ int main() { return (BOOST_VERSION != 103200); }
++ #else
++ #error boost version is not 1.32.0
++ #endif
++ ],
+ ac_fix_boost=yes,
+ ac_fix_boost=no)
+ ])
diff --git a/recipes/obsolete/monotone/files/cryptopp-endianness.patch b/recipes/obsolete/monotone/files/cryptopp-endianness.patch
new file mode 100644
index 0000000000..5d52b079bb
--- /dev/null
+++ b/recipes/obsolete/monotone/files/cryptopp-endianness.patch
@@ -0,0 +1,40 @@
+--- monotone-0.20/.pc/cryptopp-endianness.patch/cryptopp/config.h 2005-07-05 22:56:31.000000000 -0700
++++ monotone-0.20/cryptopp/config.h 2005-07-12 12:01:02.626693397 -0700
+@@ -5,15 +5,28 @@
+
+ // ***************** Important Settings ********************
+
+-// define this if running on a big-endian CPU
+-#if !defined(IS_LITTLE_ENDIAN) && (defined(__BIG_ENDIAN__) || defined(__sparc) || defined(__sparc__) || defined(__hppa__) || defined(__mips__) || (defined(__MWERKS__) && !defined(__INTEL__)))
+-# define IS_BIG_ENDIAN
+-#endif
+-
+-// define this if running on a little-endian CPU
+-// big endian will be assumed if IS_LITTLE_ENDIAN is not defined
+-#ifndef IS_BIG_ENDIAN
+-# define IS_LITTLE_ENDIAN
++// this is GCC specific, but it is safe - the original version
++// of this file defaulted to little endian without warning...
++// The code will error out if an attempt is made to define
++// IS_LITTLE_ENDIAN or IS_BIG_ENDIAN elsewhere
++#ifndef __BYTE_ORDER
++# include <endian.h>
++# ifndef __BYTE_ORDER
++# error cryptopp needs the correct byte order from the compiler
++# endif
++#endif
++#if defined(IS_LITTLE_ENDIAN) || defined(IS_BIG_ENDIAN)
++ // It doesn't work to define this on the command line, at least
++ // with the original version
++# error cryptopp - unexpected endianness definition
++#endif
++
++#if defined(__LITTLE_ENDIAN) && __BYTE_ORDER == __LITTLE_ENDIAN
++# define IS_LITTLE_ENDIAN
++#elif defined(__BIG_ENDIAN) && __BYTE_ORDER == __BIG_ENDIAN
++# define IS_BIG_ENDIAN
++#else
++# error cryptopp - unknown endianness
+ #endif
+
+ // define this if you want to disable all OS-dependent features,
diff --git a/recipes/obsolete/monotone/files/txt2c-cross.patch b/recipes/obsolete/monotone/files/txt2c-cross.patch
new file mode 100644
index 0000000000..a50b8135fc
--- /dev/null
+++ b/recipes/obsolete/monotone/files/txt2c-cross.patch
@@ -0,0 +1,15 @@
+# txt2c runs (only) on the build system. This is a fairly horrible
+# hack to make it compile with the build system compiler, not the
+# target compiler.
+
+--- monotone-0.19/Makefile.am.orig 2005-07-04 23:39:44.420722558 -0700
++++ monotone-0.19/Makefile.am 2005-07-04 23:36:50.267121331 -0700
+@@ -356,7 +356,7 @@
+ CLEANFILES = $(BUILT_SOURCES_CLEAN) $(EPS_FIGURES)
+
+ txt2c: txt2c.cc Makefile
+- $(CXX) -Wall -o $@ $<
++ $(BUILD_CXX) -Wall -o $@ $<
+ chmod 0755 $@$(EXEEXT)
+
+ apidocs: