aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2011-04-17 02:59:01 +0200
committerAndrea Adami <andrea.adami@gmail.com>2011-04-17 02:59:01 +0200
commit09c610dc6de5f94a4ce8a572045f7dcd8f18e710 (patch)
tree76bc9165dd91d311adb59bc27f692c6e0a8bbffa /recipes/obsolete
parent0ecbd433895b1559e0c5898e280e6fa7ccdc4c3b (diff)
downloadopenembedded-09c610dc6de5f94a4ce8a572045f7dcd8f18e710.tar.gz
mtd-utils: archive obsolete old versions
Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/mtd/mtd-utils-native.inc5
-rw-r--r--recipes/obsolete/mtd/mtd-utils-native_1.1.0.bb4
-rw-r--r--recipes/obsolete/mtd/mtd-utils-native_1.2.0+git.bb3
-rw-r--r--recipes/obsolete/mtd/mtd-utils-native_1.3.1.bb3
-rw-r--r--recipes/obsolete/mtd/mtd-utils-native_1.4.1.bb3
-rw-r--r--recipes/obsolete/mtd/mtd-utils-tests_1.2.0+git.bb59
-rw-r--r--recipes/obsolete/mtd/mtd-utils.inc87
-rw-r--r--recipes/obsolete/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git.patch106
-rw-r--r--recipes/obsolete/mtd/mtd-utils/fix-ignoreerrors-git.patch26
-rw-r--r--recipes/obsolete/mtd/mtd-utils/lzo_1x-git.patch13
-rw-r--r--recipes/obsolete/mtd/mtd-utils/lzo_1x.patch26
-rw-r--r--recipes/obsolete/mtd/mtd-utils_1.1.0.bb12
-rw-r--r--recipes/obsolete/mtd/mtd-utils_1.2.0+git.bb27
-rw-r--r--recipes/obsolete/mtd/mtd-utils_1.3.1.bb27
14 files changed, 401 insertions, 0 deletions
diff --git a/recipes/obsolete/mtd/mtd-utils-native.inc b/recipes/obsolete/mtd/mtd-utils-native.inc
new file mode 100644
index 0000000000..b9dcc5a0bb
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils-native.inc
@@ -0,0 +1,5 @@
+inherit native
+DEPENDS = "zlib-native"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/mtd-utils"
+
+NATIVE_INSTALL_WORKS = "1"
diff --git a/recipes/obsolete/mtd/mtd-utils-native_1.1.0.bb b/recipes/obsolete/mtd/mtd-utils-native_1.1.0.bb
new file mode 100644
index 0000000000..edaeff0c5e
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils-native_1.1.0.bb
@@ -0,0 +1,4 @@
+require mtd-utils_${PV}.bb
+require mtd-utils-native.inc
+
+DEPENDS += "lzo-native"
diff --git a/recipes/obsolete/mtd/mtd-utils-native_1.2.0+git.bb b/recipes/obsolete/mtd/mtd-utils-native_1.2.0+git.bb
new file mode 100644
index 0000000000..472d7432ea
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils-native_1.2.0+git.bb
@@ -0,0 +1,3 @@
+require mtd-utils_${PV}.bb
+require mtd-utils-native.inc
+DEPENDS += "util-linux-ng-native lzo-native"
diff --git a/recipes/obsolete/mtd/mtd-utils-native_1.3.1.bb b/recipes/obsolete/mtd/mtd-utils-native_1.3.1.bb
new file mode 100644
index 0000000000..472d7432ea
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils-native_1.3.1.bb
@@ -0,0 +1,3 @@
+require mtd-utils_${PV}.bb
+require mtd-utils-native.inc
+DEPENDS += "util-linux-ng-native lzo-native"
diff --git a/recipes/obsolete/mtd/mtd-utils-native_1.4.1.bb b/recipes/obsolete/mtd/mtd-utils-native_1.4.1.bb
new file mode 100644
index 0000000000..4208a4ba72
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils-native_1.4.1.bb
@@ -0,0 +1,3 @@
+require mtd-utils_${PV}.bb
+require mtd-utils-native.inc
+DEPENDS += "util-linux-ng-native lzo2-native"
diff --git a/recipes/obsolete/mtd/mtd-utils-tests_1.2.0+git.bb b/recipes/obsolete/mtd/mtd-utils-tests_1.2.0+git.bb
new file mode 100644
index 0000000000..fa90696e21
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils-tests_1.2.0+git.bb
@@ -0,0 +1,59 @@
+require mtd-utils_1.2.0+git.bb
+
+# this can probably be integrated into the main mtd-utils package
+# but I did not want to risk breakage -- but would be glad to
+# integrate them if that is best -- cbrake
+
+SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG}"
+
+PR = "r1"
+
+S = "${WORKDIR}/git/tests/fs-tests"
+
+FILES_${PN} = "${datadir}/mtd-utils"
+
+do_compile () {
+ make || die "Make failed"
+}
+
+do_stage () {
+}
+
+PACKAGE_STRIP = "no"
+
+mtd_utils_tests = " \
+ help_all.sh \
+ run_all.sh \
+ integrity/integck \
+ simple/ftrunc \
+ simple/test_1 \
+ simple/test_2 \
+ stress/stress00.sh \
+ stress/stress01.sh \
+ stress/atoms/fwrite00 \
+ stress/atoms/gcd_hupper \
+ stress/atoms/pdfrun \
+ stress/atoms/rmdir00 \
+ stress/atoms/rndrm00 \
+ stress/atoms/rndrm99 \
+ stress/atoms/rndwrite00 \
+ stress/atoms/stress_1 \
+ stress/atoms/stress_2 \
+ stress/atoms/stress_3 \
+ utils/free_space \
+ utils/fstest_monitor \
+ "
+
+do_install () {
+ install -d ${D}${datadir}/mtd-utils/tests
+ install -d ${D}${datadir}/mtd-utils/tests/integrity
+ install -d ${D}${datadir}/mtd-utils/tests/simple
+ install -d ${D}${datadir}/mtd-utils/tests/stress
+ install -d ${D}${datadir}/mtd-utils/tests/stress/atoms
+ install -d ${D}${datadir}/mtd-utils/tests/utils
+ for app in ${mtd_utils_tests}; do
+ install -m 0755 $app ${D}${datadir}/mtd-utils/tests/$app
+ done
+}
+
+
diff --git a/recipes/obsolete/mtd/mtd-utils.inc b/recipes/obsolete/mtd/mtd-utils.inc
new file mode 100644
index 0000000000..74c4cf053e
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils.inc
@@ -0,0 +1,87 @@
+DESCRIPTION = "Tools for managing memory technology devices."
+SECTION = "base"
+DEPENDS = "zlib"
+HOMEPAGE = "http://www.linux-mtd.infradead.org/"
+LICENSE = "GPLv2"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.infradead.org/pub/mtd-utils/mtd-utils-${PV}.tar.bz2"
+
+S = "${WORKDIR}/mtd-utils-${PV}"
+
+EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR'"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -d ${D}${includedir}/mtd
+ for binary in ${mtd_utils}; do
+ if [ -f $binary ]; then
+ install -m 0755 $binary ${D}${bindir}
+ fi
+ done
+ for f in ${S}/include/mtd/*.h; do
+ install -m 0644 $f ${D}${includedir}/mtd
+ done
+}
+
+mtd_utils = " docfdisk \
+ doc_loadbios \
+ flashcp \
+ flash_erase \
+ flash_eraseall \
+ flash_info \
+ flash_lock \
+ flash_otp_dump \
+ flash_otp_info \
+ flash_unlock \
+ ftl_check \
+ ftl_format \
+ jffs2dump \
+ mkfs.jffs2 \
+ mtd_debug \
+ nanddump \
+ nandtest \
+ nandwrite \
+ nftldump \
+ nftl_format \
+ recv_image \
+ rfddump \
+ rfdformat \
+ serve_image \
+ sumtool \
+ mkfs.ubifs/mkfs.ubifs \
+ ubi-utils/bin2nand \
+ ubi-utils/mkbootenv \
+ ubi-utils/nand2bin \
+ ubi-utils/pddcustomize \
+ ubi-utils/pfi2bin \
+ ubi-utils/pfiflash \
+ ubi-utils/ubigen \
+ ubi-utils/ubimirror \
+ ubi-utils/unubi \
+ ubi-utils/new-utils/ubiattach \
+ ubi-utils/new-utils/ubicrc32 \
+ ubi-utils/new-utils/ubidetach \
+ ubi-utils/new-utils/ubiformat \
+ ubi-utils/new-utils/ubimkvol \
+ ubi-utils/new-utils/ubinfo \
+ ubi-utils/new-utils/ubinize \
+ ubi-utils/new-utils/ubirmvol \
+ ubi-utils/new-utils/ubirsvol \
+ ubi-utils/new-utils/ubiupdatevol \
+ ubi-utils/ubiattach \
+ ubi-utils/ubicrc32 \
+ ubi-utils/ubidetach \
+ ubi-utils/ubiformat \
+ ubi-utils/ubimkvol \
+ ubi-utils/ubinfo \
+ ubi-utils/ubinize \
+ ubi-utils/ubirmvol \
+ ubi-utils/ubirsvol \
+ ubi-utils/ubiupdatevol \
+"
+
+PACKAGES =+ "mkfs-jffs mkfs-jffs2 mkfs-ubifs"
+FILES_mkfs-jffs = "${bindir}/mkfs.jffs"
+FILES_mkfs-jffs2 = "${bindir}/mkfs.jffs2"
+FILES_mkfs-ubifs = "${bindir}/mkfs.ubifs"
diff --git a/recipes/obsolete/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git.patch b/recipes/obsolete/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git.patch
new file mode 100644
index 0000000000..5504a11e8a
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils/add-exclusion-to-mkfs-jffs2-git.patch
@@ -0,0 +1,106 @@
+---
+ mkfs.jffs2.c | 45 ++++++++++++++++++++++++++++++++++++++++++---
+ 1 file changed, 42 insertions(+), 3 deletions(-)
+
+Index: git/mkfs.jffs2.c
+===================================================================
+--- git.orig/mkfs.jffs2.c 2007-01-23 15:42:34.000000000 +0000
++++ git/mkfs.jffs2.c 2007-01-23 15:46:08.000000000 +0000
+@@ -97,7 +97,12 @@ struct filesystem_entry {
+ struct filesystem_entry *files; /* Only relevant to directories */
+ };
+
+-
++struct ignorepath_entry {
++ struct ignorepath_entry* next; /* Points to the next ignorepath element */
++ char name[PATH_MAX]; /* Name of the entry */
++};
++
++static struct ignorepath_entry* ignorepath = 0;
+ static int out_fd = -1;
+ static int in_fd = -1;
+ static char default_rootdir[] = ".";
+@@ -372,7 +377,7 @@ static struct filesystem_entry *recursiv
+ char *hpath, *tpath;
+ struct dirent *dp, **namelist;
+ struct filesystem_entry *entry;
+-
++ struct ignorepath_entry* element = ignorepath;
+
+ if (lstat(hostpath, &sb)) {
+ perror_msg_and_die("%s", hostpath);
+@@ -381,6 +386,15 @@ static struct filesystem_entry *recursiv
+ entry = add_host_filesystem_entry(targetpath, hostpath,
+ sb.st_uid, sb.st_gid, sb.st_mode, 0, parent);
+
++ while ( element ) {
++ if ( strcmp( element->name, targetpath ) == 0 ) {
++ printf( "Note: ignoring directories below '%s'\n", targetpath );
++ return entry;
++ break;
++ }
++ element = element->next;
++ }
++
+ n = scandir(hostpath, &namelist, 0, alphasort);
+ if (n < 0) {
+ perror_msg_and_die("opening directory %s", hostpath);
+@@ -1405,6 +1419,7 @@ static struct option long_options[] = {
+ {"root", 1, NULL, 'r'},
+ {"pagesize", 1, NULL, 's'},
+ {"eraseblock", 1, NULL, 'e'},
++ {"ignore", 1, NULL, 'I'},
+ {"output", 1, NULL, 'o'},
+ {"help", 0, NULL, 'h'},
+ {"verbose", 0, NULL, 'v'},
+@@ -1452,6 +1467,7 @@ static char *helptext =
+ " -L, --list-compressors Show the list of the avaiable compressors\n"
+ " -t, --test-compression Call decompress and compare with the original (for test)\n"
+ " -n, --no-cleanmarkers Don't add a cleanmarker to every eraseblock\n"
++" -I, --ignore=PATH Ignore sub directory and file tree below PATH when recursing over the file system\n"
+ " -o, --output=FILE Output to FILE (default: stdout)\n"
+ " -l, --little-endian Create a little-endian filesystem\n"
+ " -b, --big-endian Create a big-endian filesystem\n"
+@@ -1617,11 +1633,12 @@ int main(int argc, char **argv)
+ struct filesystem_entry *root;
+ char *compr_name = NULL;
+ int compr_prior = -1;
++ struct ignorepath_entry* element = ignorepath;
+
+ jffs2_compressors_init();
+
+ while ((opt = getopt_long(argc, argv,
+- "D:d:r:s:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
++ "D:d:r:s:I:o:qUPfh?vVe:lbp::nc:m:x:X:Lty:i:", long_options, &c)) >= 0)
+ {
+ switch (opt) {
+ case 'D':
+@@ -1644,6 +1661,28 @@ int main(int argc, char **argv)
+ page_size = strtol(optarg, NULL, 0);
+ break;
+
++ case 'I':
++ printf( "Note: Adding '%s' to ignore Path\n", optarg );
++ element = ignorepath;
++ if ( !ignorepath ) {
++ ignorepath = xmalloc( sizeof( struct ignorepath_entry ) );
++ ignorepath->next = 0;
++ strcpy( &ignorepath->name[0], optarg );
++ } else {
++ while ( element->next ) element = element->next;
++ element->next = xmalloc( sizeof( struct ignorepath_entry ) );
++ element->next->next = 0;
++ strcpy( &element->next->name[0], optarg );
++ }
++ printf( "--------- Dumping ignore path list ----------------\n" );
++ element = ignorepath;
++ while ( element ) {
++ printf( " * '%s'\n", &element->name[0] );
++ element = element->next;
++ }
++ printf( "---------------------------------------------------\n" );
++ break;
++
+ case 'o':
+ if (out_fd != -1) {
+ error_msg_and_die("output filename specified more than once");
diff --git a/recipes/obsolete/mtd/mtd-utils/fix-ignoreerrors-git.patch b/recipes/obsolete/mtd/mtd-utils/fix-ignoreerrors-git.patch
new file mode 100644
index 0000000000..bec60a18c1
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils/fix-ignoreerrors-git.patch
@@ -0,0 +1,26 @@
+---
+ nanddump.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+Index: git/nanddump.c
+===================================================================
+--- git.orig/nanddump.c 2007-01-23 15:42:34.000000000 +0000
++++ git/nanddump.c 2007-01-23 15:47:57.000000000 +0000
+@@ -281,7 +281,7 @@ int main(int argc, char **argv)
+ }
+ }
+
+- if (badblock) {
++ if (badblock && !ignoreerrors) {
+ if (omitbad)
+ continue;
+ memset (readbuf, 0xff, bs);
+@@ -335,7 +335,7 @@ int main(int argc, char **argv)
+ if (omitoob)
+ continue;
+
+- if (badblock) {
++ if (badblock && !ignoreerrors) {
+ memset (readbuf, 0xff, meminfo.oobsize);
+ } else {
+ /* Read OOB data and exit on failure */
diff --git a/recipes/obsolete/mtd/mtd-utils/lzo_1x-git.patch b/recipes/obsolete/mtd/mtd-utils/lzo_1x-git.patch
new file mode 100644
index 0000000000..e5306875da
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils/lzo_1x-git.patch
@@ -0,0 +1,13 @@
+Index: git/compr_lzo.c
+===================================================================
+--- git.orig/compr_lzo.c
++++ git/compr_lzo.c
+@@ -26,7 +26,7 @@
+ #include <string.h>
+ #include <asm/types.h>
+ #include <linux/jffs2.h>
+-#include <lzo/lzo1x.h>
++#include <lzo1x.h>
+ #include "compr.h"
+
+ extern int page_size;
diff --git a/recipes/obsolete/mtd/mtd-utils/lzo_1x.patch b/recipes/obsolete/mtd/mtd-utils/lzo_1x.patch
new file mode 100644
index 0000000000..b882d9f504
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils/lzo_1x.patch
@@ -0,0 +1,26 @@
+Index: git/Makefile
+===================================================================
+--- git.orig/Makefile
++++ git/Makefile
+@@ -60,7 +60,7 @@ $(BUILDDIR)/mkfs.jffs2: $(BUILDDIR)/crc3
+ $(BUILDDIR)/compr_zlib.o \
+ $(BUILDDIR)/compr_lzo.o \
+ $(BUILDDIR)/compr.o
+- $(CC) $(LDFLAGS) -o $@ $^ -lz -llzo2
++ $(CC) $(LDFLAGS) -o $@ $^ -lz -llzo
+
+ $(BUILDDIR)/flash_eraseall: $(BUILDDIR)/crc32.o $(BUILDDIR)/flash_eraseall.o
+ $(CC) $(LDFLAGS) -o $@ $^
+Index: git/compr_lzo.c
+===================================================================
+--- git.orig/compr_lzo.c
++++ git/compr_lzo.c
+@@ -26,7 +26,7 @@
+ #include <string.h>
+ #include <asm/types.h>
+ #include <linux/jffs2.h>
+-#include <lzo/lzo1x.h>
++#include <lzo1x.h>
+ #include "compr.h"
+
+ extern int page_size;
diff --git a/recipes/obsolete/mtd/mtd-utils_1.1.0.bb b/recipes/obsolete/mtd/mtd-utils_1.1.0.bb
new file mode 100644
index 0000000000..87f3615fbc
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils_1.1.0.bb
@@ -0,0 +1,12 @@
+require mtd-utils.inc
+
+PR = "r4"
+
+DEPENDS += "lzo"
+
+SRC_URI += "file://add-exclusion-to-mkfs-jffs2-git.patch \
+ file://fix-ignoreerrors-git.patch \
+ file://lzo_1x.patch"
+
+SRC_URI[md5sum] = "05aa9b015625aa20afba728fb7ee47b3"
+SRC_URI[sha256sum] = "a74b0cc7ec668418389d9f56f85ca8a4619b8674a2d90f5e51bfb8ae9a0667de"
diff --git a/recipes/obsolete/mtd/mtd-utils_1.2.0+git.bb b/recipes/obsolete/mtd/mtd-utils_1.2.0+git.bb
new file mode 100644
index 0000000000..04cf2f218d
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils_1.2.0+git.bb
@@ -0,0 +1,27 @@
+require mtd-utils.inc
+
+DEPENDS += "util-linux-ng lzo"
+PR = "r4"
+
+ARM_INSTRUCTION_SET = "arm"
+
+# This is the default package, thus we lock to a specific git version so
+# upstream changes will not break builds.
+
+TAG = "ea429635388f7bb53f62c41ec3d5ccf5fa207370"
+
+SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG} \
+ file://add-exclusion-to-mkfs-jffs2-git-2.patch \
+ file://fix-ignoreerrors-git.patch \
+ file://lzo_1x-git.patch"
+
+S = "${WORKDIR}/git/"
+
+do_configure_prepend() {
+ for i in $(find . -name "Makefile") ; do
+ sed -i -e s:lzo2:lzo:g $i
+ done
+ if [ -e mkfs.ubifs/compr.c ]; then
+ sed -i -e s:lzo/::g mkfs.ubifs/compr.c
+ fi
+}
diff --git a/recipes/obsolete/mtd/mtd-utils_1.3.1.bb b/recipes/obsolete/mtd/mtd-utils_1.3.1.bb
new file mode 100644
index 0000000000..7b9d624250
--- /dev/null
+++ b/recipes/obsolete/mtd/mtd-utils_1.3.1.bb
@@ -0,0 +1,27 @@
+require mtd-utils.inc
+
+DEPENDS += "util-linux-ng lzo"
+
+PARALLEL_MAKE = ""
+ARM_INSTRUCTION_SET = "arm"
+
+# This is the default package, thus we lock to a specific git version so
+# upstream changes will not break builds.
+
+TAG = "v${PV}"
+
+SRC_URI = "git://git.infradead.org/mtd-utils.git;protocol=git;tag=${TAG} \
+ file://add-exclusion-to-mkfs-jffs2-git-2.patch \
+ file://fix-ignoreerrors-git.patch \
+ file://lzo_1x-git.patch"
+
+S = "${WORKDIR}/git/"
+
+do_configure_prepend() {
+ for i in $(find . -name "Makefile") ; do
+ sed -i -e s:lzo2:lzo:g $i
+ done
+ if [ -e mkfs.ubifs/compr.c ]; then
+ sed -i -e s:lzo/::g mkfs.ubifs/compr.c
+ fi
+}