aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 18:43:18 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2011-01-29 19:02:25 +0100
commita209e3adf6715c847441d1f7bb4ba8836b395774 (patch)
tree67324f99b3d88128f13673d63e8d95b59af5f7f4 /recipes/obsolete
parentf39c8ac813578e60af02a7492414f0fbc3b26b3c (diff)
downloadopenembedded-a209e3adf6715c847441d1f7bb4ba8836b395774.tar.gz
esmart,eflpp,entrance: move to obsolete
* esmart still depends on eina-0 instead of eina-1, so it's broken for long and nobody complained * eflpp and entrance depends on it so the same Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/e17/entrance/Sessions/Enlightenment3
-rw-r--r--recipes/obsolete/e17/entrance/Sessions/Failsafe3
-rw-r--r--recipes/obsolete/e17/entrance/allow-missing-xsession.patch19
-rw-r--r--recipes/obsolete/e17/entrance/config-db.patch118
-rw-r--r--recipes/obsolete/e17/entrance/fix-auth-mode.patch13
-rw-r--r--recipes/obsolete/e17/entrance/rebased_config-db.patch116
-rw-r--r--recipes/obsolete/e17/entrance/run-Xinit.patch17
-rw-r--r--recipes/obsolete/e17/entrance/use-bash.patch57
-rw-r--r--recipes/obsolete/e17/entrance_0.9.0.010.bb43
-rw-r--r--recipes/obsolete/efl1/eflpp_svn.bb15
-rw-r--r--recipes/obsolete/efl1/esmart_svn.bb30
11 files changed, 434 insertions, 0 deletions
diff --git a/recipes/obsolete/e17/entrance/Sessions/Enlightenment b/recipes/obsolete/e17/entrance/Sessions/Enlightenment
new file mode 100644
index 0000000000..61498c2c6c
--- /dev/null
+++ b/recipes/obsolete/e17/entrance/Sessions/Enlightenment
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+enlightenment_start
diff --git a/recipes/obsolete/e17/entrance/Sessions/Failsafe b/recipes/obsolete/e17/entrance/Sessions/Failsafe
new file mode 100644
index 0000000000..cf4fcced12
--- /dev/null
+++ b/recipes/obsolete/e17/entrance/Sessions/Failsafe
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+rxvt \ No newline at end of file
diff --git a/recipes/obsolete/e17/entrance/allow-missing-xsession.patch b/recipes/obsolete/e17/entrance/allow-missing-xsession.patch
new file mode 100644
index 0000000000..e0ebe6e0e9
--- /dev/null
+++ b/recipes/obsolete/e17/entrance/allow-missing-xsession.patch
@@ -0,0 +1,19 @@
+Index: entrance/configure.ac
+===================================================================
+--- entrance.orig/configure.ac 2009-02-17 10:59:20.000000000 +0000
++++ entrance/configure.ac 2009-02-17 13:09:51.000000000 +0000
+@@ -198,10 +198,10 @@
+ fi
+ ]
+ )
+-if test ! -x "$xsession" ; then
+- AC_MSG_WARN([** $xsession does not exist or is not executable **])
+- AC_MSG_WARN([** Please consider overriding with --with-xsession **])
+-fi
++#if test ! -x "$xsession" ; then
++# AC_MSG_WARN([** $xsession does not exist or is not executable **])
++# AC_MSG_WARN([** Please consider overriding with --with-xsession **])
++#fi
+
+ AC_DEFINE_UNQUOTED(ENTRANCE_XSESSION, "$xsession", [Xsession script])
+ AC_SUBST(xsession)
diff --git a/recipes/obsolete/e17/entrance/config-db.patch b/recipes/obsolete/e17/entrance/config-db.patch
new file mode 100644
index 0000000000..89e18ccff4
--- /dev/null
+++ b/recipes/obsolete/e17/entrance/config-db.patch
@@ -0,0 +1,118 @@
+Index: entrance/data/config/build_config.sh.in
+===================================================================
+--- entrance.orig/data/config/build_config.sh.in 2009-02-17 10:59:01.000000000 +0000
++++ entrance/data/config/build_config.sh.in 2009-02-17 13:45:06.000000000 +0000
+@@ -1,45 +1,45 @@
+ #!/bin/sh -e
+
+-usage() {
+- cat <<-EOF
+- Usage: $0 [options]
+-
+- Options:
+- -d, --dir Session directory to scan
+- -c, --file Config file (default: $DB)
+- -h, --help This help output :p
+- EOF
+-
+- if [ "$1" = "1" ] ; then
+- echo ""
+- echo "ERROR: $2"
+- fi
+-
+- exit $1
+-}
+-
+-SESSION_DIR=""
++#usage() {
++# cat <<-EOF
++# Usage: $0 [options]
++#
++# Options:
++# -d, --dir Session directory to scan
++# -c, --file Config file (default: $DB)
++# -h, --help This help output :p
++# EOF
++#
++# if [ "$1" = "1" ] ; then
++# echo ""
++# echo "ERROR: $2"
++# fi
++#
++# exit $1
++#}
++#
++#SESSION_DIR=""
+ DB="./entrance_config.cfg"
+-
+-while [ -n "$1" ] ; do
+- case $1 in
+- -d) shift; SESSION_DIR=$1;;
+- -c) shift; DB=$1;;
+- -h) usage 0;;
+- *) usage 1 "Unknown option: $1";;
+- esac
+- shift
+-done
+-
+-if [ -z "$DB" ] || [ -d "$DB" ] ; then
+- usage 1 "Invalid DB argument"
+-fi
+-
+-FROM=$SESSION_DIR
+-if [ -z "$FROM" ] ; then
+- FROM="defaults"
+-fi
+-echo "Generating config file '$DB' from '$FROM' ..."
++#
++#while [ -n "$1" ] ; do
++# case $1 in
++# -d) shift; SESSION_DIR=$1;;
++# -c) shift; DB=$1;;
++# -h) usage 0;;
++# *) usage 1 "Unknown option: $1";;
++# esac
++# shift
++#done
++#
++#if [ -z "$DB" ] || [ -d "$DB" ] ; then
++# usage 1 "Invalid DB argument"
++#fi
++#
++#FROM=$SESSION_DIR
++#if [ -z "$FROM" ] ; then
++# FROM="defaults"
++#fi
++echo "Generating config file '$DB' ..."
+
+ rm -f $DB || exit 1
+
+@@ -59,10 +59,10 @@
+ #ecore_config -c $DB -k /entrance/fonts/0/-s -s "/usr/share/fonts/truetype/"
+ #ecore_config -c $DB -k /entrance/fonts/1/-s -s "/usr/X11R6/lib/X11/fonts/Truetype/"
+ ecore_config -c $DB -k /entrance/greeting/before -s "Welcome to"
+-ecore_config -c $DB -k /entrance/greeting/after -s ""
++ecore_config -c $DB -k /entrance/greeting/after -s " e17/OE"
+
+ count=0
+-ecore_config -c $DB -k /entrance/session/0/session -s "default"
++ecore_config -c $DB -k /entrance/session/0/session -s "/etc/X11/Sessions/Enlightenment"
+ ecore_config -c $DB -k /entrance/session/0/title -s "Default"
+ ecore_config -c $DB -k /entrance/session/0/icon -s "default.png"
+ #if [ -z "$SESSION_DIR" ] ; then
+@@ -92,7 +92,7 @@
+ # done
+ #fi
+ count=`(expr $count + 1)`
+-ecore_config -c $DB -k /entrance/session/$count/session -s "failsafe"
++ecore_config -c $DB -k /entrance/session/$count/session -s "/etc/X11/Sessions/Enlightenment"
+ ecore_config -c $DB -k /entrance/session/$count/title -s "Failsafe"
+ ecore_config -c $DB -k /entrance/session/$count/icon -s "failsafe.png"
+ count=`(expr $count + 1)`
+@@ -107,5 +107,5 @@
+ ecore_config -c $DB -k /entrance/presel/mode -i 1
+
+ # for Entranced
+-ecore_config -c $DB -k /entranced/xserver -s "@xbin@/X -quiet -br -nolisten tcp@ENTRANCE_VT_ARG@"
++ecore_config -c $DB -k /entranced/xserver -s "/etc/X11/Xserver"
+ ecore_config -c $DB -k /entranced/attempts -i 5
diff --git a/recipes/obsolete/e17/entrance/fix-auth-mode.patch b/recipes/obsolete/e17/entrance/fix-auth-mode.patch
new file mode 100644
index 0000000000..46e530b256
--- /dev/null
+++ b/recipes/obsolete/e17/entrance/fix-auth-mode.patch
@@ -0,0 +1,13 @@
+Index: entrance-0.9.0.009/data/config/build_config.sh.in
+===================================================================
+--- entrance-0.9.0.009.orig/data/config/build_config.sh.in
++++ entrance-0.9.0.009/data/config/build_config.sh.in
+@@ -44,7 +44,7 @@
+ rm -f $DB || exit 1
+
+ # set auth to 1 for pam, 2 for shadow
+-ecore_config -c $DB -k /entrance/auth -i @auth_mode@
++ecore_config -c $DB -k /entrance/auth -i 0
+
+ # uncomment the below to enable experimental OpenGL hardware acceleration
+ #ecore_config -c $DB -k /entrance/engine -i 1
diff --git a/recipes/obsolete/e17/entrance/rebased_config-db.patch b/recipes/obsolete/e17/entrance/rebased_config-db.patch
new file mode 100644
index 0000000000..94f98ed123
--- /dev/null
+++ b/recipes/obsolete/e17/entrance/rebased_config-db.patch
@@ -0,0 +1,116 @@
+Index: entrance/data/config/build_config.sh.in
+===================================================================
+--- entrance.orig/data/config/build_config.sh.in
++++ entrance/data/config/build_config.sh.in
+@@ -1,45 +1,45 @@
+ #!/bin/sh -e
+
+-usage() {
+- cat <<-EOF
+- Usage: $0 [options]
+-
+- Options:
+- -d, --dir Session directory to scan
+- -c, --file Config file (default: $DB)
+- -h, --help This help output :p
+- EOF
+-
+- if [ "$1" = "1" ] ; then
+- echo ""
+- echo "ERROR: $2"
+- fi
+-
+- exit $1
+-}
+-
+-SESSION_DIR=""
++#usage() {
++# cat <<-EOF
++# Usage: $0 [options]
++#
++# Options:
++# -d, --dir Session directory to scan
++# -c, --file Config file (default: $DB)
++# -h, --help This help output :p
++# EOF
++#
++# if [ "$1" = "1" ] ; then
++# echo ""
++# echo "ERROR: $2"
++# fi
++#
++# exit $1
++#}
++#
++#SESSION_DIR=""
+ DB="./entrance_config.cfg"
+
+-while [ -n "$1" ] ; do
+- case $1 in
+- -d) shift; SESSION_DIR=$1;;
+- -c) shift; DB=$1;;
+- -h) usage 0;;
+- *) usage 1 "Unknown option: $1";;
+- esac
+- shift
+-done
+-
+-if [ -z "$DB" ] || [ -d "$DB" ] ; then
+- usage 1 "Invalid DB argument"
+-fi
+-
+-FROM=$SESSION_DIR
+-if [ -z "$FROM" ] ; then
+- FROM="defaults"
+-fi
+-echo "Generating config file '$DB' from '$FROM' ..."
++#while [ -n "$1" ] ; do
++# case $1 in
++# -d) shift; SESSION_DIR=$1;;
++# -c) shift; DB=$1;;
++# -h) usage 0;;
++# *) usage 1 "Unknown option: $1";;
++# esac
++# shift
++#done
++#
++#if [ -z "$DB" ] || [ -d "$DB" ] ; then
++# usage 1 "Invalid DB argument"
++#fi
++#
++#FROM=$SESSION_DIR
++#if [ -z "$FROM" ] ; then
++# FROM="defaults"
++#fi
++#echo "Generating config file '$DB' from '$FROM' ..."
+
+ rm -f $DB || exit 1
+
+@@ -60,9 +60,9 @@ ecore_config -c $DB -k /entrance/time_fo
+ #ecore_config -c $DB -k /entrance/fonts/1/-s -s "/usr/X11R6/lib/X11/fonts/Truetype/"
+ ecore_config -c $DB -k /entrance/greeting/use_default -i 1
+ ecore_config -c $DB -k /entrance/greeting/before -s "Welcome to"
+-ecore_config -c $DB -k /entrance/greeting/after -s ""
++ecore_config -c $DB -k /entrance/greeting/after -s " e17/OE"
+
+-ecore_config -c $DB -k /entrance/session/session -s "default"
++ecore_config -c $DB -k /entrance/session/session -s "/etc/X11/Sessions/Enlightenment"
+ ecore_config -c $DB -k /entrance/session/title -s "Default"
+ ecore_config -c $DB -k /entrance/session/icon -s "default.png"
+ #if [ -z "$SESSION_DIR" ] ; then
+@@ -92,7 +92,7 @@ ecore_config -c $DB -k /entrance/session
+ # done
+ #fi
+ count=0
+-ecore_config -c $DB -k /entrance/session/$count/session -s "failsafe"
++ecore_config -c $DB -k /entrance/session/$count/session -s "/etc/X11/Sessions/Enlightenment"
+ ecore_config -c $DB -k /entrance/session/$count/title -s "Failsafe"
+ ecore_config -c $DB -k /entrance/session/$count/icon -s "failsafe.png"
+ count=`(expr $count + 1)`
+@@ -107,5 +107,5 @@ ecore_config -c $DB -k /entrance/autolog
+ ecore_config -c $DB -k /entrance/presel/mode -i 0
+
+ # for Entranced
+-ecore_config -c $DB -k /entranced/xserver -s "@xbin@/X -quiet -br -nolisten tcp@ENTRANCE_VT_ARG@"
++ecore_config -c $DB -k /entranced/xserver -s "/etc/X11/Xserver"
+ ecore_config -c $DB -k /entranced/attempts -i 5
diff --git a/recipes/obsolete/e17/entrance/run-Xinit.patch b/recipes/obsolete/e17/entrance/run-Xinit.patch
new file mode 100644
index 0000000000..1d6c2307f7
--- /dev/null
+++ b/recipes/obsolete/e17/entrance/run-Xinit.patch
@@ -0,0 +1,17 @@
+--- entrance/src/daemon/entrance_wrapper.in.~1.1.~ 2003-01-31 13:57:06.000000000 -0800
++++ entrance/src/daemon/entrance_wrapper.in 2005-08-15 20:13:57.000000000 -0700
+@@ -5,8 +5,13 @@
+
+ test -f /etc/profile && . /etc/profile
+
++if [ -x /etc/X11/Xinit.d/99gpe-login ]; then
++ chmod -x /etc/X11/Xinit.d/99gpe-login
++fi
++
++/etc/X11/Xinit
++
+ exec @prefix@/bin/entrance "$@"
+
+ #fallback
+ exec entrance "$@"
+-
diff --git a/recipes/obsolete/e17/entrance/use-bash.patch b/recipes/obsolete/e17/entrance/use-bash.patch
new file mode 100644
index 0000000000..7dfab83711
--- /dev/null
+++ b/recipes/obsolete/e17/entrance/use-bash.patch
@@ -0,0 +1,57 @@
+Index: entrance-0.9.0.009/src/client/entrance_session.c
+===================================================================
+--- entrance-0.9.0.009.orig/src/client/entrance_session.c
++++ entrance-0.9.0.009/src/client/entrance_session.c
+@@ -854,7 +854,7 @@ _entrance_session_execute_in_shell(char
+ if (shell && (strlen(shell) > 0))
+ shell_cmd = shell;
+ else
+- shell_cmd = strdup("/bin/sh");
++ shell_cmd = strdup("/bin/bash");
+
+ if (session_name)
+ snprintf(buf, sizeof(buf), "%s %s", session_cmd, session_name);
+@@ -869,9 +869,9 @@ _entrance_session_execute_in_shell(char
+ if (res == -1)
+ /* TODO: should actually hit the user in the face with this message */
+ syslog(LOG_NOTICE,
+- "Neither '%s' or '/bin/sh' are working login shells for user '%s'. Your session may not function properly. ",
++ "Neither '%s' or '/bin/bash' are working login shells for user '%s'. Your session may not function properly. ",
+ shell, user);
+- shell_cmd = strdup("/bin/sh");
++ shell_cmd = strdup("/bin/bash");
+
+ res = execlp(shell_cmd, shell_cmd, "-c", buf, NULL);
+
+Index: entrance-0.9.0.009/src/client/main.c
+===================================================================
+--- entrance-0.9.0.009.orig/src/client/main.c
++++ entrance-0.9.0.009/src/client/main.c
+@@ -453,7 +453,7 @@ reboot_cb(void *data, Evas_Object * o, c
+ {
+ case 0:
+ if (execl
+- ("/bin/sh", "/bin/sh", "-c", "/sbin/shutdown -r now", NULL))
++ ("/bin/bash", "/bin/bash", "-c", "/sbin/shutdown -r now", NULL))
+ {
+ syslog(LOG_CRIT,
+ "Reboot failed: Unable to execute /sbin/shutdown");
+@@ -495,7 +495,7 @@ shutdown_cb(void *data, Evas_Object * o,
+ {
+ case 0:
+ if (execl
+- ("/bin/sh", "/bin/sh", "-c", "/sbin/shutdown -h now", NULL))
++ ("/bin/bash", "/bin/bash", "-c", "/sbin/shutdown -h now", NULL))
+ {
+ syslog(LOG_CRIT,
+ "Shutdown failed: Unable to execute /sbin/shutdown");
+Index: entrance-0.9.0.009/src/daemon/entrance_wrapper.in
+===================================================================
+--- entrance-0.9.0.009.orig/src/daemon/entrance_wrapper.in
++++ entrance-0.9.0.009/src/daemon/entrance_wrapper.in
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/bin/bash
+ # Wrapper script to set up login environment:
+ # Load up all the junk in /etc/profile first, and then
+ # pass control to entrance proper.
diff --git a/recipes/obsolete/e17/entrance_0.9.0.010.bb b/recipes/obsolete/e17/entrance_0.9.0.010.bb
new file mode 100644
index 0000000000..605f0bffd1
--- /dev/null
+++ b/recipes/obsolete/e17/entrance_0.9.0.010.bb
@@ -0,0 +1,43 @@
+DESCRIPTION = "Entrance is the Enlightenment login manager"
+LICENSE = "MIT BSD"
+# can also use pam and crypt
+DEPENDS = "evas ecore edje esmart bash keylaunch xserver-common login-manager"
+RDEPENDS_${PN} += "glibc-gconv-iso8859-1 entrance-themes"
+PR = "r3"
+
+# entrance and estickies were removed in 46590 for rewrite, move back to EFL_SRCREV when they're back
+SRCREV = "46589"
+
+inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
+
+SRC_URI += "\
+ file://rebased_config-db.patch \
+ file://allow-missing-xsession.patch \
+ file://run-Xinit.patch \
+ file://fix-auth-mode.patch \
+ file://use-bash.patch \
+ file://Sessions"
+
+S = "${WORKDIR}/entrance"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
+ --with-xsession=/etc/X11/Xsession \
+ --with-auth-mode=0"
+
+FILES_${PN}-dbg += "${libexecdir}/entrance/.debug/*"
+
+do_configure_prepend() {
+ autopoint
+}
+
+do_install_append() {
+ install -d ${D}/etc/X11/Xsession.d
+ install -d ${D}/etc/X11/Sessions
+
+ install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
+
+ install -d ${D}/etc/X11/login-managers/
+ mv ${D}/etc/init.d/entrance ${D}/etc/X11/login-managers/entrance
+}
diff --git a/recipes/obsolete/efl1/eflpp_svn.bb b/recipes/obsolete/efl1/eflpp_svn.bb
new file mode 100644
index 0000000000..aa5097f10b
--- /dev/null
+++ b/recipes/obsolete/efl1/eflpp_svn.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "EFLpp are C++ bindings to the EFL"
+AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
+HOMEPAGE = "http://www.vanille-media.de/site/index.php/projects/efl/"
+LICENSE = "LGPL"
+DEPENDS = "evas ecore edje emotion esmart libsigc++-2.0"
+SRCREV = "${EFL_SRCREV}"
+PV = "0.1.0+svnr${SRCPV}"
+PR = "r1"
+
+inherit efl
+SRCNAME = "cxx"
+SRC_URI = "${E_SVN}/trunk/BINDINGS;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
diff --git a/recipes/obsolete/efl1/esmart_svn.bb b/recipes/obsolete/efl1/esmart_svn.bb
new file mode 100644
index 0000000000..d326370a04
--- /dev/null
+++ b/recipes/obsolete/efl1/esmart_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "ESmart is a collection of smart Evas objects"
+LICENSE = "MIT BSD"
+DEPENDS = "evas ecore edje imlib2 libtool"
+PV = "0.9.0.050+svnr${SRCPV}"
+PR = "r2"
+SRCREV = "${EFL_SRCREV_1.0.0}"
+
+inherit efl
+SRC_URI = "${E_SVN}/OLD;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+PACKAGES =+ "${PN}-textentry \
+ ${PN}-thumb \
+ ${PN}-container \
+ ${PN}-container-plugins \
+ ${PN}-file-dialog \
+ ${PN}-draggies \
+ ${PN}-trans-x11"
+
+FILES_${PN}-dbg += "${libdir}/.debug/ ${libdir}/esmart/*/.debug/"
+FILES_${PN}-textentry = "${libdir}/libesmart_text_entry*.so*"
+FILES_${PN}-thumb = "${libdir}/libesmart_thumb*.so*"
+FILES_${PN}-container = "${libdir}/libesmart_container*"
+DEPENDS_${PN}-container += "${PN}-container-plugins"
+FILES_${PN}-container-plugins = "${libdir}/esmart/layout/*.so"
+FILES_${PN}-file-dialog = "${libdir}/libesmart_file_dialog*.so*"
+FILES_${PN}-draggies = "${libdir}/libesmart_draggies*.so*"
+FILES_${PN}-trans-x11 = "${libdir}/libesmart_trans_x11*.so*"