summaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-08 16:54:09 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-08 17:22:43 +0100
commit038f68a6b713e8e19780e06856af02da38485e9f (patch)
tree00598ca2b95d038d21d0687eafd4f06766587944 /recipes/obsolete
parent82380e0d0f73494ec2573921d14e94fb3b633d60 (diff)
downloadopenembedded-038f68a6b713e8e19780e06856af02da38485e9f.tar.gz
shr: move etk-themes to obsolete, remove etk-theme-neo from RSUGGESTS
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/shr/etk-theme-neo_git.bb13
-rw-r--r--recipes/obsolete/shr/etk-theme-shr_git.bb9
-rw-r--r--recipes/obsolete/shr/etk-theme.inc34
3 files changed, 56 insertions, 0 deletions
diff --git a/recipes/obsolete/shr/etk-theme-neo_git.bb b/recipes/obsolete/shr/etk-theme-neo_git.bb
new file mode 100644
index 0000000000..ab028b1228
--- /dev/null
+++ b/recipes/obsolete/shr/etk-theme-neo_git.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "nEo etk theme - a very fast, high contrast etk theme"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RSUGGESTS = "elementary-theme-neo e-wm-theme-illume-neo gtk-theme-neo gpe-theme-neo icon-theme-neo"
+LICENSE = "unknown"
+
+SRCREV = "1cc80e26a4558dfc2268b349d9a1f468e515bcfb"
+PV = "0.2-${EFL_SRCREV}+gitr${SRCREV}"
+PR = "r4"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+require etk-theme.inc
diff --git a/recipes/obsolete/shr/etk-theme-shr_git.bb b/recipes/obsolete/shr/etk-theme-shr_git.bb
new file mode 100644
index 0000000000..764955e48f
--- /dev/null
+++ b/recipes/obsolete/shr/etk-theme-shr_git.bb
@@ -0,0 +1,9 @@
+DESCRIPTION = "etk SHR theme"
+LICENSE = "MIT BSD"
+PV = "1.1.1-${EFL_SRCREV}+gitr${SRCREV}"
+PR = "r2"
+
+SRCREV = "1cc80e26a4558dfc2268b349d9a1f468e515bcfb"
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+require etk-theme.inc
diff --git a/recipes/obsolete/shr/etk-theme.inc b/recipes/obsolete/shr/etk-theme.inc
new file mode 100644
index 0000000000..6e8b33db27
--- /dev/null
+++ b/recipes/obsolete/shr/etk-theme.inc
@@ -0,0 +1,34 @@
+SECTION = "e/utils"
+DEPENDS = "edje-native"
+RDEPENDS = "etk"
+
+S = "${WORKDIR}/git/etk/${PN}/"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/default.edc -o ${S}/default.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/etk/themes.${PN}/
+ install -m 0644 ${S}/default.edj ${D}${datadir}/etk/themes.${PN}/
+}
+
+FILES_${PN} = "${datadir}/etk/themes.${PN}"
+
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "etk-theme"
+ALTERNATIVE_LINK = "${datadir}/etk/themes"
+ALTERNATIVE_PATH = "${datadir}/etk/themes.${PN}"
+ALTERNATIVE_PRIORITY ?= 1
+
+pkg_postinst() {
+ if [[ -e ${ALTERNATIVE_LINK} && ! -h ${ALTERNATIVE_LINK} ]] ; then
+ echo "warn: ${ALTERNATIVE_LINK} exists and it's not a link!"
+ echo "warn: It will be replaced with link managed by update-alternatives"
+ echo "warn: Moving ${ALTERNATIVE_LINK} to ${ALTERNATIVE_LINK}.old."
+ echo "warn: It should be empty but probably isn't!"
+ echo "warn: Check what's left there and remove it manually."
+ mv -f ${ALTERNATIVE_LINK} ${ALTERNATIVE_LINK}.old
+ fi
+}