summaryrefslogtreecommitdiffstats
path: root/recipes/obsolete
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-03-04 14:14:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-03-08 16:57:14 +0100
commit82380e0d0f73494ec2573921d14e94fb3b633d60 (patch)
treea210f2bdfabae0083a4e8fdcb4a4e3218531034c /recipes/obsolete
parentd2fc55223a375e47c203d777f8517c870ceb5e65 (diff)
downloadopenembedded-82380e0d0f73494ec2573921d14e94fb3b633d60.tar.gz
shr: move some obsolete SHR apps to obsolete directory
* with SRCREV moved from sane-srcrevs.inc to recipes Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/obsolete')
-rw-r--r--recipes/obsolete/shr/libframeworkd-phonegui-efl-theme-neo_git.bb27
-rw-r--r--recipes/obsolete/shr/libframeworkd-phonegui-efl-theme.inc22
-rw-r--r--recipes/obsolete/shr/libframeworkd-phonegui-efl2_git.bb19
-rw-r--r--recipes/obsolete/shr/libframeworkd-phonegui-efl_git.bb23
-rw-r--r--recipes/obsolete/shr/libframeworkd-phonegui_git.bb16
-rw-r--r--recipes/obsolete/shr/shr-contacts_git.bb14
-rw-r--r--recipes/obsolete/shr/shr-dialer_git.bb14
-rw-r--r--recipes/obsolete/shr/shr-messages_git.bb14
8 files changed, 149 insertions, 0 deletions
diff --git a/recipes/obsolete/shr/libframeworkd-phonegui-efl-theme-neo_git.bb b/recipes/obsolete/shr/libframeworkd-phonegui-efl-theme-neo_git.bb
new file mode 100644
index 0000000000..15dcc2f9ef
--- /dev/null
+++ b/recipes/obsolete/shr/libframeworkd-phonegui-efl-theme-neo_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "nEo libframeworkd-phonegui-efl - a very fast, high contrast etk theme"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RDEPENDS = "libframeworkd-phonegui-efl"
+RSUGGESTS = "elementary-theme-neo e-wm-theme-illume-neo gtk-theme-neo etk-theme-neo gpe-theme-neo icon-theme-neo"
+LICENSE = "unknown"
+
+SRCREV = "1cc80e26a4558dfc2268b349d9a1f468e515bcfb"
+PV = "0.2-${EFL_SRCREV}+gitr${SRCREV}"
+PR = "r3"
+
+require libframeworkd-phonegui-efl-theme.inc
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/libframeworkd-phonegui-efl/theme-neo"
+
+do_compile() {
+ for edc in call contacts dialer dialog elm-resizing-label incoming-message keypad messages sim-auth ussd ; do
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/${edc}/. -fd ${S}/${edc}. ${S}/${edc}/${edc}.edc -o ${S}/${edc}.edj
+ done
+}
+
+do_install() {
+ install -d ${D}${datadir}/libframeworkd-phonegui-efl.${PN}/
+ install -m 0644 ${S}/*.edj ${D}${datadir}/libframeworkd-phonegui-efl.${PN}/
+}
diff --git a/recipes/obsolete/shr/libframeworkd-phonegui-efl-theme.inc b/recipes/obsolete/shr/libframeworkd-phonegui-efl-theme.inc
new file mode 100644
index 0000000000..eab118f322
--- /dev/null
+++ b/recipes/obsolete/shr/libframeworkd-phonegui-efl-theme.inc
@@ -0,0 +1,22 @@
+SECTION = "e/utils"
+DEPENDS += "edje-native"
+
+FILES_${PN} += "${datadir}/libframeworkd-phonegui-efl.${PN}"
+
+inherit update-alternatives
+
+ALTERNATIVE_NAME = "libframeworkd-phonegui-efl-theme"
+ALTERNATIVE_LINK = "${datadir}/libframeworkd-phonegui-efl"
+ALTERNATIVE_PATH = "${datadir}/libframeworkd-phonegui-efl.${PN}"
+ALTERNATIVE_PRIORITY ?= 1
+
+pkg_postinst() {
+ if [[ -e ${ALTERNATIVE_LINK} && ! -h ${ALTERNATIVE_LINK} ]] ; then
+ echo "warn: ${ALTERNATIVE_LINK} exists and it's not a link!"
+ echo "warn: It will be replaced with link managed by update-alternatives"
+ echo "warn: Moving ${ALTERNATIVE_LINK} to ${ALTERNATIVE_LINK}.old."
+ echo "warn: It should be empty but probably isn't!"
+ echo "warn: Check what's left there and remove it manually."
+ mv -f ${ALTERNATIVE_LINK} ${ALTERNATIVE_LINK}.old
+ fi
+}
diff --git a/recipes/obsolete/shr/libframeworkd-phonegui-efl2_git.bb b/recipes/obsolete/shr/libframeworkd-phonegui-efl2_git.bb
new file mode 100644
index 0000000000..9d4d74e90f
--- /dev/null
+++ b/recipes/obsolete/shr/libframeworkd-phonegui-efl2_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "frameworkd EFL phonegui 2"
+SECTION = "e/apps"
+DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui etk evas ecore edje edje-native elementary"
+PV = "0.0.1+gitr${SRCREV}"
+PR = "r2"
+
+SRCREV = "917226025c67b75def91e98ea923c2e550474a5b"
+SRC_URI = "git://shr.bearstech.com/repo/libframeworkd-phonegui-efl2.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig autotools autotools_stage
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+
+do_configure_prepend() {
+ autopoint --force
+}
+
diff --git a/recipes/obsolete/shr/libframeworkd-phonegui-efl_git.bb b/recipes/obsolete/shr/libframeworkd-phonegui-efl_git.bb
new file mode 100644
index 0000000000..34f96923f5
--- /dev/null
+++ b/recipes/obsolete/shr/libframeworkd-phonegui-efl_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "frameworkd EFL phonegui"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "e/apps"
+DEPENDS += " dbus-glib libframeworkd-glib libframeworkd-phonegui etk evas ecore edje edje-native elementary"
+PV = "0.0.3+gitr${SRCREV}"
+PR = "r36"
+
+require libframeworkd-phonegui-efl-theme.inc
+
+inherit pkgconfig autotools autotools_stage
+
+SRCREV = "9d7ca1cecb93022e5b890cd87756ac6f072710ca"
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+do_configure_prepend() {
+ sed -i "s|^filesdir = \$(datadir)/libframeworkd-phonegui-efl/|filesdir = \$(datadir)/libframeworkd-phonegui-efl.${PN}|g" data/Makefile.am
+ autopoint --force
+}
+
diff --git a/recipes/obsolete/shr/libframeworkd-phonegui_git.bb b/recipes/obsolete/shr/libframeworkd-phonegui_git.bb
new file mode 100644
index 0000000000..b11f0394d3
--- /dev/null
+++ b/recipes/obsolete/shr/libframeworkd-phonegui_git.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Frameworkd phonegui library"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "libs"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r10"
+
+DEPENDS="glib-2.0 dbus-glib libframeworkd-glib libphone-utils"
+
+inherit pkgconfig autotools autotools_stage
+
+SRCREV = "9d7ca1cecb93022e5b890cd87756ac6f072710ca"
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+CONFFILES_${PN} = "${sysconfdir}/frameworkd-phonegui.conf"
diff --git a/recipes/obsolete/shr/shr-contacts_git.bb b/recipes/obsolete/shr/shr-contacts_git.bb
new file mode 100644
index 0000000000..6a2283117b
--- /dev/null
+++ b/recipes/obsolete/shr/shr-contacts_git.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The SHR Contacts application"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += "dbus-glib libframeworkd-glib libframeworkd-phonegui"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r6"
+
+inherit pkgconfig autotools
+
+SRCREV = "9d7ca1cecb93022e5b890cd87756ac6f072710ca"
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
diff --git a/recipes/obsolete/shr/shr-dialer_git.bb b/recipes/obsolete/shr/shr-dialer_git.bb
new file mode 100644
index 0000000000..816f9d856c
--- /dev/null
+++ b/recipes/obsolete/shr/shr-dialer_git.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The SHR Dialer"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += "dbus-glib libframeworkd-glib libframeworkd-phonegui"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r9"
+
+inherit pkgconfig autotools
+
+SRCREV = "9d7ca1cecb93022e5b890cd87756ac6f072710ca"
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
diff --git a/recipes/obsolete/shr/shr-messages_git.bb b/recipes/obsolete/shr/shr-messages_git.bb
new file mode 100644
index 0000000000..cb8fc810d3
--- /dev/null
+++ b/recipes/obsolete/shr/shr-messages_git.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "The SHR Messages"
+HOMEPAGE = "http://shr-project.org/"
+LICENSE = "GPL"
+SECTION = "x11/applications"
+DEPENDS += "dbus-glib libframeworkd-glib libframeworkd-phonegui"
+PV = "0.0.2+gitr${SRCREV}"
+PR = "r8"
+
+inherit pkgconfig autotools
+
+SRCREV = "9d7ca1cecb93022e5b890cd87756ac6f072710ca"
+SRC_URI = "git://git.shr-project.org/repo/shr.git;protocol=http;branch=master"
+S = "${WORKDIR}/git/${PN}"
+